2 Replies Latest reply on Sep 18, 2012 4:44 PM by kaligastia

    Unable to build Jboss 7.1.2 Final from source

    kaligastia Newbie

      Hi..

       

      I'm trying to build this release for test purposes.. but there are problems with missing dependencies..

       

      The complete message is:

       

       

      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building JBoss Application Server: Build 7.1.2.Final
      [INFO] ------------------------------------------------------------------------
      [WARNING] The POM for org.jboss.as:jboss-as-client-all:jar:7.1.2.Final is missing, no dependency information available
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 3.031s
      [INFO] Finished at: Mon Sep 17 16:05:02 COT 2012
      [INFO] Final Memory: 22M/53M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal on project jboss-as-build: Could not resolve dependencies for project org.jboss.as:jboss-as-build:
      pom:7.1.2.Final: Failure to find org.jboss.as:jboss-as-client-all:jar:7.1.2.Final in http://repository.jboss.org/nexus/content/gr
      oups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-rep
      ository-group has elapsed or updates are forced -> [Help 1]
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
      
      

       

      In fact the repository doesn't exist in the nexus repo or maybe is not public..

       

      If somebody knows a workaround to this problem please share your answer..

       

      Thanks...