1 Reply Latest reply on Nov 6, 2012 12:27 PM by Nicholas DiPiazza

    JBoss Messaging 1.4.7.GA on JBoss 5.1.0.GA - cannot bind to "jaas" on startup

    Nicholas DiPiazza Novice

      Dear community,

       

      Possibly related posts:

       

       

      I'm migrating from JBoss 4.3.0.GA EAP to JBoss 5.1.0.GA EAP.

       

      This means that I am moving from JBoss Messaging 1.4.0.SP3_C10 to JBoss Messaging 1.4.7.GA.

       

      This only meant a few minor changes to the XML configuration files, so i went ahead and made those and redeployed.

       

      Namely, in jboss-messaging.sar I had to add the SecurityMetadataStore MBean:

       

         <!--  The SecurityStore mbean -->
         <mbean code="org.jboss.jms.server.security.SecurityMetadataStore"
                   name="jboss.messaging:service=SecurityStore">           
              <attribute name="DefaultSecurityConfig">
                   <security>
                        <role name="guest" read="true" write="true" create="true"/>
                   </security>
              </attribute>       
              <attribute name="SuckerPassword">XXXXXXX</attribute>  
         </mbean>
      

       

      But now when i deploy my jboss-messaging.sar (with nothing else running in the server)... on startup I get this error:

       

      12:14:41,724 ERROR [AbstractKernelController] Error installing to Start: name=jboss.messaging:service=SecurityStore state=Create mode=Manual requiredState=Installed
      javax.naming.NameNotFoundException: jaas not bound
       at org.jnp.server.NamingServer.getBinding(NamingServer.java:771)
       at org.jnp.server.NamingServer.getBinding(NamingServer.java:779)
       at org.jnp.server.NamingServer.getObject(NamingServer.java:785)
       at org.jnp.server.NamingServer.lookup(NamingServer.java:396)
      

       

      But if I go ahead and trigger the deployment after the server has fully started, I do not get this error. So in other words, there is a missing dependency not being honored here. The jboss-messaging.sar needs to wait until the /jaas resources are fully deployed.

       

      I followed the related link (above) where an individual had this exact same problem.... but I was not able to extract the solution. Any ideas?

       

      My jboss5/server/myconfig/deploy/secruity/security-jboss-beans.xml is the default one from the all configuration.

        • 1. Re: JBoss Messaging 1.4.7.GA on JBoss 5.1.0.GA - cannot bind to "jaas" on startup
          Nicholas DiPiazza Novice

          I came up with a solution.

           

          I was not able to solve this issue as it stood. The old format for jboss-messaging.sar/*.xml doesn't port to the later version.

           

          So what I did was instead of using the jboss-messaging.sar files I had working on JBoss 4.3.0.GA EAP as the starting point, I copied the JBoss 5.1.0.GA EAP's server/all/deploy/messaging into my server/customconfig/deploy/ folder.

           

          I started JBoss5, made sure it still starts up. It did.

           

          Then I just applied all the non-default settings I had in my jboss-messaging.sar/*.xml files and then applied them over to the files in server/customconfig/deploy/messaging/*

           

          The jboss messaging queues and topics are now successfully deployed.

           

          The actual problem had something to do with that fact that I was trying to specify the mbean for SecurityStore in the messaging-service.xml file as an mbean. But now I believe it is a microcontainer <bean>. So switching over to the microcontainer approach worked nicely.

           

          -Nicholas