1 2 Previous Next 20 Replies Latest reply on Aug 15, 2013 11:45 AM by Joshua Wilson

    EAP6 + Snowdrop compatible?

    _cp Newbie

      Is anyone here using EAP6 and Snowdrop with any success?

       

      I'm using EAP6 (7.1.2.Final) and Snowdrop 2.0.2.Final and JBoss fails on startup looking for a missing module: org.jboss.interceptor. This module exists in AS7 but not in EAP.

       

      Here's the exception:

      [Host Controller] Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module

      [Host Controller]       at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java

      :195) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

      [Host Controller]       at org.jboss.as.controller.parsing.ExtensionXml.access$000(ExtensionXml.java

      :68) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

      [Host Controller]       at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:126

      ) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

      [Host Controller]       at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:123

      ) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

      [Host Controller]       at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [rt.ja

      r:1.6.0_27]

      [Host Controller]       at java.util.concurrent.FutureTask.run(FutureTask.java:138) [rt.jar:1.6.0_27

      ]

      [Host Controller]       at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor

      .java:886) [rt.jar:1.6.0_27]

      [Host Controller]       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.jav

      a:908) [rt.jar:1.6.0_27]

      [Host Controller]       at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_27]

      [Host Controller]       at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.

      0.0.GA-redhat-1.jar:2.0.0.GA-redhat-1]

      [Host Controller] Caused by: org.jboss.modules.ModuleNotFoundException: Module org.jboss.interceptor

      :main is not found in local module loader @1835282 (roots: C:\Programs\jboss-eap-6.0\modules)

      [Host Controller]       at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126

      ) [jboss-modules.jar:1.1.2.GA-redhat-1]

      [Host Controller]       at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jb

      oss-modules.jar:1.1.2.GA-redhat-1]

      [Host Controller]       at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jbos

      s-modules.jar:1.1.2.GA-redhat-1]

      [Host Controller]       at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:

       

      Thanks

        • 1. Re: EAP6 + Snowdrop compatible?
          Holger L Newbie

          Hi.

           

          Did you find out how to solve this issue? I've tried copying the interceptor module from JBoss AS 7.1.1 Final however that resulted in another exception:

          java.lang.NoSuchMethodError: org.jboss.as.controller.ExtensionContext.registerSubsystem

           

          Has anyone got it working?

           

          Thanks

          • 2. Re: EAP6 + Snowdrop compatible?
            Holger L Newbie

            After downloading the EAP Snowdrop version I got it working.

            • 3. Re: EAP6 + Snowdrop compatible?
              Razvan Reff Newbie

              Hi Holger,

               

              I am facing the exact same problem. Can you please give me some details about how you got it to work ? Where did you download the EAP Snowdrop version from ? What do I have to do to get it to deploy ?

               

              Thanks a lot,

              Razvan

              • 4. Re: EAP6 + Snowdrop compatible?
                Holger L Newbie

                Hi Razvan,

                 

                I've downloaded the EAP snowdrop version from the redhat customer portal - you'll find it in the web framework kit section (JBoss Enterprise Frameworks -> Web Framework Kit). After the the exception above was resolved. Otherwise I was pretty much following the Snowdrop User Guide also available on the red hat portal.

                 

                Hope this helps.

                • 5. Re: EAP6 + Snowdrop compatible?
                  Marius Bogoevici Expert

                  OK folks, sorry for this.

                   

                  We have a 2.0.4.Final release which has been on since ages, but for whatever reason, the downloads page update has failed.

                   

                  I'll update it ASAP.

                  • 6. Re: EAP6 + Snowdrop compatible?
                    Marius Bogoevici Expert

                    Ok, it's up now. Sorry for the troubles you had. This has been up for a couple of months.

                    • 7. Re: EAP6 + Snowdrop compatible?
                      Razvan Reff Newbie

                      Hi there!

                       

                      Thank you for your quick response!

                       

                      However, I am still having trouble with this issue.

                       

                      After the latest update, the download link to the JBoss AS 7(with spring modules) version of Snowdrop http://downloads.jboss.org/snowdrop/2.0.4.Final/jboss-spring-subsystem-as7-2.0.4.Final.zip doesn't seem to work.

                       

                      Can you help me with this ?

                       

                      Thank you,

                      Razvan

                      • 8. Re: EAP6 + Snowdrop compatible?
                        Marius Bogoevici Expert

                        Hi Razvan,

                         

                        Sorry, the file name got mangled on upload. Try now, should be fixed.

                        • 9. Re: EAP6 + Snowdrop compatible?
                          Razvan Reff Newbie

                          Hi Marius,

                           

                          Thanks for fixing the link. However, I've ran into this new issue after installing snowdrop on JBoss:

                           

                          10:27:04,178 INFO  [org.jboss.modules] JBoss Modules version 1.1.2.GA-redhat-1

                          10:27:04,736 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA-redhat-1

                          10:27:04,854 INFO  [org.jboss.as] JBAS015899: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) starting

                          10:27:07,031 ERROR [org.jboss.as.controller.management-operation] JBAS014612: Operation ("parallel-extension-add") failed - address: ([]): java.lang.RuntimeException: JBAS014670: Failed initializing module org.jboss.snowdrop

                                  at org.jboss.as.controller.extension.ParallelExtensionAddHandler$1.execute(ParallelExtensionAddHandler.java:99) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:397) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:284) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.AbstractOperationContext.completeStep(AbstractOperationContext.java:211) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.ModelControllerImpl.boot(ModelControllerImpl.java:156) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.AbstractControllerService.boot(AbstractControllerService.java:191) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.server.ServerService.boot(ServerService.java:295) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.server.ServerService.boot(ServerService.java:270) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:156) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at java.lang.Thread.run(Unknown Source) [rt.jar:1.7.0_07]

                          Caused by: java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: org.jboss.as.controller.ExtensionContext.registerSubsystem(Ljava/lang/String;)Lorg/jboss/as/controller/SubsystemRegistration;

                                  at java.util.concurrent.FutureTask$Sync.innerGet(Unknown Source) [rt.jar:1.7.0_07]

                                  at java.util.concurrent.FutureTask.get(Unknown Source) [rt.jar:1.7.0_07]

                                  at org.jboss.as.controller.extension.ParallelExtensionAddHandler$1.execute(ParallelExtensionAddHandler.java:91) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  ... 9 more

                          Caused by: java.lang.NoSuchMethodError: org.jboss.as.controller.ExtensionContext.registerSubsystem(Ljava/lang/String;)Lorg/jboss/as/controller/SubsystemRegistration;

                                  at org.jboss.spring.deployers.as7.SpringExtension.initialize(SpringExtension.java:93)

                                  at org.jboss.as.controller.extension.ExtensionAddHandler.initializeExtension(ExtensionAddHandler.java:99) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.extension.ParallelExtensionAddHandler$ExtensionInitializeTask.call(ParallelExtensionAddHandler.java:127) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at org.jboss.as.controller.extension.ParallelExtensionAddHandler$ExtensionInitializeTask.call(ParallelExtensionAddHandler.java:113) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]

                                  at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) [rt.jar:1.7.0_07]

                                  at java.util.concurrent.FutureTask.run(Unknown Source) [rt.jar:1.7.0_07]

                                  at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [rt.jar:1.7.0_07]

                                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [rt.jar:1.7.0_07]

                                  at java.lang.Thread.run(Unknown Source) [rt.jar:1.7.0_07]

                                  at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.0.0.GA-redhat-1.jar:2.0.0.GA-redhat-1]

                           

                          10:27:07,050 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.

                          10:27:07,076 INFO  [org.jboss.as] JBAS015950: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) stopped in 5ms

                           

                          Any ideas on what may cause this?

                           

                          Thank you,

                          Razvan

                          • 10. Re: EAP6 + Snowdrop compatible?
                            Marius Bogoevici Expert

                            Hi Razvan,

                             

                            You're right, this is an issue with 2.0.4.Final which we have fixed only in the product version of Snowdrop. We'll do a quick release to take care of this tomorrow.

                            • 11. Re: EAP6 + Snowdrop compatible?
                              Razvan Reff Newbie

                              Hi Marius,

                               

                              Any news on this issue ? Can you please tell me what to do to (finally) make it work ?

                               

                              Thank you,
                              Razvan

                              • 12. Re: EAP6 + Snowdrop compatible?
                                Razvan Reff Newbie

                                Hi guys,

                                 

                                Time passes and there's still no news on this subject. Am I the only one trying to use latest version of snowdrop?

                                Can anyone please help me out here ? Will this ever be fixed, or should I call it quits and find a different option (one that works).

                                 

                                Many thanks,

                                Razvan

                                • 13. Re: EAP6 + Snowdrop compatible?
                                  Holger L Newbie

                                  Hi Razavan,

                                   

                                  Are you using JBoss AS7 or JBoss EAP6? If you use EAP6 you will also need to use the RedHat snowdrop libs (see my post above) since there seem to be some differences. I have not tried AS7. Sorry to be not more of help.

                                   

                                  Holger

                                  • 14. Re: EAP6 + Snowdrop compatible?
                                    Darryl Miles Novice

                                    Any chance of that updated release, your comment indicates that 2.0.4.Final is not recent enough for using with EAP 6.1 implying that 2.0.5.Final will be needed.

                                     

                                    What is required to work with Spring Framework 3.2.2.RELEASE I have created a module (moving the spring-asm which has been wrapped into spring-core now http://www.springsource.org/node/3654 ).

                                     

                                    Also is there any harm to be adding: spring-aspects spring-jdbc spring-orm spring-tx and spring-webmvc  to my own module.xml

                                     

                                     

                                    UPDATE: Created ticket https://issues.jboss.org/browse/SNOWDROP-66

                                     

                                    UPDATE2: I have just attached a ZIP file to the ticket which a built from git version.  Those those wishing to build their own here is a useful thread with information https://community.jboss.org/thread/204189 "Instructions on how to build snowdrop project"

                                    1 2 Previous Next