4 Replies Latest reply on Nov 19, 2013 9:29 AM by Jochen Cordes

    Error while starting server with JAVA 7

    Ankit Chaudhari Newbie

      Hello,

       

      I'm using JBoss EAP 5.1.0 Server using Java jdk 7.

       

      All code compiles well but when the server starts, it spits out an error

       

      Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/bootstrap/BaseServerConfig

                at org.jboss.bootstrap.AbstractServerImpl.doInit(AbstractServerImpl.java:190)

                at org.jboss.bootstrap.AbstractServerImpl.init(AbstractServerImpl.java:173)

                at org.jboss.bootstrap.AbstractServerImpl.init(AbstractServerImpl.java:143)

                at org.jboss.Main.boot(Main.java:218)

                at org.jboss.Main$1.run(Main.java:556)

                at java.lang.Thread.run(Unknown Source)

      Caused by: java.lang.ClassNotFoundException: org.jboss.bootstrap.BaseServerConfig

                at java.net.URLClassLoader$1.run(Unknown Source)

                at java.net.URLClassLoader$1.run(Unknown Source)

                at java.security.AccessController.doPrivileged(Native Method)

                at java.net.URLClassLoader.findClass(Unknown Source)

                at java.lang.ClassLoader.loadClass(Unknown Source)

                at java.lang.ClassLoader.loadClass(Unknown Source)

                ... 6 more

       

      After doing some research over the problem i realized an exact problem tracked in this link ->

      https://issues.jboss.org/browse/JBBOOT-138

       

      I'd appreciate if anyone could please point me direction on how to get this fixed?

       

      Thanks,

      A