1 2 Previous Next 15 Replies Latest reply on Oct 2, 2016 6:19 AM by masoud jabbarvand

    Not able to hit the end point of my service

    Put Time Newbie

      I'm using switchyard 0.8.0, on jBoss dev studio (Eclipse).

       

      I followed the video episode 6 tutorial. And repeated the steps as is.

      Everything works fine, the project builds, the unit tests run correctly, the package gets deployed on the server.

       

      But when I hit the end point from either browser or SoapUI, I keep getting the "end point not found"  error.

      The actual error is this:

      HTTP Status 404 - /episode6b/Payments


      type Status report

      message /episode6b/Payments

      description The requested resource (/episode6b/Payments) is not available.


      JBoss Web/7.0.13.Final

       

       

       

      Is there any check list that will help me solve this problem.

       

      I have tried the steps at least 10 times, and every time the result is the same.

        • 1. Re: Not able to hit the end point of my service
          Keith Babo Master

          Check out the console or server log for your AS 7 server after you deploy the application and you should see something like this:

           

          07:12:01,900 INFO  [org.jboss.wsf.stack.cxf.metadata.MetadataBuilder] (MSC service thread 1-15) Add Service

          id=org.switchyard.component.soap.endpoint.BaseWebService

          address=http://localhost:8080/quickstart-bean/OrderService

          implementor=org.switchyard.component.soap.endpoint.BaseWebService

          invoker=org.jboss.wsf.stack.cxf.JBossWSInvoker

          serviceName={urn:switchyard-quickstart:bean-service:1.0}OrderService

          portName={urn:switchyard-quickstart:bean-service:1.0}OrderServicePort

          wsdlLocation=vfs:/content/switchyard-quickstart-bean-service.jar/wsdl/OrderService.wsdl

          mtomEnabled=false

           

          The above is based on the bean-service quickstart, so the actual context path and service name will be different for you.

          • 2. Re: Not able to hit the end point of my service
            Put Time Newbie

            That worked! Thanks.

            Now the end point works, well, at least I get back a HTTP 200 reply.

            Here's the reply:

            HTTP/1.1 200 OK

            Server: Apache-Coyote/1.1

            Content-Length: 0

            Date: Wed, 03 Apr 2013 12:24:15 GMT

             

             

            Another question, the content length is supposed to be not zero at least.

            Another thing, in the service, I actually do a System.out, so at least I should see that happening.

            If it is indeed getting printed, I need to be able to see it.

             

            Where can I see server logs?

            • 3. Re: Not able to hit the end point of my service
              David Ward Master

              A System.out.println should, by default, show up in your console.  If it doesn't, either 1) your code is not getting invoked, or 2) logging configuration has changed.  Server logs, by default, can be found in switchyard-as7-0.8/standalone/log/.

               

              You also have the option of starting jboss in debug mode, and attach to it with your IDE to remote debug.  To do this, you can add the following to your bin/standalone.conf start up options:

              -Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=1044

              • 4. Re: Not able to hit the end point of my service
                Put Time Newbie

                Ok, I got to know where the logs were.

                There was actually some problem in soap XML.

                I corrected it and it works now.

                 

                As an extension to this, I want to return a SOAP reply XML, i.e. the result.

                Can you point me towards this?

                 

                i.e. how can I return a SOAP reply XML back to the caller?

                 

                Thanks

                • 5. Re: Not able to hit the end point of my service
                  David Ward Master

                  Your WSDL interface needs to define this, so that your switchyard exchange pattern is in_out vs. in_only. Then, your service implementation needs to actually return something. Finally, you might need to regsiter transformers to turn your response into xml.  This is all very basic, and switchyard includes many quickstarts which showcase this.  I suggest you start there.

                   

                  Try looking through this code first:

                  https://github.com/jboss-switchyard/quickstarts/tree/0.8.0.Final/bean-service

                  • 6. Re: Not able to hit the end point of my service
                    imen barouni Newbie

                    Hello,

                    Keith Babo

                     

                    I've got the exact same problem listed here (for the tutorial of the video N°6).

                    in addition to that ther is no trace of deploying my wsdl on the server's console.

                    here is what i have in the console after running my application in the server:

                    04:08:36,563 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss AS 7.1.1.Final "Brontes" started in 4633ms - Started 173 of 302 services (128 services are passive or on-demand)

                    04:08:50,607 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "switchyard-example.jar"

                    04:08:50,720 INFO  [org.jboss.weld.deployer] (MSC service thread 1-6) JBAS016002: Processing weld deployment switchyard-example.jar

                    04:08:50,751 INFO  [org.jboss.weld.deployer] (MSC service thread 1-3) JBAS016005: Starting Services for CDI deployment: switchyard-example.jar

                    04:08:50,810 INFO  [org.jboss.weld.Version] (MSC service thread 1-3) WELD-000900 1.1.6 (Final)

                    04:08:50,848 INFO  [org.jboss.weld.deployer] (MSC service thread 1-1) JBAS016008: Starting weld service for deployment switchyard-example.jar

                    04:08:51,269 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "switchyard-example.jar"

                    • 7. Re: Not able to hit the end point of my service
                      Magesh Bojan Master

                      Hi Imen,

                       

                      Looks like the server instance where the application is deployed doesn't have SwitchYard installed on it. Could you post the complete server.log of this server to confirm?

                       

                      thanks,

                      Magesh

                      • 8. Re: Not able to hit the end point of my service
                        imen barouni Newbie

                        Hello Magech,

                         

                        You were right about the server, i replaced it, but there is anothor problem.

                        actually, i tested my wsdl without the server. this way:

                        Nouvelle image bitmap.bmp

                        but when i tried to "run" my service here is the error i get:

                        Nouvelle image bitmap.bmp

                         

                        now, when i run the server and deploy my project on the server:

                        1- this is what i've got on the console (it's a successful deployment):

                        07:07:45,838 INFO  [org.jboss.wsf.stack.cxf.metadata.MetadataBuilder] (MSC service thread 1-3) Add Service

                        id=org.switchyard.component.soap.endpoint.BaseWebService

                        address=http://localhost:8080/Payements/Payements

                        implementor=org.switchyard.component.soap.endpoint.BaseWebService

                        invoker=org.jboss.wsf.stack.cxf.JBossWSInvoker

                        serviceName={urn:com.example.switchyard:switchyard-example:1.0}Payements

                        portName={urn:com.example.switchyard:switchyard-example:1.0}PayementsPort

                        wsdlLocation=vfs:/C:/tools/serveur/switchyard-as7-0.8/bin/content/switchyard-example.jar/Payements.wsdl

                        mtomEnabled=false

                        07:07:47,539 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (MSC service thread 1-3) Creating Service {urn:com.example.switchyard:switchyard-example:1.0}Payements from WSDL: vfs:/C:/tools/serveur/switchyard-as7-0.8/bin/content/switchyard-example.jar/Payements.wsdl

                        07:07:48,501 INFO  [org.apache.cxf.endpoint.ServerImpl] (MSC service thread 1-3) Setting the server's publish address to be http://localhost:8080/Payements/Payements

                        07:07:48,649 INFO  [org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher] (MSC service thread 1-3) WSDL published to: file:/C:/tools/serveur/switchyard-as7-0.8/standalone/data/wsdl/Payements.deployment/Payements.wsdl

                        07:07:48,683 INFO  [org.jboss.ws.common.management.DefaultEndpointRegistry] (MSC service thread 1-3) register: jboss.ws:context=Payements,endpoint=org.switchyard.component.soap.endpoint.BaseWebService

                        07:07:49,009 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "switchyard-example.jar"

                         

                        2- this is what i've got when i try to access my web service throught the web brouser:

                        Nouvelle image bitmap.bmp

                        3- when i access the administration interface of jboss:

                        a- this is what i'v got in (switchyard->runtime)

                        Nouvelle image bitmap.bmp

                        b- this is what i've got on (webservices):

                        Nouvelle image bitmap.bmp

                        clearely something is wrong, my web service is successfully deployed, jboss is seeing it as a service but there is no trace of it as an end point.

                         

                        could you please tell me what's wrong?

                         

                        thank you

                        • 9. Re: Not able to hit the end point of my service
                          Magesh Bojan Master

                          Hi Imen,

                           

                          Your service has been deployed properly and you are able to hit the service. To test with the Webservices explorer, you will have to first start the server, which you have done. Now you might also notice that the WSDL in your project has an endpoint address as http://localhost:8080/switchyard-example/Payements, but has been publised in the server as http://localhost:8080/Payements/Payements. By just hitting this address nothing is going to happen, except for the error message as seen in 2. You can see the published WSDL at this address http://localhost:8080/Payements/Payements?wsdl. Using this you can test in soapUI or other client.

                           

                          The issue of the server publishing to a different address has been solved via this JIRA, so if you use version 1.0 then that should not be there anymore.

                           

                          https://issues.jboss.org/browse/SWITCHYARD-1428

                           

                          The Webservices admin screen not showing the endpoint is something the Webservices team need to look into. Thanks for pointing that out. I have created a JIRA to investigate this for our next release.

                           

                          https://issues.jboss.org/browse/SWITCHYARD-1615

                           

                          regards,

                          Magesh

                          • 10. Re: Not able to hit the end point of my service
                            imen barouni Newbie

                            Hi Magesh,

                            thank you so much for your help. I am really grateful.

                            • 11. Re: Not able to hit the end point of my service
                              imen barouni Newbie

                              Hello Magesh,

                               

                              Where can i get the version 1.0 of the server please?

                              i downloaded the one i was working with from this link: http://www.jboss.org/switchyard/downloads.html.

                              it's this one: Nouvelle image bitmap.bmp

                              but when you asked me to download the version 1.0 to fix my problem, i selected v1.0.Final on the list at the buttom of the same page.

                              so, i downloaded; switchyard-1.0.0.Final-EAP6.1.GA.zip but it isn't a server. here is a snapshot of it's contant:

                              Nouvelle image bitmap.bmp

                               

                              thank you

                              • 12. Re: Not able to hit the end point of my service
                                Magesh Bojan Master

                                Hi Imen,

                                 

                                We haven't released the binaries yet, officially. But that is the one you need to use. You should overlay this binary on top of EAP 6.1.0.Final from here:

                                 

                                http://www.jboss.org/jbossas/downloads/

                                 

                                You can also use the installer if you may like.

                                • 13. Re: Not able to hit the end point of my service
                                  Amit Gulhane Newbie

                                  Hi Keith,

                                   

                                  I am getting the exact problem where my webservice is getting wrongly published as basewebservice, as below.

                                   

                                  12:06:50,143 INFO  [org.jboss.ws.cxf.metadata] (MSC service thread 1-5) JBWS024061: Adding service endpoint metadata: id=org.switchyard.component.soap.endpoint.BaseWebService

                                  address=http://localhost:8080/ICO029_Dispatch_eWS/BaseWebService

                                  implementor=org.switchyard.component.soap.endpoint.BaseWebService

                                  serviceName={http://endpoint.soap.component.switchyard.org/}BaseWebServiceService

                                  portName={http://endpoint.soap.component.switchyard.org/}BaseWebServicePort

                                  annotationWsdlLocation=null

                                  wsdlLocationOverride=null

                                  mtomEnabled=false

                                   

                                  I am not sure how my webservice is getting replaced with basewebservice...please help with the same...

                                  Thanks

                                  • 14. Re: Not able to hit the end point of my service
                                    Magesh Bojan Master

                                    Hi Amit,

                                     

                                    Are you using old SwitchYard still? Can you upgrade to latest version?

                                    1 2 Previous Next