4 Replies Latest reply on Apr 24, 2013 6:28 AM by Marek Goldmann

    Can't currently boxgrind a boxgrinder-meta appliance from Git

    Tony Sweeney Newbie

      I'm trying to boxgrind a slightly customized boxgrinder-meta appliance.  Unfortunately the base appliance from git no longer builds correctly since yesterday (18-Apr-2013).  I suspect it may be a problem with the Fedora repositories.  The error from the log is:

       

      D, [2013-04-19T15:08:01.872217 #6506] DEBUG -- : Mounting /dev/loop02 at /images/jenkins/boxgrinder-meta/workspace/build/appliances/x86_64/fedora/17/boxgrinder-meta/1.9/fedora-plugin/tmp/imgcreate-qA9LWD/install_root/

      D, [2013-04-19T15:08:01.911645 #6506] DEBUG -- : Writing mkinitrd config /images/jenkins/boxgrinder-meta/workspace/build/appliances/x86_64/fedora/17/boxgrinder-meta/1.9/fedora-plugin/tmp/imgcreate-qA9LWD/install_root/etc/sysconfig/mkinitrd

      D, [2013-04-19T15:08:02.503341 #6506] DEBUG -- : Retrieving http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux/releases/17/Everything/x86_64/os/repodata/repomd.xml ...OK

      D, [2013-04-19T15:08:07.552758 #6506] DEBUG -- : Retrieving http://mirror.bytemark.co.uk/fedora/linux/updates/17/x86_64/repodata/repomd.xml ...OK

      D, [2013-04-19T15:08:11.636191 #6506] DEBUG -- : Retrieving http://mirror.bytemark.co.uk/fedora/linux/updates/17/x86_64/repodata/1aa05fb28887472a81e7a8f76e1f8a5b72a15af1ac41ca51d7ca9ee8779bdbe3-primary.sqlite.bz2 ...OK

      D, [2013-04-19T15:08:19.580575 #6506] DEBUG -- : Retrieving http://mirror.bytemark.co.uk/fedora/linux/updates/17/x86_64/repodata/79cc4ddbc187abfa2728c7116cbb3b42297426041c2bc7d0c170cb0e5bf45e85-filelists.sqlite.bz2 ...OK

      D, [2013-04-19T15:08:22.878209 #6506] DEBUG -- : ['/', 'biosboot']

      D, [2013-04-19T15:08:22.878328 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:23.360455 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:23.556152 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:23.664214 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:23.789705 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:23.829712 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:23.857422 #6506] DEBUG -- : Package febootstrap-supermin-helper is obsoleted by supermin-helper, but obsoleting package does not provide for requirements

      D, [2013-04-19T15:08:24.020095 #6506] DEBUG -- : Unable to create appliance : Failed to build transaction : 1:libguestfs-1.18.11-2.fc17.x86_64 requires febootstrap-supermin-helper >= 3.3

      D, [2013-04-19T15:08:24.043521 #6506] DEBUG -- : Unmounting directory /images/jenkins/boxgrinder-meta/workspace/build/appliances/x86_64/fedora/17/boxgrinder-meta/1.9/fedora-plugin/tmp/imgcreate-qA9LWD/install_root/

      D, [2013-04-19T15:08:24.053198 #6506] DEBUG -- : Removing compat symlinks

      D, [2013-04-19T15:08:24.053292 #6506] DEBUG -- : Unmapping /dev/loop0

      D, [2013-04-19T15:08:24.063434 #6506] DEBUG -- : Losetup remove /dev/loop0

      E, [2013-04-19T15:08:24.135690 #6506] ERROR -- : /usr/lib/ruby/gems/1.8/gems/boxgrinder-core-0.3.12/lib/boxgrinder-core/helpers/exec-helper.rb:85:in `execute'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/plugins/os/rpm-based/rpm-based-os-plugin.rb:107:in `execute_appliance_creator'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/plugins/os/rpm-based/rpm-based-os-plugin.rb:71:in `build_with_appliance_creator'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/plugins/os/fedora/fedora-plugin.rb:53:in `execute'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/plugins/base-plugin.rb:172:in `run'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/appliance.rb:184:in `execute_plugin'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/appliance.rb:207:in `execute_without_userchange'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/appliance.rb:129:in `execute_plugin_chain'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/appliance.rb:125:in `each'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/appliance.rb:125:in `execute_plugin_chain'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/lib/boxgrinder-build/appliance.rb:164:in `create'

      /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.10.2/bin/boxgrinder-build:203

      /usr/bin/boxgrinder-build:19:in `load'

      /usr/bin/boxgrinder-build:19

      F, [2013-04-19T15:08:24.135853 #6506] FATAL -- : RuntimeError: An error occurred while executing command: 'appliance-creator -d -v -t 'build/appliances/x86_64/fedora/17/boxgrinder-meta/1.9/fedora-plugin/tmp' --cache=/var/cache/boxgrinder/rpms-cache/x86_64/fedora/17 --config 'build/appliances/x86_64/fedora/17/boxgrinder-meta/1.9/fedora-plugin/tmp/boxgrinder-meta.ks' -o 'build/appliances/x86_64/fedora/17/boxgrinder-meta/1.9/fedora-plugin/tmp' --name 'boxgrinder-meta' --vmem 1024 --vcpu 1 --format raw', process exited with wrong exit status: 1