1 2 Previous Next 15 Replies Latest reply on Sep 24, 2014 7:01 PM by Jose Miguel Loor

    Error while starting JBoss Fuse

    Anirban Gupta Newbie

      Hi,

       

      I am getting the following error while trying to start JBoss Fuse 6.0.0.

       

      Exception in thread "JMX Connector Thread [service:jmx:rmi://0.0.0.0:44444/jndi/rmi://0.0.0.0:1099/karaf-root]" java.lang.RuntimeException: Could not start JMX connector server

                at org.apache.karaf.management.ConnectorServerFactory$1.run(ConnectorServerFactory.java:252)

      Caused by: java.io.IOException: Cannot bind to URL [rmi://0.0.0.0:2000/karaf-root]: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: 0.0.0.0; nested exception is:

                java.net.ConnectException: Connection timed out: connect]

                at javax.management.remote.rmi.RMIConnectorServer.newIOException(Unknown Source)

                at javax.management.remote.rmi.RMIConnectorServer.start(Unknown Source)

                at org.apache.karaf.management.ConnectorServerFactory$1.run(ConnectorServerFactory.java:239)

      Caused by: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: 0.0.0.0; nested exception is:

                java.net.ConnectException: Connection timed out: connect]

                at com.sun.jndi.rmi.registry.RegistryContext.bind(Unknown Source)

                at com.sun.jndi.toolkit.url.GenericURLContext.bind(Unknown Source)

                at javax.naming.InitialContext.bind(Unknown Source)

                at javax.management.remote.rmi.RMIConnectorServer.bind(Unknown Source)

                ... 2 more

      Caused by: java.rmi.ConnectException: Connection refused to host: 0.0.0.0; nested exception is:

                java.net.ConnectException: Connection timed out: connect

                at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)

                at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)

                at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)

                at sun.rmi.server.UnicastRef.newCall(Unknown Source)

                at sun.rmi.registry.RegistryImpl_Stub.bind(Unknown Source)

                ... 6 more

      Caused by: java.net.ConnectException: Connection timed out: connect

                at java.net.DualStackPlainSocketImpl.connect0(Native Method)

                at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)

                at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)

                at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)

                at java.net.AbstractPlainSocketImpl.connect(Unknown Source)

                at java.net.PlainSocketImpl.connect(Unknown Source)

                at java.net.SocksSocketImpl.connect(Unknown Source)

                at java.net.Socket.connect(Unknown Source)

                at java.net.Socket.connect(Unknown Source)

                at java.net.Socket.<init>(Unknown Source)

                at java.net.Socket.<init>(Unknown Source)

                at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(Unknown Source)

                at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(Unknown Source)

       

      Please help.

       

      I am new to JBoss Fuse and using all the default configurations. No services are currently running on port 1099 and I even tried to start JBoss Fuse by changing rmi port to some other value but its giving the same error.

       

      Regards,

      Anirban.

                ... 11 more

        • 1. Re: Error while starting JBoss Fuse
          Freeman(Yue) Fang Master

          Hi,

           

          This is generally caused by that your firewall/network configuration that prevent to bind to ip "0.0.0.0", you need change your firewall/network configuration or edit $JBOSS_FUSE/etc/org.apache.karaf.management.cfg, chang the "0.0.0.0" to "127.0.0.1" or your real IP.

           

          Freeman

          • 2. Re: Error while starting JBoss Fuse
            Anirban Gupta Newbie

            Hi,

             

            I changed the IP address to 127.0.0.1 and it is now giving me

             

            Error connecting 0.0.0.0:8101 : SSH client error: java.net.ConnectException: Connection timed out: connect

             

             

            Error connecting 0.0.0.0:8101 : SSH client error: java.net.ConnectException: Con

            nection timed out: connect

             

             

            Error connecting 0.0.0.0:8101 : SSH client error: java.net.ConnectException: Con

            nection timed out: connect

             

            I am trying to start up JBoss Fuse from Fuse IDE. Is there any place where I have to increse the startup time?

             

            Regards,

            Anirban.

            • 3. Re: Error while starting JBoss Fuse
              Freeman(Yue) Fang Master

              Hi,

               

              This is not the timeout issue, this is still your firewall/network issue which prevent to bind to address "0.0.0.0", the changes I mentioned

              resolved the  problem in JMX, you also need change $JBOSS_FUSE/etc/org.apache.karaf.shell.cfg, change

              sshHost=0.0.0.0

              to

              sshHost=127.0.0.1

               

              to resolver similar issue in SSH server

              Freeman

              1 of 1 people found this helpful
              • 4. Re: Error while starting JBoss Fuse
                Anirban Gupta Newbie

                Hi,

                Another error, can you kindly say for the below error, which xml should I change?

                Error connecting 0.0.0.0:8101 : I/O exception occurred: proxy error: Tunnel or S
                SL Forbidden

                Error connecting 0.0.0.0:8101 : I/O exception occurred: proxy error: Tunnel or S
                SL Forbidden

                Error connecting 0.0.0.0:8101 : I/O exception occurred: proxy error: Tunnel or S
                SL Forbidden

                Regards,

                Anirban.

                • 5. Re: Error while starting JBoss Fuse
                  dako ak Newbie

                  Almost all config parameter can be changed in folder "$JBOSS_FUSE/etc".

                  I would search in all files of this folder by this port number (8101).

                  1 of 1 people found this helpful
                  • 6. Re: Error while starting JBoss Fuse
                    Anirban Gupta Newbie

                    Ok Thanks to both of you, the ESB is starting up fine now. Now I want to deploy a sample application to the fuse ESB. I created a new Fuse IDE project using spring (say camel-spring), created an OSGI bundle and deployed the OSGI. Now i will have to deploy a feature right? I created a feature following the instructions given in the link:

                     

                    http://fusesource.com/docs/esb/4.4.1/esb_deploy_osgi/DeployFeatures-Deploy.html

                     

                    and it worked. But I just want to ask is these the only ways of deploying? These involves a lot of manual work like modifying the features.xml going to console, executing the commands features:addUrl, features:refreshUrl, features:install. Isn't there an easy way of deploying like what we generally do in application servers (right click on application -> Deploy To). Followng the above procedure to deploy features, we will have to do lots of manual work for every small change in our project.

                     

                    Also can you kindly say what is the best practice for developing routes, using Java DSL or Spring DSL?

                     

                    Regards,

                    Anirban.

                    • 7. Re: Error while starting JBoss Fuse
                      Freeman(Yue) Fang Master

                      Hi,

                       

                      About the feature deployment, it's probably a little bit more work when you first time to write that features descriptor, but

                      it's really convenient when it's available there, it's very good way to manage your bundles/dependencies, especially when your

                      application become larger.

                       

                      If you only have a single bundle and don't have other dependencies, you can also use

                      osgi:install -s groudId/artifacitId/version

                      to install the bundle, or simply drop that bundle in

                      $JBOSS_FUSE/deploy

                      folder, that's more easy, but not a good way to manage the complex applications.

                       

                      Freeman

                       

                       

                      • 8. Re: Error while starting JBoss Fuse
                        Anirban Gupta Newbie

                        And can you kindly say using which DSL of Camel would be a good option to start developing our application in, Spring DSL or Java DSL? I have went through some literatures on this topic and I think that using Spring DSL would be better. Still what are the best practices?

                         

                        Regards,

                        Anirban.

                        • 9. Re: Error while starting JBoss Fuse
                          Freeman(Yue) Fang Master

                          Hi,

                           

                          My answer is  it depends which way you are more comfortable with, take a look at related discussion[1], you actually can search more discussion about this question.

                           

                          [1]http://camel.465427.n5.nabble.com/Spring-vs-Java-DSL-td4903423.html

                           

                          Freeman

                          • 10. Re: Error while starting JBoss Fuse
                            Anirban Gupta Newbie

                            I frequently get this error while starting JBoss Fuse from Fuse IDE:

                             

                            Error connecting 0.0.0.0:8101 : SSH client error: java.net.ConnectException:
                            Con
                            nection refused: connect

                             

                            Error connecting 0.0.0.0:8101 : SSH client error: java.net.ConnectException:
                            Con
                            nection refused: connect

                             

                            Error connecting 0.0.0.0:8101 : SSH client error: java.net.ConnectException:
                            Con
                            nection refused: connect

                             

                            Can you please say what causes this error and what may be the solutions?

                             

                            Regards,

                            Anirban.

                            • 11. Re: Error while starting JBoss Fuse
                              Willem Jiang Newbie

                              Can you check if this port is used by other program?

                              localhost:8101 is the zookeeper server default address which will be used.

                              • 12. Re: Error while starting JBoss Fuse
                                Anirban Gupta Newbie

                                No it is not used, what I do as a workaround i delete the .ssh directory from Users folder (Windows 7) and restart the server. Then it ask for creating a new certificate and I go on clicking ok and everything works fine. But want to know the reason of this error.

                                • 13. Re: Error while starting JBoss Fuse
                                  Freeman(Yue) Fang Master

                                  Hi,

                                   

                                  This kind of error generally means in your .ssh/known_hosts, the [localhost]:8101 bind to a out-of-data cert(you probably install other version of FUSE ESB),  you can simply remove single [localhost]:8101 line from .ssh/known_hosts to remove this old cache if you switch between FUSE ESB.

                                   

                                  Freeman

                                  • 14. Re: Error while starting JBoss Fuse
                                    Jose Miguel Loor Apprentice

                                    I have changed the org.apache.karaf.management.cfg file like this:

                                     

                                    rmiRegistryHost = 0.0.0.0 to rmiRegistryHost = 192.168.0.242

                                     

                                    and

                                     

                                    serviceUrl = service:jmx:rmi://0.0.0.0:${rmiServerPort}/jndi/rmi://${rmiRegistryHost}:${rmiRegistryPort}/karaf-${karaf.name}

                                    to

                                    serviceUrl = service:jmx:rmi://192.168.0.242:${rmiServerPort}/jndi/rmi://${rmiRegistryHost}:${rmiRegistryPort}/karaf-${karaf.name}

                                     

                                    and then i get this error:

                                     

                                    Error executing command: java.net.MalformedURLException: Bad host: "192.168.0.24242"

                                    1 2 Previous Next