3 Replies Latest reply on Jul 17, 2013 3:53 PM by Ramesh Reddy

    Getting error while starting JBoss 7.1.1 with Teiid 8.4

    tanmoypalit Newbie

      Hi,

      I am getting the following error when I am trying to start JBoss Server 7.1.1.final with Teiid 8.4  (standalone-teiid.xml)

       

      13:39:05,368 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA 13:39:05,524 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA 13:39:05,568 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting 13:39:05,857 ERROR [org.jboss.as.server] JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration           at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]           at org.jboss.as.server.ServerService.boot(ServerService.java:266) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]           at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:155) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]           at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_33] Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[3,1] Message: Unexpected element '{urn:jboss:domain:1.4}server'           at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:108) [staxmapper-1.1.0.Final.jar:1.1.0.Final]           at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final.jar:1.1.0.Final]           at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]           ... 3 more 13:39:05,862 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details. 13:39:05,868 INFO  [org.jboss.as] JBAS015950: JBoss AS 7.1.1.Final "Brontes" stopped in 2ms

       

      But when I install Teiid 8.2 instead of 8.4, I don't get this error.

       

      Any idea why this is happening?

       

      Regards

      Tanmoy