1 Reply Latest reply on Aug 22, 2013 10:14 AM by Ramesh Reddy

    Failing to Resolve Dependencies

    devin pinkston Newbie

      Hello,

       

      I seem to be having a little bit of trouble building/deploying my teiid maven project (resource adapter from Accumulo).  I used the sample settings.xml that was posted on a blog here for using Maven, I have tried using both Intellij and Eclipse as well.  The error I receive when trying to package/deploy:

       

      Right now I am just trying to build the accumulo-api, somewhat similar to how the MongoDB api is setup.  I attached the pom.xml as well.

      The following artifacts could not be resolved: org.jboss.as:jboss-as-cli:jar:7.2.0.Alpha1-redhat-4, org.jboss.as:jboss-as-controller:jar:7.2.0.Alpha1-redhat-4: Could not find artifact org.jboss.as:jboss-as-cli:jar:7.2.0.Alpha1-redhat-4 in jboss-deprecated-repository (https://repository.jboss.org/nexus/content/repositories/deprecated/) -> [Help 1]

       

      I attached a couple files including my settings.xml, does anything stand out as being way off? 

       

      Thanks!

        • 1. Re: Failing to Resolve Dependencies
          Ramesh Reddy Master

          The 7.2.0-Alpha1 resources are not in the jboss public repos, there are in some of the redhat repos, so you need to add the following to settings.xml

           

              <profile>
                <id>jboss-eap-alpha</id>
                <repositories>
                  <repository>
                    <id>jboss-eap-alpha</id>
                    <name>JBoss EAP6.1 Alpha</name>
                    <url>http://maven.repository.redhat.com/techpreview/eap6/6.1.0.Alpha1/maven-repository/</url>
                    <layout>default</layout>
                    <releases>
                      <enabled>true</enabled>
                      <updatePolicy>never</updatePolicy>
                    </releases>
                    <snapshots>
                      <enabled>false</enabled>
                    </snapshots>
                  </repository>
                </repositories>
              </profile>
          

           

          Or you can switch Teiid version to something like 8.3.0.Final. More over the dependencies listed are not needed at all by your project, if you set up your build in such a way that you are not compiling the whole Teiid project, but just your projects.

           

          Ramesh..

          1 of 1 people found this helpful