1 Reply Latest reply on Sep 20, 2013 5:33 AM by Rakesh Balguri

    java.lang.AbstractMethodError: org.h2.jdbc.JdbcPreparedStatement.isWrapperFor(Ljava/lang/Class;)

    Rakesh Balguri Expert

      Hi all,

       

      We are trying to upgrade our application from JBoss7.1.1 to EAP 6.1 Alpha and Teiid from 8.1 to 8.5 and we are getting the following exception when we are trying to access any tables in H2.

       

      java.lang.AbstractMethodError: org.h2.jdbc.JdbcPreparedStatement.isWrapperFor(Ljava/lang/Class;)

       

      This works fine with JBoss7.1.1 and Teiid 8.1

      Can someone please suggest how to resolve this issue.