1 2 Previous Next 22 Replies Latest reply on Dec 5, 2013 2:36 AM by Jean-Frederic Clere

    HTTP 404 Not Found when try http://localhost/mod_cluster-manager

    Damith K Newbie

      I am trying to use mod_cluster and this is my first clustering experience. My apache is working fine and I see It works! page.

      but when I try to access http://localhost/mod_cluster-manager I get page not found error.

      Jboss AS 6.1.0 final

      mod_cluster version  mod_cluster-1.2.0

       

      in error_log I see below error

      [error] [client 127.0.0.1] File does not exist: C:/Documents and Settings/user/My Documents/Downloads/openlogic-mod_cluster-1.2.0-windows-ia32-bin-1/mod_cluster-1.2.0/httpd-2.2/htdocs/mod_cluster-manager

       

      Here is my httpd.conf file snipt.

       

      <IfModule ssl_module>

      SSLRandomSeed startup builtin

      SSLRandomSeed connect builtin

      </IfModule>

       

      LoadModule proxy_module modules/mod_proxy.so

      LoadModule proxy_ajp_module modules/mod_proxy_ajp.so

      #LoadModule proxy_http_module modules/mod_proxy_http.so

       

      LoadModule proxy_cluster_module modules/mod_proxy_cluster.so

       

      LoadModule manager_module modules/mod_manager.so

      LoadModule slotmem_module modules/mod_slotmem.so

      LoadModule advertise_module modules/mod_advertise.so

       

      # MOD_CLUSTER_ADDS

      # Adjust to you hostname and subnet.

      <IfModule manager_module>

        Listen 127.0.0.1:6666

        ManagerBalancerName mycluster

        <VirtualHost 127.0.0.1:6666>

      #   <Location />

      #    Order deny,allow

      #    Deny from all

      #    Allow from 127.0.0.1

      #   </Location>

          <Directory />

           Order deny,allow

           Deny from all

           Allow from 127.0.0

          

          </Directory>

       

          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

          #ServerAdvertise on http://127.0.0.1:6666

          AdvertiseFrequency 5

          #AdvertiseSecurityKey secret

          #AdvertiseGroup 224.0.1.105:23364

          EnableMCPMReceive

       

          <Location /mod_cluster-manager>

             SetHandler mod_cluster-manager

             Order deny,allow

             Deny from all

             Allow from 127.0.0

             AllowDisplay On

          </Location>

       

        </VirtualHost>

      </IfModule>

        • 1. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
          Damith K Newbie

          Ok at least I was able to view the page. with change <VirtualHost *:80>. Can anyone explain me why and how this happened? whats the relation ship with this tag?

          I see the below details now in the http://localhost/mod_cluster_manager page. but still cluster nodes are not showing.

           

          mod_cluster/1.2.0.Final

          start of "httpd.conf" configuration

          mod_proxy_cluster.c: OK

          mod_sharedmem.c: OK

          Protocol supported: AJP

          mod_advertise.c: OK

          Server: TSA-ST-9TK6NX1.xyz

          Server: TSA-ST-9TK6NX1.xyz VirtualHost: *:80

          end of "httpd.conf" configuration

           

          Auto Refresh show DUMP output show INFO output

          • 2. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
            Jean-Frederic Clere Master

            The SetHandler mod_cluster-manager is in a VirtualHost so that is normal you should have accesss to http://localhost:6666/mod_cluster-manager

            The nodes need see the advertise messages you probably have a firewall that prevent that. (See http://docs.jboss.org/mod_cluster/1.2.0/html/faq.html).

            • 3. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
              Damith K Newbie

              Hi Jean,

              Thanks for the quick revert.

              I have switch off the firewall already as I saw ppl were advised to do so. I just want to tell that I did basic Jboss configuration that is I copied the whole jboss distribution to two folders (node_1 and node_2) and start one by one. ( I changed the port to ports-default and ports-01

              I start jboss as run.bat -c all

              below is the output of the first after I start the second node. This means clustering works fine.


              [org.jboss.ha.core.framework.server.DistributedReplicantManagerImpl.DefaultPartition] I am (127.0.0.1:1099) received membershipChanged event:

              [org.jboss.ha.core.framework.server.DistributedReplicantManagerImpl.DefaultPartition] Dead members: 0 ([])

              [org.jboss.ha.core.framework.server.DistributedReplicantManagerImpl.DefaultPartition] New Members : 1 ([127.0.0.1:1199])

              [org.jboss.ha.core.framework.server.DistributedReplicantManagerImpl.DefaultPartition] All Members : 2 ([127.0.0.1:1099, 127.0.0.1:1199])

              [org.hornetq.core.server.cluster.impl.BridgeImpl] Connecting bridge sf.my-cluster.1ca73522-564c-11e3-b7f4-f01faf2ed9c4 to its destination [be832adf-564b-11e3-aa7a-f01faf2ed9c4]

              [org.hornetq.core.server.cluster.impl.BridgeImpl] Bridge sf.my-cluster.1ca73522-564c-11e3-b7f4-f01faf2ed9c4 is connected [be832adf-564b-11e3-aa7a-f01faf2ed9c4-> sf.my-cluster.1ca73522-564c-11e3-b7f4-f01faf2ed9c4]

               

               

              I have add this line in to run.conf file in each jboss node.
              JAVA_OPTS="$JAVA_OPTS -Djboss.messaging.ServerPeerID=1 -Djboss.partition.name=testPartition -Djboss.partition.udpGroup=239.255.100.100

              JAVA_OPTS="$JAVA_OPTS -Djboss.messaging.ServerPeerID=2 -Djboss.partition.name=testPartition -Djboss.partition.udpGroup=239.255.100.100

               

              That's it.

              • 4. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                Damith K Newbie

                I did some changes to httpd.conf.

                 

                <IfModule manager_module>

                  Listen 127.0.0.1:6666

                  ManagerBalancerName mycluster

                  <VirtualHost *:80>

                    <Location />

                     Order deny,allow

                     Deny from all

                     Allow from 127.0.0.1

                    </Location>

                 

                    KeepAliveTimeout 300

                    MaxKeepAliveRequests 0

                    #ServerAdvertise on http://127.0.0.1:6666

                    AdvertiseFrequency 5                       <---- remove comment

                    #AdvertiseSecurityKey secret

                    #AdvertiseGroup 224.0.1.105:23364

                    EnableMCPMReceive                       <---- remove comment

                 

                    <Location /mod_cluster_manager>

                       SetHandler mod_cluster-manager

                       Order deny,allow

                       Deny from all

                       Allow from 127.0.0

                       AllowDisplay On

                    </Location>

                 

                  </VirtualHost>

                </IfModule>

                 

                 

                below is the new out put.

                 

                mod_cluster/1.2.0.Final

                start of "httpd.conf" configuration

                mod_proxy_cluster.c: OK

                mod_sharedmem.c: OK

                Protocol supported: AJP

                mod_advertise.c: OK

                Server: TSA-ST-9TK6NX1.xyz

                Server: TSA-ST-9TK6NX1.xyz VirtualHost: *:80 Advertising on Group 224.0.1.105 Port 23364 for (null)://(null):0 every 5 seconds

                end of "httpd.conf" configuration

                 

                Auto Refresh show DUMP output show INFO output

                • 5. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                  Jean-Frederic Clere Master

                  Advertising on Group 224.0.1.105 Port 23364 for (null)://(null):0 every 5 seconds

                  it seems you need ServerAdvertise on http://127.0.0.1:80

                  • 6. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                    Damith K Newbie

                    Hi Jean,

                     

                    If I got what you said, I uncomment the "ServerAdvertise on http://127.0.0.1:6666" line. Now the httpd.conf snipt as follows.

                     

                     

                        KeepAliveTimeout 300

                        MaxKeepAliveRequests 0

                        ServerAdvertise on http://127.0.0.1:6666                      <--  uncommented this line.

                        AdvertiseFrequency 5

                        #AdvertiseSecurityKey secret

                        AdvertiseGroup 239.255.100.100:23364

                        EnableMCPMReceive

                     

                     

                    And now the out put of "http://localhost/mod_cluster_manager"

                     

                     

                    mod_cluster/1.2.0.Final

                    start of "httpd.conf" configuration

                    mod_proxy_cluster.c: OK

                    mod_sharedmem.c: OK

                    Protocol supported: AJP

                    mod_advertise.c: OK

                    Server: TSA-ST-9TK6NX1.sgp-tsd.dsd

                    Server: localhost VirtualHost: 127.0.0.1:80 Advertising on Group 239.255.100.100 Port 23364 for http://127.0.0.1:6666 every 5 seconds

                    end of "httpd.conf" configuration

                     

                    Auto Refresh show DUMP output show INFO output

                    -------------------------------------------------------------------------------------

                     

                    Also I tried the test utility program "Tester" with argument 239.255.100.100 23364  Below is the output.

                     

                    ready waiting...

                    received: HTTP/1.0 200 OK

                    Date: Thu, 28 Nov 2013 01:55:47 GMT

                    Sequence: 171

                    Digest: 1af0d1d7139e5352406fc01976f4aff0

                    Server: 177f9f7c-6f37-df4a-baa9-a046f02159f4

                    X-Manager-Address: 127.0.0.1:6666

                    X-Manager-Url: /177f9f7c-6f37-df4a-baa9-a046f02159f4

                    X-Manager-Protocol: http

                    X-Manager-Host: localhost

                     

                    ]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]]

                    received from /10.77.4.144:23364

                    received: HTTP/1.0 200 OK

                    Date: Thu, 28 Nov 2013 01:55:52 GMT

                    Sequence: 172

                    Digest: 7c66ae86cf5f3c264c52085e02c298d4

                    Server: 177f9f7c-6f37-df4a-baa9-a046f02159f4

                    X-Manager-Address: 127.0.0.1:6666

                    X-Manager-Url: /177f9f7c-6f37-df4a-baa9-a046f02159f4

                    X-Manager-Protocol: http

                    X-Manager-Host: localhost

                    • 7. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                      Jean-Frederic Clere Master

                      Check that you have AS6 configured according to http://docs.jboss.org/mod_cluster/1.2.0/html/java.config.html#ModClusterListener

                      Check that you have mod_cluster bean started in AS6: there should be mod_cluster message while starting the server.

                      BTW: Why are you using such an old version of AS?

                      • 8. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                        Damith K Newbie

                        Hi Jean,

                         

                        When I follow that instructions I get below error.


                        ERROR [AbstractKernelController] Error installing to Start: name=WebServer state=Create: java.lang.ClassNotFoundException: org.jboss.modcluster.container.catalina.standalone.ModClusterListener from BaseClassLoader@874920{vfs:///D:/NewJBoss/jboss1/server/all/deploy/jbossweb.sar}

                         

                         

                        Regards,

                        Imesh

                        • 10. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                          Damith K Newbie

                          Hi Jean,

                           

                          Which jar file?

                          I already have \server\all\deploy\mod_cluster.sar folder and mod_cluster.jar file is inside.

                          • 11. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                            Jean-Frederic Clere Master

                            That is an old version.... that is mod_cluster 1.1.0.Final.

                            you should remove the mod_cluster.sar folder and replace it by the mod_cluster.sar from http://www.jboss.org/mod_cluster/downloads/1-2-6-Final-bin.html

                            again why are you using an old version?

                            • 12. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                              Damith K Newbie

                              Hi Jean,

                               

                              Sorry,My company wants to use this version. And I can not change it. May be "Old is gold".  Hope you will assist me to fix this further.

                               

                              OK I downloaded the file java bundles from the page you gave and their were 3 folders call demo, JBossWeb-Tomcat, mod_cluster.sar

                              I simply copied mod_cluster.sar folder to jboss1\server\all\deploy    folder.

                               

                              I have this error now.

                               

                              ERROR [AbstractKernelController] Error installing to PreInstall: name=ModClusterService state=Real mode=On Demand requiredState=Described: org.jboss.joinpoint.spi.JoinpointException: Constructor not found org.jboss.modcluster.ModClusterService[org.jboss.modcluster.config.ModClusterConfig, org.jboss.modcluster.load.LoadBalanceFactorProvider] in [ReflectConstructorInfoImpl@5052b9{[ReflectClassInfoImpl@1670fa5{name=org.jboss.modcluster.config.impl.ModClusterConfig}, ReflectClassInfoImpl@1341f7c{name=org.jboss.modcluster.load.LoadBalanceFactorProviderFactory}]}, ReflectConstructorInfoImpl@ff13d7{[ReflectClassInfoImpl@1670fa5{name=org.jboss.modcluster.config.impl.ModClusterConfig}, ReflectClassInfoImpl@1341f7c{name=org.jboss.modcluster.load.LoadBalanceFactorProviderFactory}, ReflectClassInfoImpl@6fc757{name=org.jboss.modcluster.mcmp.MCMPRequestFactory}]}, ReflectConstructorInfoImpl@8820fa{[ReflectClassInfoImpl@1670fa5{name=org.jboss.modcluster.config.impl.ModClusterConfig}, ReflectClassInfoImpl@1341f7c{name=org.jboss.modcluster.load.LoadBalanceFactorProviderFactory}, ReflectClassInfoImpl@6fc757{name=org.jboss.modcluster.mcmp.MCMPRequestFactory}, ReflectClassInfoImpl@12d12e6{name=org.jboss.modcluster.mcmp.MCMPResponseParser}, ReflectClassInfoImpl@33e2a6{name=org.jboss.modcluster.mcmp.ResetRequestSource}]}, ReflectConstructorInfoImpl@650cb3{[ReflectClassInfoImpl@24f87e{name=org.jboss.modcluster.config.NodeConfiguration}, ReflectClassInfoImpl@1364b8f{name=org.jboss.modcluster.config.BalancerConfiguration}, ReflectClassInfoImpl@19ab59a{name=org.jboss.modcluster.config.MCMPHandlerConfiguration}, ReflectClassInfoImpl@1341f7c{name=org.jboss.modcluster.load.LoadBalanceFactorProviderFactory}, ReflectClassInfoImpl@6fc757{name=org.jboss.modcluster.mcmp.MCMPRequestFactory}, ReflectClassInfoImpl@12d12e6{name=org.jboss.modcluster.mcmp.MCMPResponseParser}, ReflectClassInfoImpl@33e2a6{name=org.jboss.modcluster.mcmp.ResetRequestSource}, ReflectClassInfoImpl@8b943{name=org.jboss.modcluster.mcmp.MCMPHandler}, ReflectClassInfoImpl@bb1311{name=org.jboss.modcluster.advertise.AdvertiseListenerFactory}]}, ReflectConstructorInfoImpl@1e0cbb9{[ReflectClassInfoImpl@1670fa5{name=org.jboss.modcluster.config.impl.ModClusterConfig}, ReflectClassInfoImpl@15ee1b2{name=org.jboss.modcluster.load.LoadBalanceFactorProvider}]}]

                              • 14. Re: HTTP 404 Not Found when try http://localhost/mod_cluster-manager
                                Jean-Frederic Clere Master

                                org.jboss.modcluster.ModClusterService[org.jboss.modcluster.config.ModClusterConfig, org.jboss.modcluster.load.LoadBalanceFactorProvider]

                                 

                                That looks wrong (probably from mod_cluster-jboss-beans.xml)

                                 

                                I have in repo:

                                +++

                                [jfclere@jfcpc mod_cluster]$ find . -name ModClusterConfig.java
                                ./core/src/main/java/org/jboss/modcluster/config/impl/ModClusterConfig.java

                                +++

                                1 2 Previous Next