7 Replies Latest reply on Dec 1, 2015 1:23 AM by Harish chanda

    Can't clone repository.

    Pedro Vaz Newbie

      I'm trying to share a project development between eclipse and kie workbench using a remote GIT repository using ssh.

       

      I have a test project and a branch DSV working in eclipse x local x remote without problemns.

       

      When I try to clone repository in KIE Workbench I recive the modal message:

       

           Can't clone repository. java.lang.RuntimeException:Invalid remote: origin


      The server.log file don't show any information.

       

       

      Questions:

      How can I clone de project?

      How can I specify de branch?

      How can I publish the changes from the local cloned repo to the remote repo?

       

      Thanks

        • 1. Re: Can't clone repository.
          Jay Guidos Novice

          You can clone using normal git commands, as long as KIE Workbench is running.  Lets say you created a repo in workbench called myRepo.  To clone:

           

          git clone git://localhost/myRepo

           

          now do your stuff and branch, commit, merge and push (and pull) just like any other git repo.

           

          Jay

          • 2. Re: Can't clone repository.
            Maciej Swiderski Master

            invalid remote origin means you have specified invalid url to the git repository you try to clone. Double check that it is a valid git repository url and you provided correct credentials as well.

             

            HTH

            • 3. Re: Can't clone repository.
              Pedro Vaz Newbie

              I delete the previous repository experiences from .niogit (I'm using jbpm6-installer standard instalation), try again with the same configuration used in eclipse and it works.

              Thanks!

               

              I need to know how to specify a branch, and how to push the changes to the remote repository.

               

               

              About Jay Guidos Answare, I'm trying to avoid the need of access the server environment directly. Unless there is no another option.

              • 4. Re: Can't clone repository.
                Pedro Vaz Newbie

                When I try to access the Organizational Unit that contains the cloned repository using the Authoring\ Project Authoring path, I recive the message:


                Unable to complete your request. The following exception occurred: null.


                 

                Using the path 'Authoring\ Administration' path I can see the maven/eclipse project and all the files without problem.

                 

                How can I configure the log to obtain more detailed information?

                • 5. Re: Can't clone repository.
                  Maciej Swiderski Master

                  there could be an issue with immediate refresh of added repository for some UI components like Project Explorer. Try to switch to repository view and back, that should refresh some of the cached data. It has been already addressed and will be part of next release.

                   

                  HTH

                  • 6. Re: Can't clone repository.
                    Pedro Vaz Newbie

                    The behaviour persists with the user krisv, who create the repository.

                    When I access with other users, I access the project but when accessing a file I recive the message "Unable to complete your request. The following exception occurred: number of transferred bytes cannot be negative."

                     

                    I have reconfigured all my environment, Cleaned my database, point to SQL-Server, changed the jbpm-console.war/WEB-INF/log4j.xml level to DEBUG, and changed the jboss start configuration "org.kie.demo" and "org.jbpm.console.demo" to false. But still get the same message.

                     

                    The log show the follow information:

                     

                     

                    ERROR [stderr] (FileRepositoryConnector-1) Exception in thread "FileRepositoryConnector-1" java.lang.IllegalArgumentException: number of transferred bytes cannot be negative

                     

                    12:50:58,145 ERROR [org.guvnor.common.services.builder.BuildServiceImpl] (http-localhost-127.0.0.1-8080-3) number of transferred bytes cannot be negative: java.lang.IllegalArgumentException: number of transferred bytes cannot be negative

                    at org.sonatype.aether.util.listener.DefaultTransferEvent.setTransferredBytes(DefaultTransferEvent.java:123) [aether-util-1.13.1.jar:]

                    at org.sonatype.aether.connector.file.FileRepositoryWorker.run(FileRepositoryWorker.java:299) [aether-connector-file-1.13.1.jar:]

                    at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60) [aether-util-1.13.1.jar:]

                    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_21]

                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_21]

                    at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_21]

                     

                     

                    I think that I'm closer. But I will need a lot of help.

                     

                    Thanks!

                    • 7. Re: Can't clone repository.
                      Harish chanda Newbie

                      Hi Maciej Swiderski,

                      Even i'm facing the same issue. Cannot clone GIT repository.When I tried to clone  remote repository in Kie workbench.

                      I got the following error.

                       

                      cant clone repository: java.lang.runtimeException;

                      https:// localhost:8080/sample.git : cannot open git-upload-pack

                       

                      Could you help me on this.