1 2 Previous Next 22 Replies Latest reply on Feb 24, 2014 5:00 AM by Tomaz Cerar

    Deployment doesn't see the web.xml entries

    Shai Almog Newbie

      Hi,

      I downloaded 2.0.0.Beta1 and copied our war directory from the our GAE app within Eclipse into the standalone deployment directory as ROOT.war.

      I created a ROOT.war.deployed file and it seemed to work correctly, the index.html root shows the basic UI however all the servlets mentioned in the web.xml file seem to be unmapped.

       

      Is there something trivial I'm missing here?

       

      I also need some code to detect if I'm running on App Engine or not, is there an official way to achieve this?

       

      Thanks.

        • 1. Re: Deployment doesn't see the web.xml entries
          Tomaz Cerar Master

          Hi,

           

          do you see any errors in server/console log when deploying your app?

           

          how does your web.xml look like and where do you have it?

          • 2. Re: Deployment doesn't see the web.xml entries
            Shai Almog Newbie

            Thanks, super fast reply ;-)

            (had to create a new account to answer, reply frequency too high ugh).

             

            I don't see any errors at all other than simple networking warnings such as these:

            18:30:48,741 WARN  [org.hibernate.search.impl.ConfigContext] (MSC service thread 1-3) HSEARCH000075: Configuration setting hibernate.search.lucene_version was not specified, using LUCENE_CURRENT.

            18:30:48,741 WARN  [org.hibernate.search.impl.ConfigContext] (MSC service thread 1-1) HSEARCH000075: Configuration setting hibernate.search.lucene_version was not specified, using LUCENE_CURRENT.

            18:30:48,741 WARN  [org.hibernate.search.impl.ConfigContext] (MSC service thread 1-2) HSEARCH000075: Configuration setting hibernate.search.lucene_version was not specified, using LUCENE_CURRENT.

            18:30:48,741 WARN  [org.hibernate.search.impl.ConfigContext] (MSC service thread 1-5) HSEARCH000075: Configuration setting hibernate.search.lucene_version was not specified, using LUCENE_CURRENT.

            18:30:48,741 WARN  [org.hibernate.search.impl.ConfigContext] (MSC service thread 1-4) HSEARCH000075: Configuration setting hibernate.search.lucene_version was not specified, using LUCENE_CURRENT.

            18:30:48,742 WARN  [org.hibernate.search.impl.ConfigContext] (MSC service thread 1-7) HSEARCH000075: Configuration setting hibernate.search.lucene_version was not specified, using LUCENE_CURRENT.

            18:30:48,860 WARN  [org.hibernate.search.backend.impl.jgroups.JGroupsChannelProvider] (MSC service thread 1-7) HSEARCH000007: FLUSH is not present in your JGroups stack! FLUSH is needed to ensure messages are not dropped while new nodes join the cluster. Will proceed, but inconsistencies may arise!

            18:30:48,861 WARN  [org.hibernate.search.backend.impl.jgroups.JGroupsChannelProvider] (MSC service thread 1-2) HSEARCH000007: FLUSH is not present in your JGroups stack! FLUSH is needed to ensure messages are not dropped while new nodes join the cluster. Will proceed, but inconsistencies may arise!

            18:30:48,860 WARN  [org.hibernate.search.backend.impl.jgroups.JGroupsChannelProvider] (MSC service thread 1-3) HSEARCH000007: FLUSH is not present in your JGroups stack! FLUSH is needed to ensure messages are not dropped while new nodes join the cluster. Will proceed, but inconsistencies may arise!

            18:30:48,860 WARN  [org.hibernate.search.backend.impl.jgroups.JGroupsChannelProvider] (MSC service thread 1-1) HSEARCH000007: FLUSH is not present in your JGroups stack! FLUSH is needed to ensure messages are not dropped while new nodes join the cluster. Will proceed, but inconsistencies may arise!

            18:30:48,860 WARN  [org.hibernate.search.backend.impl.jgroups.JGroupsChannelProvider] (MSC service thread 1-5) HSEARCH000007: FLUSH is not present in your JGroups stack! FLUSH is needed to ensure messages are not dropped while new nodes join the cluster. Will proceed, but inconsistencies may arise!

            18:30:48,860 WARN  [org.hibernate.search.backend.impl.jgroups.JGroupsChannelProvider] (MSC service thread 1-4) HSEARCH000007: FLUSH is not present in your JGroups stack! FLUSH is needed to ensure messages are not dropped while new nodes join the cluster. Will proceed, but inconsistencies may arise!

             

            The xml is a HUGE file but here is a gist of it:

            <?xml version="1.0" encoding="UTF-8"?>

            <!DOCTYPE web-app

                PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"

                "http://java.sun.com/dtd/web-app_2_3.dtd">

             

            <web-app>

             

              <!-- Servlets -->

             

              <servlet>

                <servlet-name>XxxServlet</servlet-name>

                <servlet-class>com.bla.XxxServlet</servlet-class>

              </servlet>

            ....

            a lot more here

            <servlet-mapping>
               <servlet-name>xxxx</servlet-name>
               <url-pattern>/remote_api</url-pattern>

                </servlet-mapping>

             

            <security-constraint>

              <web-resource-collection>

                <url-pattern>/xxx/*</url-pattern>

              </web-resource-collection>

              <auth-constraint>

                <role-name>admin</role-name>

              </auth-constraint>

            </security-constraint>

             

                <mime-mapping>

                    <extension>jar</extension>

                    <mime-type>application/java-archive</mime-type>

                </mime-mapping>

                <mime-mapping>

                    <extension>jad</extension>

                    <mime-type>text/vnd.sun.j2me.app-descriptor</mime-type>

                </mime-mapping>

                <mime-mapping>

                    <extension>apk</extension>

                    <mime-type>application/vnd.android.package-archive</mime-type>

                </mime-mapping>

                <mime-mapping>

                    <extension>cod</extension>

                    <mime-type>application/vnd.rim.cod</mime-type>

                </mime-mapping> 

               

              <!-- Default page to serve -->

              <welcome-file-list>

                <welcome-file>index.html</welcome-file>

              </welcome-file-list>

             

            </web-app>

            • 3. Re: Deployment doesn't see the web.xml entries
              Ales Justin Master

              How do you see there is no mapping?

              No /remote_api response?

              We override it, afair, where we change the actual servlet.

              • 4. Re: Deployment doesn't see the web.xml entries
                Shai Almog Newbie

                I assumed as much, I just try to access one of my servlets and it returns a "not found" message which is the same one I get from just typing any random URL.
                I probably did something stupid, the last time I dealt with JBoss was in the 3.x era.

                • 5. Re: Deployment doesn't see the web.xml entries
                  Ales Justin Master

                  Hmm,  we have a bunch of tests where we handle servlets,  and no problems

                  so far.

                   

                  Can you create a small. war to expose this?

                  • 6. Re: Deployment doesn't see the web.xml entries
                    Shai Almog Newbie

                    I'm 99.999% sure its a problem on my side I'm just not sure where to look. I'll try to create a new project and transfer our code piece by piece.

                    Thanks.

                    • 7. Re: Deployment doesn't see the web.xml entries
                      Ales Justin Master

                      Inspect the final state of your. war,  its Web.xml.

                      • 8. Re: Deployment doesn't see the web.xml entries
                        Shai Almog Newbie

                        Thanks.

                        I've been playing with this for several hours, a simple WAR just works but my full WAR directory doesn't. After playing with this for ages I'm getting this odd error on deployment which wasn't there before:

                        JBAS014777:   Services which failed to start:  service jboss.persistenceunit."ROOT.war#transactions-optional": org.jboss.msc.service.StartException in service jboss.persistenceunit."ROOT.war#transactions-optional": java.lang.LinkageError: Failed to link org/datanucleus/jpa/JPAClassTransformer (Module "deployment.ROOT.war:main" from Service Module Loader)

                         

                        I'm not exactly sure what to make of it.

                         

                        I have several suspicious files that might cause issues, this is the content of my WEB-INF directory:

                        appengine-generated    classes   deploy   logging.properties    web.xml
                        appengine-web.xml    cron.xml   lib   queue.xml

                         

                        Should appengine-generated be here?

                        Under lib I have the following files:

                        appengine-api-1.0-sdk-1.7.3.jar   commons-logging-1.1.1.jar   geronimo-jta_1.1_spec-1.1.1.jar   json.jar
                        appengine-api-labs.jar   datanucleus-appengine-1.0.10.final.jar    guava-11.0.2.jar   json_simple-1.1.jar
                        appengine-endpoints.jar   datanucleus-core-1.1.5.jar   gwt-servlet.jar   jsr107cache-1.1.jar
                        appengine-jsr107cache-1.7.3.jar   datanucleus-jpa-1.1.5.jar   gwt-visualization-noredist.jar   mockito-all-1.8.5.jar
                        appengine-mapper.jar   gcm-server.jar   gwt-visualization.jar
                        charts4j-1.2.jar   geronimo-jpa_3.0_spec-1.1.1.jar   jdo2-api-2.3-eb.jar

                         

                        I'm not sure if the versions are correct or whether they should even be here?

                         

                        Thanks.

                        • 9. Re: Deployment doesn't see the web.xml entries
                          Shai Almog Newbie

                          I found the problematic file but I'm still not sure I understand what is going on. I have the file WEB-INF/appengine-web.xml which is this:

                          <?xml version="1.0" encoding="utf-8"?>

                          <appengine-web-app xmlns="http://appengine.google.com/ns/1.0">

                            <application>codename-one</application>

                            <version>1</version>

                           

                            <!-- Configure serving/caching of GWT files -->

                            <static-files>

                              <include path="**" />

                           

                              <!-- The following line requires App Engine 1.3.2 SDK -->

                              <include path="**.nocache.*" expiration="0s" />

                           

                              <include path="**.cache.*" expiration="365d" />

                              <exclude path="**.gwt.rpc" />

                            </static-files>

                           

                            <!-- Configure java.util.logging -->

                            <system-properties>

                              <property name="java.util.logging.config.file" value="WEB-INF/logging.properties"/>

                            </system-properties>

                            <sessions-enabled>true</sessions-enabled>

                            <threadsafe>true</threadsafe>

                          </appengine-web-app>

                           

                          I think its been this way since I started working with App Engine. But it seems to be causing the problems I've run into.

                           

                          After removing this file I run into other problems with persistence throwing various exceptions

                          I have WEB-INF/classes/META-INF/jdoconfig.xml:

                          <?xml version="1.0" encoding="utf-8" standalone="no"?>

                          <jdoconfig xmlns="http://java.sun.com/xml/ns/jdo/jdoconfig" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://java.sun.com/xml/ns/jdo/jdoconfig">

                           

                             <persistence-manager-factory name="transactions-optional">

                                 <property name="javax.jdo.PersistenceManagerFactoryClass" value="org.datanucleus.store.appengine.jdo.DatastoreJDOPersistenceManagerFactory"/>

                                 <property name="javax.jdo.option.ConnectionURL" value="appengine"/>

                                 <property name="javax.jdo.option.NontransactionalRead" value="true"/>

                                 <property name="javax.jdo.option.NontransactionalWrite" value="true"/>

                                 <property name="javax.jdo.option.RetainValues" value="true"/>

                                 <property name="datanucleus.appengine.autoCreateDatastoreTxns" value="true"/>

                             </persistence-manager-factory>

                          </jdoconfig>

                           

                           

                          WEB-INF/classes/META-INF/persistence.xml:

                          <?xml version="1.0" encoding="UTF-8" standalone="no"?>

                          <persistence xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.0" xsi:schemaLocation="http://java.sun.com/xml/ns/persistence         http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd">

                           

                              <persistence-unit name="transactions-optional">

                                  <provider>org.datanucleus.store.appengine.jpa.DatastorePersistenceProvider</provider>

                                  <properties>

                                      <property name="datanucleus.NontransactionalRead" value="true"/>

                                      <property name="datanucleus.NontransactionalWrite" value="true"/>

                                      <property name="datanucleus.ConnectionURL" value="appengine"/>

                                  </properties>

                              </persistence-unit>

                           

                          </persistence>

                           

                          I'm getting these errors on deployment when those two files are present:

                          19:01:46,009 WARN  [org.jboss.modules] (ServerService Thread Pool -- 372) Failed to define class org.datanucleus.jpa.JPAClassTransformer in Module "deployment.ROOT.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/datanucleus/jpa/JPAClassTransformer (Module "deployment.ROOT.war:main" from Service Module Loader)

                              at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:428) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.Module.loadModuleClass(Module.java:548) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:189) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Final]

                              at org.datanucleus.jpa.EntityManagerFactoryImpl.<init>(EntityManagerFactoryImpl.java:245) [datanucleus-jpa-1.1.5.jar:]

                              at org.datanucleus.store.appengine.jpa.DatastoreEntityManagerFactory.<init>(DatastoreEntityManagerFactory.java:68) [datanucleus-appengine-1.0.10.final.jar:]

                              at org.datanucleus.store.appengine.jpa.DatastorePersistenceProvider.createContainerEntityManagerFactory(DatastorePersistenceProvider.java:45) [datanucleus-appengine-1.0.10.final.jar:]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl.createContainerEntityManagerFactory(PersistenceUnitServiceImpl.java:318) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl.access$1100(PersistenceUnitServiceImpl.java:67) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1$1.run(PersistenceUnitServiceImpl.java:167) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1$1.run(PersistenceUnitServiceImpl.java:117) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_45]

                              at org.wildfly.security.manager.WildFlySecurityManager.doChecked(WildFlySecurityManager.java:463)

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1.run(PersistenceUnitServiceImpl.java:182) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_45]

                              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_45]

                              at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

                              at org.jboss.threads.JBossThread.run(JBossThread.java:122)

                          Caused by: java.lang.NoClassDefFoundError: org/datanucleus/enhancer/DataNucleusClassFileTransformer

                              at java.lang.ClassLoader.defineClass1(Native Method) [rt.jar:1.7.0_45]

                              at java.lang.ClassLoader.defineClass(ClassLoader.java:800) [rt.jar:1.7.0_45]

                              at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:345) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:423) [jboss-modules.jar:1.3.0.Final]

                              ... 22 more

                          Caused by: java.lang.ClassNotFoundException: org.datanucleus.enhancer.DataNucleusClassFileTransformer from [Module "deployment.ROOT.war:main" from Service Module Loader]

                              at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:197) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Final]

                              ... 26 more

                           

                          19:01:46,014 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 372) MSC000001: Failed to start service jboss.persistenceunit."ROOT.war#transactions-optional": org.jboss.msc.service.StartException in service jboss.persistenceunit."ROOT.war#transactions-optional": java.lang.LinkageError: Failed to link org/datanucleus/jpa/JPAClassTransformer (Module "deployment.ROOT.war:main" from Service Module Loader)

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1$1.run(PersistenceUnitServiceImpl.java:172) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1$1.run(PersistenceUnitServiceImpl.java:117) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_45]

                              at org.wildfly.security.manager.WildFlySecurityManager.doChecked(WildFlySecurityManager.java:463)

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1.run(PersistenceUnitServiceImpl.java:182) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_45]

                              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_45]

                              at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

                              at org.jboss.threads.JBossThread.run(JBossThread.java:122)

                          Caused by: java.lang.LinkageError: Failed to link org/datanucleus/jpa/JPAClassTransformer (Module "deployment.ROOT.war:main" from Service Module Loader)

                              at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:428) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.Module.loadModuleClass(Module.java:548) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:189) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Final]

                              at org.datanucleus.jpa.EntityManagerFactoryImpl.<init>(EntityManagerFactoryImpl.java:245) [datanucleus-jpa-1.1.5.jar:]

                              at org.datanucleus.store.appengine.jpa.DatastoreEntityManagerFactory.<init>(DatastoreEntityManagerFactory.java:68) [datanucleus-appengine-1.0.10.final.jar:]

                              at org.datanucleus.store.appengine.jpa.DatastorePersistenceProvider.createContainerEntityManagerFactory(DatastorePersistenceProvider.java:45) [datanucleus-appengine-1.0.10.final.jar:]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl.createContainerEntityManagerFactory(PersistenceUnitServiceImpl.java:318) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl.access$1100(PersistenceUnitServiceImpl.java:67) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              at org.jboss.as.jpa.service.PersistenceUnitServiceImpl$1$1.run(PersistenceUnitServiceImpl.java:167) [wildfly-jpa-8.0.0.CR1.jar:8.0.0.CR1]

                              ... 8 more

                          Caused by: java.lang.NoClassDefFoundError: org/datanucleus/enhancer/DataNucleusClassFileTransformer

                              at java.lang.ClassLoader.defineClass1(Native Method) [rt.jar:1.7.0_45]

                              at java.lang.ClassLoader.defineClass(ClassLoader.java:800) [rt.jar:1.7.0_45]

                              at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:345) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:423) [jboss-modules.jar:1.3.0.Final]

                              ... 22 more

                          Caused by: java.lang.ClassNotFoundException: org.datanucleus.enhancer.DataNucleusClassFileTransformer from [Module "deployment.ROOT.war:main" from Service Module Loader]

                              at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:197) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Final]

                              at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Final]

                              ... 26 more

                           

                          19:01:46,019 ERROR [org.jboss.as.controller.management-operation] (DeploymentScanner-threads - 2) JBAS014613: Operation ("full-replace-deployment") failed - address: ([]) - failure description: {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"ROOT.war#transactions-optional\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"ROOT.war#transactions-optional\": java.lang.LinkageError: Failed to link org/datanucleus/jpa/JPAClassTransformer (Module \"deployment.ROOT.war:main\" from Service Module Loader)

                              Caused by: java.lang.LinkageError: Failed to link org/datanucleus/jpa/JPAClassTransformer (Module \"deployment.ROOT.war:main\" from Service Module Loader)

                              Caused by: java.lang.NoClassDefFoundError: org/datanucleus/enhancer/DataNucleusClassFileTransformer

                              Caused by: java.lang.ClassNotFoundException: org.datanucleus.enhancer.DataNucleusClassFileTransformer from [Module \"deployment.ROOT.war:main\" from Service Module Loader]"}}

                           

                           

                          Thanks for your help.

                          • 10. Re: Deployment doesn't see the web.xml entries
                            Marko Lukša Apprentice

                            Regarding appengine-web.xml: I'm guessing the problem is the following lines:

                            <static-files>

                            <include path="**" />

                            This would mean all urls shoult be treated as static. That's probably why CapeDwarf returns a 404 instead of invoking the servlet. I'll look into it.

                             

                            Regarding datanucleus problems: I see we're using datanucleus-core 3.1.2, while you are using 1.1.5. This could be the reason why it's not working. alesj can tell you more.

                            1 of 1 people found this helpful
                            • 11. Re: Deployment doesn't see the web.xml entries
                              Shai Almog Newbie

                              Thanks, that's very helpful. I changed the ** to * which is currently enough for me and that seems to have made things better.

                              However, I'm getting 500 errors in the GWT code that aren't logged to the server log. Is there a setting I need to activate or an additional log?

                              • 12. Re: Deployment doesn't see the web.xml entries
                                Ales Justin Master

                                Regarding datanucleus problems: I see we're using datanucleus-core 3.1.2, while you are using 1.1.5. This could be the reason why it's not working. Ales Justin can tell you more.

                                CapeDwarf JPA handling is a bit tricky, as WildFly already handles this, so we need to disable it a bit -- to get GAE's behaviour.

                                As Marko said, we have tests with DN 3.1.2, so perhaps try that version -- as that is JPA2, where 1.1.5 is still JPA1.

                                • 13. Re: Deployment doesn't see the web.xml entries
                                  Ales Justin Master

                                  However, I'm getting 500 errors in the GWT code that aren't logged to the server log. Is there a setting I need to activate or an additional log?

                                  Follow GAE's logging -- logging.properties file and ref in appengine-web.xml.

                                  * https://developers.google.com/appengine/docs/java/#Java_Logging

                                  1 of 1 people found this helpful
                                  • 14. Re: Deployment doesn't see the web.xml entries
                                    Shai Almog Newbie

                                    Thanks. This is what I have in ROOT.war/WEB-INF/logging.properties

                                    .level = INFO

                                     

                                    And app engine web has this:

                                    <system-properties>

                                        <property name="java.util.logging.config.file" value="WEB-INF/logging.properties"/>

                                      </system-properties>

                                     

                                    I can download the datanucleus-core 3.1.2 but I'm assuming I will also need to update datanucleus-jpa-1.1.5.jar and other jars. Is there a place where I can download what's officially supported and replace my existing jars? A reference war file of some sort?


                                    Thanks.

                                    1 2 Previous Next