2 Replies Latest reply on Feb 22, 2014 3:11 PM by Bhathiya Supun

    Jpp 6.1(gatein 3.6) Mysql configuration

    Bhathiya Supun Newbie

      Edit:- I still need help...hit "assumed answer" by mistake and  don't know how to undo it 
      I tried to configure jboss portal 6.1 for about 2 days now. I tried editing configure.properties,standalone.xml , creating module.xml . This runs and server starts @localhost(without any error logs) and redirect me to localhost:8080/portal/mobile.But database is not populated with schema.what could have gone wrong?  thanks in advance for any suugetions.

      Here is my standalone.xml

       

      <?xml version="1.0" encoding="UTF-8" standalone="no"?>

      <server xmlns="urn:jboss:domain:1.4">

          <extensions>

              <extension module="org.jboss.as.clustering.infinispan"/>

              <extension module="org.jboss.as.connector"/>

              <extension module="org.jboss.as.deployment-scanner"/>

              <extension module="org.jboss.as.ee"/>

              <extension module="org.jboss.as.ejb3"/>

              <extension module="org.jboss.as.jaxrs"/>

              <extension module="org.jboss.as.jdr"/>

              <extension module="org.jboss.as.jmx"/>

              <extension module="org.jboss.as.jpa"/>

              <extension module="org.jboss.as.jsf"/>

              <extension module="org.jboss.as.logging"/>

              <extension module="org.jboss.as.mail"/>

              <extension module="org.jboss.as.naming"/>

              <extension module="org.jboss.as.pojo"/>

              <extension module="org.jboss.as.remoting"/>

              <extension module="org.jboss.as.sar"/>

              <extension module="org.jboss.as.security"/>

              <extension module="org.jboss.as.threads"/>

              <extension module="org.jboss.as.transactions"/>

              <extension module="org.jboss.as.web"/>

              <extension module="org.jboss.as.webservices"/>

              <extension module="org.jboss.as.weld"/>

              <extension module="org.gatein"/>

          </extensions>

          <system-properties>

              <property name="gatein.jcr.config.type" value="local"/>

              <property name="gatein.jcr.index.changefilterclass" value="org.exoplatform.services.jcr.impl.core.query.DefaultChangesFilter"/>

          </system-properties>

          <management>

              <security-realms>

                  <security-realm name="ManagementRealm">

                      <authentication>

                          <local default-user="$local"/>

                          <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                  </security-realm>

                  <security-realm name="ApplicationRealm">

                      <authentication>

                          <local default-user="$local" allowed-users="*"/>

                          <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                      <authorization>

                          <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                      </authorization>

                  </security-realm>

              </security-realms>

              <management-interfaces>

                  <native-interface security-realm="ManagementRealm">

                      <socket-binding native="management-native"/>

                  </native-interface>

                  <http-interface security-realm="ManagementRealm">

                      <socket-binding http="management-http"/>

                  </http-interface>

              </management-interfaces>

          </management>

          <profile>

              <subsystem xmlns="urn:jboss:domain:logging:1.2">

                  <console-handler name="CONSOLE">

                      <level name="INFO"/>

                      <formatter>

                          <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                      </formatter>

                  </console-handler>

                  <periodic-rotating-file-handler name="FILE" autoflush="true">

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                      </formatter>

                      <file relative-to="jboss.server.log.dir" path="server.log"/>

                      <suffix value=".yyyy-MM-dd"/>

                      <append value="true"/>

                  </periodic-rotating-file-handler>

                  <logger category="com.google.javascript.jscomp">

                      <level name="WARN"/>

                  </logger>

                  <logger category="com.arjuna">

                      <level name="WARN"/>

                  </logger>

                  <logger category="org.apache.tomcat.util.modeler">

                      <level name="WARN"/>

                  </logger>

                  <logger category="org.jboss.as.config">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="sun.rmi">

                      <level name="WARN"/>

                  </logger>

                  <logger category="jacorb">

                      <level name="WARN"/>

                  </logger>

                  <logger category="jacorb.config">

                      <level name="ERROR"/>

                  </logger>

                  <root-logger>

                      <level name="INFO"/>

                      <handlers>

                          <handler name="CONSOLE"/>

                          <handler name="FILE"/>

                      </handlers>

                  </root-logger>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:datasources:1.1">

                  <datasources>

                      <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">

                          <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>

                          <driver>h2</driver>

                          <security>

                              <user-name>sa</user-name>

                              <password>sa</password>

                          </security>

                      </datasource>

                      <datasource jndi-name="java:/jdbcidm_portal" pool-name="IDMPortalDS" enabled="true" use-java-context="true">

                          <connection-url>jdbc:h2:file:${jboss.server.data.dir}/gatein/portal/jdbcidm_portal;DB_CLOSE_DELAY=-1</connection-url>

                          <driver>h2</driver>

                          <security>

                              <user-name>sa</user-name>

                              <password>sa</password>

                          </security>

                      </datasource>

                     <datasource jndi-name="java:/jdbcjcr_portal" pool-name="JCRPortalDS" enabled="true" use-java-context="true">

                          <connection-url>jdbc:h2:file:${jboss.server.data.dir}/gatein/portal/jdbcjcr_portal;DB_CLOSE_DELAY=-1</connection-url>

                          <driver>h2</driver>

                          <security>

                              <user-name>sa</user-name>

                              <password>sa</password>

                          </security>

                      </datasource>

      <datasource

        jndi-name="java:/mygateindb_portal" pool-name="my_pool"

        enabled="true" jta="true"

        use-java-context="true" use-ccm="true">

        <connection-url>

        jdbc:mysql://localhost:3306/mygateindb_portal

        </connection-url>

        <driver>

        mysql

        </driver>

        <security>

        <user-name>

        root

        </user-name>

        <password>

       

        </password>

        </security>

        <statement>

        <prepared-statement-cache-size>

        100

        </prepared-statement-cache-size>

        <share-prepared-statements/>

        </statement>

        </datasource>

       

                      <!-- Uncommented this when deploying gatein-sample-portal -->

                      <!--

                      <datasource jndi-name="java:/jdbcidm_sample-portal" pool-name="IDMSamplePortalDS" enabled="true" use-java-context="true">

                          <connection-url>jdbc:h2:file:${jboss.server.data.dir}/gatein/sample-portal/jdbcidm_sample_portal;DB_CLOSE_DELAY=-1</connection-url>

                          <driver>h2</driver>

                          <security>

                              <user-name>sa</user-name>

                              <password>sa</password>

                          </security>

                      </datasource>

                      -->

                      <!-- Uncommented this when deploying gatein-sample-portal -->

                      <!--

                      <datasource jndi-name="java:/jdbcjcr_sample-portal" pool-name="JCRSamplePortalDS" enabled="true" use-java-context="true">

                          <connection-url>jdbc:h2:file:${jboss.server.data.dir}/gatein/sample-portal/jdbcjcr_sample_portal;DB_CLOSE_DELAY=-1</connection-url>

                          <driver>h2</driver>

                          <security>

                              <user-name>sa</user-name>

                              <password>sa</password>

                          </security>

                      </datasource>

                      -->

                      <drivers>

        <driver name="mysql" module="com.mysql"/>

                          <driver name="h2" module="com.h2database.h2">

                              <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>

                          </driver>

                      </drivers>

                  </datasources>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">

                  <deployment-scanner deployment-timeout="300" path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ee:1.1">

                  <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>

                  <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ejb3:1.4">

                  <session-bean>

                      <stateless>

                          <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>

                      </stateless>

                      <stateful default-access-timeout="5000" cache-ref="simple"/>

                      <singleton default-access-timeout="5000"/>

                  </session-bean>

                  <pools>

                      <bean-instance-pools>

                          <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                          <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                      </bean-instance-pools>

                  </pools>

                  <caches>

                      <cache name="simple" aliases="NoPassivationCache"/>

                      <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>

                  </caches>

                  <passivation-stores>

                      <file-passivation-store name="file"/>

                  </passivation-stores>

                  <async thread-pool-name="default"/>

                  <timer-service thread-pool-name="default">

                      <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>

                  </timer-service>

                  <remote connector-ref="remoting-connector" thread-pool-name="default"/>

                  <thread-pools>

                      <thread-pool name="default">

                          <max-threads count="10"/>

                          <keepalive-time time="100" unit="milliseconds"/>

                      </thread-pool>

                  </thread-pools>

                  <default-security-domain value="other"/>

                  <default-missing-method-permissions-deny-access value="true"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:infinispan:1.4">

                  <!--Uncommented this if you want persistent HTTP sessions among server restarts (WARN: Performance penalty)-->

        <!--

                  <cache-container name="web" aliases="standard-session-cache" default-cache="local-web" module="org.jboss.as.clustering.web.infinispan">

                      <local-cache name="local-web" batching="true">

                          <file-store passivation="false" purge="false"/>

                      </local-cache>

                  </cache-container>

        -->

                  <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">

                      <local-cache name="entity">

                          <transaction mode="NON_XA"/>

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <local-cache name="local-query">

                          <transaction mode="NONE"/>

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <local-cache name="timestamps">

                          <transaction mode="NONE"/>

                          <eviction strategy="NONE"/>

                      </local-cache>

                  </cache-container>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jca:1.1">

                  <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>

                  <bean-validation enabled="true"/>

                  <default-workmanager>

                      <short-running-threads>

                          <core-threads count="50"/>

                          <queue-length count="50"/>

                          <max-threads count="50"/>

                          <keepalive-time time="10" unit="seconds"/>

                      </short-running-threads>

                      <long-running-threads>

                          <core-threads count="50"/>

                          <queue-length count="50"/>

                          <max-threads count="50"/>

                          <keepalive-time time="10" unit="seconds"/>

                      </long-running-threads>

                  </default-workmanager>

                  <cached-connection-manager/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jmx:1.2">

                  <expose-resolved-model/>

                  <expose-expression-model/>

                  <remoting-connector/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jpa:1.1">

                  <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>

              <subsystem xmlns="urn:jboss:domain:mail:1.1">

                  <mail-session jndi-name="java:jboss/mail/Default">

                      <smtp-server outbound-socket-binding-ref="mail-smtp"/>

                  </mail-session>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:naming:1.3">

                  <remote-naming/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>

              <subsystem xmlns="urn:jboss:domain:remoting:1.1">

                  <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>

              <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

              <subsystem xmlns="urn:jboss:domain:security:1.2">

                  <security-domains>

                      <security-domain name="other" cache-type="default">

                          <authentication>

                              <login-module code="Remoting" flag="optional">

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                              <login-module code="RealmDirect" flag="required">

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                          </authentication>

                      </security-domain>

                      <security-domain name="jboss-web-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                      <security-domain name="jboss-ejb-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                      <security-domain name="gatein-domain" cache-type="default">

                          <authentication>

                              <login-module code="org.gatein.security.oauth.jaas.OAuthLoginModule" flag="required">

                                  <module-option name="portalContainerName" value="portal"/>

                                  <module-option name="realmName" value="gatein-domain"/>

                              </login-module>

                              <login-module code="org.gatein.sso.integration.SSODelegateLoginModule" flag="required">

                                  <module-option name="enabled" value="#{gatein.sso.login.module.enabled}"/>

                                  <module-option name="delegateClassName" value="#{gatein.sso.login.module.class}"/>

                                  <module-option name="portalContainerName" value="portal"/>

                                  <module-option name="realmName" value="gatein-domain"/>

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                              <login-module code="org.exoplatform.services.security.j2ee.JBossAS7LoginModule" flag="required">

                                  <module-option name="portalContainerName" value="portal"/>

                                  <module-option name="realmName" value="gatein-domain"/>

                              </login-module>

                          </authentication>

                      </security-domain>

                      <!-- Uncommented this when deploying gatein-sample-portal -->

                      <!--

                      <security-domain name="gatein-domain-sample-portal" cache-type="default">

                          <authentication>

                              <login-module code="org.gatein.security.oauth.jaas.OAuthLoginModule" flag="required">

                                  <module-option name="portalContainerName" value="sample-portal"/>

                                  <module-option name="realmName" value="gatein-domain-sample-portal"/>

                              </login-module>

                              <login-module code="org.gatein.sso.integration.SSODelegateLoginModule" flag="required">

                                  <module-option name="enabled" value="#{gatein.sso.login.module.enabled}" />

                                  <module-option name="delegateClassName" value="#{gatein.sso.login.module.class}" />

                                  <module-option name="portalContainerName" value="sample-portal" />

                                  <module-option name="realmName" value="gatein-domain-sample-portal" />

                                  <module-option name="password-stacking" value="useFirstPass" />

                              </login-module>

                              <login-module code="org.exoplatform.services.security.j2ee.JBossAS7LoginModule" flag="required">

                                  <module-option name="portalContainerName" value="sample-portal"/>

                                  <module-option name="realmName" value="gatein-domain-sample-portal"/>

                              </login-module>

                          </authentication>

                      </security-domain>

                      -->

                  </security-domains>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:threads:1.1"/>

              <subsystem xmlns="urn:jboss:domain:transactions:1.3">

                  <core-environment>

                      <process-id>

                          <uuid/>

                      </process-id>

                  </core-environment>

                  <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                  <coordinator-environment default-timeout="300"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">

                  <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                  <virtual-server name="default-host" enable-welcome-root="true">

                      <alias name="localhost"/>

                      <alias name="example.com"/>

                  </virtual-server>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:webservices:1.2">

                  <modify-wsdl-address>true</modify-wsdl-address>

                  <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>

                  <endpoint-config name="Standard-Endpoint-Config"/>

                  <endpoint-config name="Recording-Endpoint-Config">

                      <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">

                          <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>

                      </pre-handler-chain>

                  </endpoint-config>

                  <client-config name="Standard-Client-Config"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:weld:1.0"/>

              <subsystem xmlns="urn:jboss:domain:gatein:1.0">

                  <portlet-war-dependencies>

                      <dependency name="org.gatein.wci"/>

                      <dependency name="org.gatein.pc"/>

                      <dependency name="javax.portlet.api"/>

                  </portlet-war-dependencies>

              </subsystem>

          </profile>

          <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

              </interface>

              <interface name="public">

                  <inet-address value="${jboss.bind.address:127.0.0.1}"/>

              </interface>

              <!-- TODO - only show this if the jacorb subsystem is added  -->

              <interface name="unsecure">

                  <!--

                    ~  Used for IIOP sockets in the standard configuration.

                    ~                  To secure JacORB you need to setup SSL

                    -->

                  <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>

              </interface>

          </interfaces>

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

              <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

              <socket-binding name="ajp" port="8009"/>

              <socket-binding name="http" port="8080"/>

              <socket-binding name="https" port="8443"/>

              <socket-binding name="remoting" port="4447"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <outbound-socket-binding name="mail-smtp">

                  <remote-destination host="localhost" port="25"/>

              </outbound-socket-binding>

          </socket-binding-group>

      </server>

      This is C:\Users\Bhathiya\Documents\jpp\jboss-jpp-6.1\standalone\configuration\gatein\configuration.properties

       

      gatein.conf.dir=${jboss.server.config.dir}/gatein

      gatein.data.dir=${jboss.server.data.dir}/gatein

      gatein.db.data.dir=${gatein.data.dir}/db

      ###########################

      #

      # Single node configuration

      # or

      # Default cluster configuration using local indexes (see standalone-ha.xml for more settings)

      #

      # JCR

      gatein.jcr.data.dir=${gatein.data.dir}/jcr

      ##########################

      #

      # Cluster configuration with shared filesystem (NFS)

      #

      # JCR

      # All gatein nodes have to point to the same shared filesystem directory

      #gatein.clustered.data.dir=${jboss.home.dir}/../gatein-cluster

      #gatein.jcr.index.changefilterclass=org.exoplatform.services.jcr.impl.core.query.jbosscache.JBossCacheIndexChangesFilter

      # DB

      gatein.jcr.data.dir=${gatein.clustered.data.dir}/jcr

      gatein.jcr.datasource.driver=com.mysql.jdbc.Driver

      gatein.jcr.datasource.url=jdbc:mysql://localhost:3306/mygateindb${container.name.suffix}

      gatein.jcr.datasource.username=root

      gatein.jcr.datasource.password=

       

      # Turn on JCR value storage that is disabled for default cluster configuration in standalone-ha.xml

      #gatein.jcr.storage.enabled=true

      ###########################

      #

      # Common configuration for all profiles

      #

       

       

      # JCR

      gatein.jcr.datasource.name=java:/jdbcjcr

      gatein.jcr.datasource.dialect=auto

       

       

      gatein.jcr.storage.data.dir=${gatein.jcr.data.dir}/values

      gatein.jcr.cache.config=war:/conf/jcr/jbosscache/${gatein.jcr.config.type}/config.xml

      gatein.jcr.cache.config.workspace.portal-system=war:/conf/jcr/jbosscache/${gatein.jcr.config.type}/config_portal-system.xml

      gatein.jcr.lock.cache.config=war:/conf/jcr/jbosscache/${gatein.jcr.config.type}/lock-config.xml

      gatein.jcr.index.data.dir=${gatein.jcr.data.dir}/lucene

       

       

      gatein.jcr.index.cache.config=war:/conf/jcr/jbosscache/cluster/indexer-config.xml

      gatein.jcr.jgroups.config=classpath:/jgroups/gatein-${gatein.default.jgroups.stack:udp}.xml

      gatein.jcr.db-structure-type=isolated

      gatein.jcr.workspace.default=portal-system

      gatein.jcr.workspace.system=system

       

      # IDM

      gatein.idm.datasource.name=java:/jdbcidm

      gatein.idm.datasource.driver=com.mysql.jdbc.Driver

      gatein.idm.datasource.url=jdbc:mysql://localhost:3306/mygateinidm${container.name.suffix}

      gatein.idm.datasource.username=root

      gatein.idm.datasource.password=

       

      # EMail

      gatein.email.smtp.username=

      gatein.email.smtp.password=

      gatein.email.smtp.host=smtp.gmail.com

      gatein.email.smtp.port=465

      gatein.email.smtp.starttls.enable=true

      gatein.email.smtp.auth=true

      gatein.email.smtp.socketFactory.port=465

      gatein.email.smtp.socketFactory.class=javax.net.ssl.SSLSocketFactory

       

      # Portlet container configuration

      gatein.portlet.validation=true

      gatein.portlet.config=${gatein.conf.dir}/portlet.xml

       

      # Portal configuration

      gatein.portal.idm.createuserportal=false

      gatein.portal.idm.destroyuserportal=true

      gatein.portal.controller.config=${gatein.conf.dir}/controller.xml

       

      # key files for gadget

      gatein.gadgets.securitytokenkeyfile=${gatein.conf.dir}/gadgets/key.txt

      gatein.gadgets.signingkeyfile=${gatein.conf.dir}/gadgets/oauthkey.pem

       

      # SSO

      gatein.sso.enabled=false

      # OAuth

      gatein.oauth.portal.url=http://localhost:8080

       

      ## Facebook

      gatein.oauth.facebook.enabled=false

      gatein.oauth.facebook.clientId=to be replaced

      gatein.oauth.facebook.clientSecret=to be replaced

      gatein.oauth.facebook.redirectURL=${gatein.oauth.portal.url}/@@portal.container.name@@/facebookAuth

      gatein.oauth.facebook.scope=email

       

       

      ## Google

      gatein.oauth.google.enabled=false

      gatein.oauth.google.clientId=to be replaced

      gatein.oauth.google.clientSecret=to be replaced

      gatein.oauth.google.redirectURL=${gatein.oauth.portal.url}/@@portal.container.name@@/googleAuth

      gatein.oauth.google.scope=https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/userinfo.profile

      gatein.oauth.google.accessType=offline

       

      ## Twitter

      gatein.oauth.twitter.enabled=false

      gatein.oauth.twitter.clientId=to be replaced

      gatein.oauth.twitter.clientSecret=to be replaced

      gatein.oauth.twitter.redirectURL=${gatein.oauth.portal.url}/@@portal.container.name@@/twitterAuth

       

       

       

       

      # Resource browser caching configuration

      #gatein.assets.version=PORTAL-VERSION

      #gatein.assets.script.max-age=604800

      #gatein.assets.css.max-age=604800

       

       

      # Root password

      #gatein.portal.setup.initialpassword.root=

      # Copyright (C) 2009 eXo Platform SAS.

      #

       

      I also created C:\Users\Bhathiya\Documents\jpp\jboss-jpp-6.1\modules\com\mysql\main\module.xml

       

      <module xmlns="urn:jboss:module:1.0" name="com.mysql">

        <resources>

          <resource-root path="mysql-connector-java-5.1.29-bin.jar"/>

        </resources>

        <dependencies>

          <module name="javax.api"/>

        <module name="javax.transaction.api"/>

        </dependencies>

      </module>