10 Replies Latest reply on Aug 15, 2014 4:50 PM by Dan Stewart

    jBPM 6.0.1 KIE Workbench Stuck

    Andrew Gisby Newbie

      Hi

       

      I'm new to jBPM. I'm trying to get the demo running (without eclipse, but have tried ant options with/without).

       

      JBOSS AS 7.1 is running and the two war's dashBuilder and jbpm-consle have deployed OK (checking server.log). When I go to localhost:8080/jbpm-console, I get prompted to log in, so looks like all is running.

       

      However, when I login in as krisv/krisv as per tutorial docs, I get the spinning "please wait loading application..." (doesn't budge for far too long), a few echo's in the log (setting date formats, that sort of thing), but nothing else. The KIE workbench does not display. I've tried Chrome and Firefox. Checking the browser JS console, there don't appear to be any errors. Checking the JVM, heap is slowly consumed (so it must be doing something?). KIE workbench just isn't displayed though. I'm at a loss.


      Help ... Any pointers to how I can find what is stopping things?

       

      (Windows 7, i5 x64, 16GB).

        • 1. Re: jBPM 6.0.1 KIE Workbench Stuck
          Mauricio Salatino Master

          Hmm.. that's strange.

          It seems to be a windows problem. Which version of jBPM are you using exactly?

          One more thing that you can try is to make sure that you remove all the cookies/history from your browser and try again when you make sure that both application are deployed.

          1 of 1 people found this helpful
          • 2. Re: jBPM 6.0.1 KIE Workbench Stuck
            Andrew Gisby Newbie

            I've installed 6.0.1 full final.

             

            Tried clearing cookies etc. Both applications deployed and enabled according to console and server.log.

             

            It is something to do with the laptop I'm trying to get it running on. I've tried it on another machine since this post and all is fine. I suspect it is something to do with the firewall and av. I'll keep on looking and post back once I find something. Thanks for the advice.

             

            UPDATE:

            Found it. It was a "Sophos Web Intelligence" service causing the issue. I'll need to talk to our admins to pin down the why.

            • 3. Re: jBPM 6.0.1 KIE Workbench Stuck
              Mauricio Salatino Master

              Good to hear that you find the issue! What was the problem exactly? the port?

              • 4. Re: jBPM 6.0.1 KIE Workbench Stuck
                Andrew Gisby Newbie

                I need to talk to the info sec / desktop admins to find out exactly what. When I do, I'll post back for reference.

                • 5. Re: jBPM 6.0.1 KIE Workbench Stuck
                  Danesh Karimi Newbie

                  Hi

                  I have exactly the same problem.

                  Some times it open successfully but most of the times staying in this state for always:

                  Please wait

                  Loading application...

                   

                  also restarting the server doesn't solve the problem

                   

                  JBPM loading problem.jpg

                   

                  -------------------------------------------

                  UPDATE:

                    Solved.....  It was because of AVG anti virus.

                  • 6. Re: jBPM 6.0.1 KIE Workbench Stuck
                    Dan Stewart Newbie

                    I am also a newbie, and I have had this exact problem, but I have not been able to solve it.  I am running on RHlinux 2.6.18, using jbpm-6.0.1.Final-installer-full.zip, and accessing the jbpm-console from firefox 3.6.26.   The AS server comes up, the two wars deploy fine (per the logs), I log into the KIE with krisv/krisv, and I get the "Please wait Loading application" message forever.

                     

                    I have another clue:  opening up the Firefox error console, I see the following error when I try to access localhost:8080/jbpm-console:

                     

                    Error: uncaught exception: java.lang.RuntimeException: critical error in IOC container bootstrap: com.google.gwt.core.client.JavaScriptException: (TypeError) : a is null

                     

                    I am not running antivirus, firewall is turned off, and I am not using Sophos.

                     

                    Any suggestions?

                    • 7. Re: jBPM 6.0.1 KIE Workbench Stuck
                      Mauricio Salatino Master

                      Can you try with a different browser? or setting the browser to a private mode, so you are sure that there are no cookies bothering?

                      Do you have an internet connection in the machine where you have installed the kie-wb? Are you behind a proxy?

                      • 8. Re: jBPM 6.0.1 KIE Workbench Stuck
                        Dan Stewart Newbie

                        I get the same hangup in firefox with cookies/history cleared, and when in private mode.  I also tried Konqueror, it had the same hangup.  I am working with my sys admins to get chrome installed to try it (maybe next week).

                         

                        I have an internet connection on the machine where AS/kie-wb is running, and it is behind a proxy.  I had to run with org.kie.demo=false in build.xml to get past the fact that git and my proxy don't get along (as described elsewhere on this forum).  I am running firefox/Konqueror on the same machine where AS/kie-wb is running (using localhost:8080/jbpm-console)

                         

                        I was able to get kie-wb up and running on a windows box, but I need this functionality to run my linux server. 

                        • 9. Re: jBPM 6.0.1 KIE Workbench Stuck
                          Mauricio Salatino Master

                          What exact version are you using?

                          Are you using a vanilla installer? or something modified?

                          Regards

                          • 10. Re: jBPM 6.0.1 KIE Workbench Stuck
                            Dan Stewart Newbie

                            jbpm-6.0.1.Final-installer-full.zip, the only modification to the install package is to change org.kie.demo=false in build.xml.

                             

                            I just tried it with jbpm-distribution-6.1.0.CR1-installer-full.zip, had the same result.

                             

                            Thanks for looking into this, Mauricio.