6 Replies Latest reply on Apr 3, 2014 11:11 AM by Pawel Domański

    Cannot load metrics in JBoss 7 sub-resources

    Michel Werren Novice

      Hello

       

      I try to setup our monitoring with RHQ 4.10.0. Looks really nice!

       

      Till now, anything seems to work, except the monitoring tab in all sub-resources of the JBoss AS 7 resource.

       

      We use Postgres 9.3 (i also tried 9.2 before, but the same result), Java 1.7.51 on Debian 7.0.4 x64. The monitored JBoss instance(s) is / are all EAP 6.1.0.Final's, in standalone mode.

       

      With the default RHQ build i got the exception in the first.txt.

       

      After that i found out, that an issue for Hibernate has exist in a previous version: https://hibernate.atlassian.net/browse/HHH-5209. So i tried to replace the Hibernate RHQ AS module with the one of the EAP 6.1.0.Final (4.2.0.Final), since the original one from RHQ is a CR version. Now i got the exception in second.txt

       

      I also tried to upgrade the JDBC drivers to the 9.3, no difference.

       

      Advise?

       

      Thanks a lot!

       

      Regards

      Michel