5 Replies Latest reply on May 15, 2014 7:34 AM by Freeman(Yue) Fang

    Installing FAB in JBoss Fuse 6.1

    Yuri Sokolovski Newbie

      Hi, folks.

       

      I am trying to use fab: commands in JBoss Fuse 6.1  (fab:install, fab:start etc) and Karaf complains that it doesn't recognize fab: scheme:

       

      Caused by: java.net.MalformedURLException: Unknown protocol: fab

              at java.net.URL.<init>(URL.java:619)[:1.7.0_21]

              at org.apache.felix.framework.util.SecureAction.createURL(SecureAction.java:254)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.cache.JarRevision.initialize(JarRevision.java:148)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:77)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.cache.BundleArchive.createRevisionFromLocation(BundleArchive.java:878)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.cache.BundleArchive.reviseInternal(BundleArchive.java:550)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.cache.BundleArchive.<init>(BundleArchive.java:153)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.cache.BundleCache.create(BundleCache.java:277)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at org.apache.felix.framework.Felix.installBundle(Felix.java:3117)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              ... 13 more

      Caused by: java.lang.IllegalStateException: Unknown protocol: fab

              at org.apache.felix.framework.URLHandlersStreamHandlerProxy.parseURL(URLHandlersStreamHandlerProxy.java:372)[org.apache.felix.framework-4.0.3.redhat-610355.jar:]

              at java.net.URL.<init>(URL.java:614)[:1.7.0_21]

       

      So the question is: What is the proper way to install FAB in JBoss Fuse 6.1.

       

      Thank you!