0 Replies Latest reply on Dec 3, 2008 12:02 PM by Wilson Freitas

    Configuring Servicemix to work with an external ActiveMQ broker:

    Wilson Freitas Newbie

      Configuring Servicemix to work with an external ActiveMQ broker:

       

      Requisites:

        - Servicemix 3.3.x installed on $SERVICEMIX_HOME folder.

        - ActiveMQ 5.x installed on $AMQ_HOME folder.

        - $JAVA_HOME env variable pointing to JDK 1.5 root folder.

       

      Servicemix configuration:

      -


       

      1. Edit $SERVICEMIX_HOME/conf/activemq.xml and change it to the following content:

      =========================================================================== 

       

      =========================================================================== 

       

      2. Open a command prompt and start the AMQ broker running:

        $AMQ_HOME/bin/activemq

       

      3. Open a command prompt and start Servicemix service:

        $SERVICEMIX_HOME/bin/servicemix

         

      ActiveMQ configuration:

      ==================

       

      No extra configuration steps are required for ActiveMQ. If AMQ is running on

      the same SMX box disable JMX to avoid port conflicts. To disable JMX edit $AMQ_HOME/conf/activemq.xml and add the attribute useJmx="false" to the broker tag.

       

      --

      Wilson Freitas

      Vetta Technologies