4 Replies Latest reply on Jun 30, 2009 4:40 AM by Torsten Mielke

    Version of WSS4J in Fuse ESB 3.4

    Arman Bedonian Newbie

      Hello,

       

      From looking at the contents of the ServiceMix shared component, it looks like wss4j 1.5.2 is supported by Fuse ESB 3.4 (I've checked 3.4.0.1 and 3.4.0.2).  However, I want to get support for a WS-Security BinarySecurityToken, which is in later versions of wss4j (I've confirmed that BinarySecurityTokenProcessor is in 1.5.5).

       

      If I put wss4j-1.5.5.jar in the lib directory, I get exceptions.  Will a newer version of wss4j be in 3.4.0.3 or do I need to request Fuse for this specific upgrade.

       

      Thank you.