4 Replies Latest reply on Sep 11, 2009 11:09 AM by Dave Stanley

    badmagicexception possible causes ?

    Martin Mathew Newbie

      Hi All

       

      I got the following exception while starting fuse amq

       

       

      ERROR: java.lang.RuntimeException: Failed to execute start task. Reason: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.apache.activemq.xbean.XBeanBrokerService#0' defined in class path resource : Invocation of init method failed; nested exception is org.apache.activemq.kaha.impl.index.BadMagicException

      java.lang.RuntimeException: Failed to execute start task. Reason: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.apache.activemq.xbean.XBeanBrokerService#0' defined in class path resource : Invocation of init method failed; nested exception is org.apache.activemq.kaha.impl.index.BadMagicException

              at org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:99)

              at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:51)

              at org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:106)

              at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:51)

              at org.apache.activemq.console.command.ShellCommand.main(ShellCommand.java:78)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

              at java.lang.reflect.Method.invoke(Unknown Source)

              at org.apache.activemq.console.Main.runTaskClass(Main.java:225)

              at org.apache.activemq.console.Main.main(Main.java:106)

       

       

      This exception talks abt some badmagicexception for which the javadoc doesnt give a convincing explanation. I ran it on Linux box

      wat could be the possible causes of fuse amq not being able to read the files

       

      This issue got resolved after i deleted the contents of the data folder and restarted the amq.