1 2 Previous Next 18 Replies Latest reply on May 23, 2010 10:11 PM by Ben O'Day

    ESB 4.2.0 - CXF - Provider org.apache.axis2.jaxws.spi.Provider not found

    Daffy Duck Novice

      Hi,

       

      Another big issue I encounter on this latest ESB release. A bundle performing a WS call using CXF that works perfectly with previous ESB releases now raises following exception:

       

      javax.xml.ws.spi.FactoryFinder$ConfigurationError: Provider org.apache.axis2.jaxws.spi.Provider not found

           at javax.xml.ws.spi.FactoryFinder$2.run(FactoryFinder.java:135)

           at javax.xml.ws.spi.FactoryFinder.doPrivileged(FactoryFinder.java:264)

           at javax.xml.ws.spi.FactoryFinder.newInstance(FactoryFinder.java:122)

           at javax.xml.ws.spi.FactoryFinder.access$200(FactoryFinder.java:42)

           at javax.xml.ws.spi.FactoryFinder$3.run(FactoryFinder.java:255)

           at javax.xml.ws.spi.FactoryFinder.doPrivileged(FactoryFinder.java:264)

           at javax.xml.ws.spi.FactoryFinder.find(FactoryFinder.java:165)

           at javax.xml.ws.spi.Provider.provider(Provider.java:39)

           at javax.xml.ws.Service.(Service.java:36)

       

      The CXF bundle is running and calling a CXF WS from a CXF client works. But calling an Axis WS from a CXF client does not work anymore.

       

      Any idea? I say it again: my bundle works fine using ESB 4.1.0-psc-01-02RC1.

       

       

      Regards,

      CM

        1 2 Previous Next