6 Replies Latest reply on Dec 7, 2012 2:32 AM by Claus Ibsen

    Fuse IDE JMX Explorer Unable to connect

    Parker Lord Newbie

      I have been unable to get the Fuse Integration Perspecitve to allow me to connect to any local camel contexts running inside the IDE.

       

      Prior to upgrading to 2.1.747, I at least was able to see the local camel context process, but whenever I tried to open it, it just got stuck on Loading.... forever.

       

       

      After the upgrade, in the JMX Explorer, I just see to entries,

      JMX Server and JMX Server1.

       

      Clicking on either one gives the same error:

       

      An error occurred while opening the connection.

      Failed to retrieve RMIServer stub: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:

           java.net.ConnectException: Connection refused: connect]

       

      I would really like to be able to evaluate the visual debugging tools inside the IDE. Any suggestions?