1 2 Previous Next 22 Replies Latest reply on Jul 7, 2015 10:56 AM by jure12347

    JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1

    jure12347 Newbie

      Hello there!

       

      I have the following problem.

       

      When i try to test the standalone server according to this instructions:

       

      "In an attempt to recreate the customer problem, in an easier to debug environment, we will attempt to recreate the HornetQ issue in a standalone JBoss EAP 6.1 install with some demo code.  Within C&DS when jobsteps are started, a message gets submitted to the JMS engine of the Application Server.  On JBoss this is the HornetQ server.  So to recreate this, we have a simple MDB that will allow us to wait for a specified amount of time to simulate the jobstep processing time.  We have a jsp that will allow us to submit requests to the JMS Server and get processed by the MDB.

      Files provided:

      • standalone-mdb-test.xml  - similar to cdsserver.xml
      • mytestmdb.ear  --- the MDB to simulate the jobstep processing.
      • mytestjms.war   --- the jsp to send messages to the MDB

      Setup Steps

      1. 1. Install JBoss EAP 6.1 (unzip to a clean directory on the same PC as C&DS)
      2. 2. Copy standalone-mdb-test.xml to the standalone/configuration directory
      3. 3. Copy mytestjms.war and mytestmdb.ear to standalone/deployments

      Starting the JBoss Server

      To start the JBoss server, we will use the special configuration file.  So run the following command to start the server (from the JBoss bin directory):

      cd \jboss-eap-6.1\bin

      1. standalone.bat –c standalone-mdb-test.xml

      When the server starts we can then start the MDB test."

       

      I get the following error:

      JBAS015801: Invalid option 'ľc'

       

      Before that Java virtual machine wouldnt load, because it reported heap memory size was too low. I changed it to 512M and that now works.

       

      Whole info from CMD:

      "15:26:17,712 INFO  [org.jboss.modules] (main) JBoss Modules version 1.2.0.Final-redhat-1

      15:26:17,789 ERROR [stderr] (main) JBAS015801: Invalid option 'ľc'"

       

      Please help me =)

        • 1. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
          Mustafa Musaji Novice

          Can you upload the contents of your standalone.bat, standalone-mdb-test.xml and the standalone.conf.bat files please? Something is wrong in one of these files - more than likely the standalone.conf.bat file where JAVA_OPTS is set.

          • 2. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
            jure12347 Newbie

            Hey there

             

            Here are the contents of standalone.conf.bat:

             

            rem ### -*- batch file -*- ######################################################

            rem #                                                                          ##

            rem #  JBoss Bootstrap Script Configuration                                    ##

            rem #                                                                          ##

            rem #############################################################################

             

             

            rem # $Id: run.conf.bat 88820 2009-05-13 15:25:44Z dimitris@jboss.org $

             

             

            rem #

            rem # This batch file is executed by run.bat to initialize the environment

            rem # variables that run.bat uses. It is recommended to use this file to

            rem # configure these variables, rather than modifying run.bat itself.

            rem #

             

             

            rem Uncomment the following line to disable manipulation of JAVA_OPTS (JVM parameters)

            rem set PRESERVE_JAVA_OPTS=true

             

             

            if not "x%JAVA_OPTS%" == "x" (

              echo "JAVA_OPTS already set in environment; overriding default settings with values: %JAVA_OPTS%"

              goto JAVA_OPTS_SET

            )

             

             

            rem #

            rem # Specify the JBoss Profiler configuration file to load.

            rem #

            rem # Default is to not load a JBoss Profiler configuration file.

            rem #

            rem set "PROFILER=%JBOSS_HOME%\bin\jboss-profiler.properties"

             

             

            rem #

            rem # Specify the location of the Java home directory (it is recommended that

            rem # this always be set). If set, then "%JAVA_HOME%\bin\java" will be used as

            rem # the Java VM executable; otherwise, "%JAVA%" will be used (see below).

            rem #

            rem set "JAVA_HOME=C:\opt\jdk1.6.0_23"

             

             

            rem #

            rem # Specify the exact Java VM executable to use - only used if JAVA_HOME is

            rem # not set. Default is "java".

            rem #

            rem set "JAVA=C:\opt\jdk1.6.0_23\bin\java"

             

             

            rem #

            rem # Specify options to pass to the Java VM. Note, there are some additional

            rem # options that are always passed by run.bat.

            rem #

             

             

            rem # JVM memory allocation pool parameters - modify as appropriate.

            set "JAVA_OPTS=-Xms512M -Xmx512M -XX:MaxPermSize=512M"

             

             

            rem # Prefer IPv4

            set "JAVA_OPTS=%JAVA_OPTS% -Djava.net.preferIPv4Stack=true"

             

             

            rem # Make Byteman classes visible in all module loaders

            rem # This is necessary to inject Byteman rules into AS7 deployments

            set "JAVA_OPTS=%JAVA_OPTS% -Djboss.modules.system.pkgs=org.jboss.byteman"

             

             

            rem # Sample JPDA settings for remote socket debugging

            rem set "JAVA_OPTS=%JAVA_OPTS% -agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n"

             

             

            rem # Sample JPDA settings for shared memory debugging

            rem set "JAVA_OPTS=%JAVA_OPTS% -agentlib:jdwp=transport=dt_shmem,address=jboss,server=y,suspend=n"

             

             

            rem # Use JBoss Modules lockless mode

            rem set "JAVA_OPTS=%JAVA_OPTS% -Djboss.modules.lockless=true"

             

             

            :JAVA_OPTS_SET

             

             

             

            Here is the content of standalone.bat:

             

            @echo off

            rem -------------------------------------------------------------------------

            rem JBoss Bootstrap Script for Windows

            rem -------------------------------------------------------------------------

             

             

            rem Use --debug to activate debug mode with an optional argument to specify the port

            rem Usage : standalone.bat --debug

            rem         standalone.bat --debug 9797

             

             

            rem By default debug mode is disable.

            set DEBUG_MODE=false

            set DEBUG_PORT=8787

            rem Set to all parameters by default

            set SERVER_OPTS=%*

             

             

            rem Get the program name before using shift as the command modify the variable ~nx0

            if "%OS%" == "Windows_NT" (

              set "PROGNAME=%~nx0%"

            ) else (

              set "PROGNAME=standalone.bat"

            )

             

             

            @if not "%ECHO%" == ""  echo %ECHO%

            @if "%OS%" == "Windows_NT" setlocal

             

             

            if "%OS%" == "Windows_NT" (

              set "DIRNAME=%~dp0%"

            ) else (

              set DIRNAME=.\

            )

             

             

            rem Read command-line args.

            :READ-ARGS

            if "%1" == "" (

               goto MAIN

            ) else if "%1" == "--debug" (

               goto READ-DEBUG-PORT

            ) else (

               rem This doesn't work as Windows splits on = and spaces by default

               rem set SERVER_OPTS=%SERVER_OPTS% %1

               shift

               goto READ-ARGS

            )

             

             

            :READ-DEBUG-PORT

            set "DEBUG_MODE=true"

            set DEBUG_ARG="%2"

            if not "x%DEBUG_ARG" == "x" (

               if x%DEBUG_ARG:-=%==x%DEBUG_ARG% (

                  shift

                  set DEBUG_PORT=%DEBUG_ARG%

               )

               shift

               goto READ-ARGS

            )

             

             

            :MAIN

            rem $Id$

            )

             

             

            pushd %DIRNAME%..

            set "RESOLVED_JBOSS_HOME=%CD%"

            popd

             

             

            if "x%JBOSS_HOME%" == "x" (

              set "JBOSS_HOME=%RESOLVED_JBOSS_HOME%"

            )

             

             

            pushd "%JBOSS_HOME%"

            set "SANITIZED_JBOSS_HOME=%CD%"

            popd

             

             

            if /i "%RESOLVED_JBOSS_HOME%" NEQ "%SANITIZED_JBOSS_HOME%" (

               echo.

               echo   WARNING:  JBOSS_HOME may be pointing to a different installation - unpredictable results may occur.

               echo.

               echo             JBOSS_HOME: %JBOSS_HOME%

               echo.

               rem 2 seconds pause

               ping 127.0.0.1 -n 3 > nul

            )

             

             

            rem Read an optional configuration file.

            if "x%STANDALONE_CONF%" == "x" (

               set "STANDALONE_CONF=%DIRNAME%standalone.conf.bat"

            )

            if exist "%STANDALONE_CONF%" (

               echo Calling "%STANDALONE_CONF%"

               call "%STANDALONE_CONF%" %*

            ) else (

               echo Config file not found "%STANDALONE_CONF%"

            )

             

             

             

             

            rem Set debug settings if not already set

            if "%DEBUG_MODE%" == "true" (

               echo "%JAVA_OPTS%" | findstr /I "\-agentlib:jdwp" > nul

              if errorlevel == 1 (

                 set "JAVA_OPTS=%JAVA_OPTS% -agentlib:jdwp=transport=dt_socket,address=%DEBUG_PORT%,server=y,suspend=n"

              ) else (

                 echo Debug already enabled in JAVA_OPTS, ignoring --debug argument

              )

            )

             

             

            set DIRNAME=

             

             

            rem Setup JBoss specific properties

            set JAVA_OPTS=-Dprogram.name=%PROGNAME% %JAVA_OPTS%

             

             

            if "x%JAVA_HOME%" == "x" (

              set  JAVA=java

              echo JAVA_HOME is not set. Unexpected results may occur.

              echo Set JAVA_HOME to the directory of your local JDK to avoid this message.

            ) else (

              set "JAVA=%JAVA_HOME%\bin\java"

            )

             

             

            if not "%PRESERVE_JAVA_OPTS%" == "true" (

              rem Add -client to the JVM options, if supported (32 bit VM), and not overriden

              echo "%JAVA_OPTS%" | findstr /I \-server > nul

              if errorlevel == 1 (

                "%JAVA%" -client -version 2>&1 | findstr /I /C:"Client VM" > nul

                if not errorlevel == 1 (

                  set "JAVA_OPTS=-client %JAVA_OPTS%"

                )

              )

            )

             

             

            if not "%PRESERVE_JAVA_OPTS%" == "true" (

              rem Add compressed oops, if supported (64 bit VM), and not overriden

              echo "%JAVA_OPTS%" | findstr /I "\-XX:\-UseCompressedOops \-client" > nul

              if errorlevel == 1 (

                "%JAVA%" -XX:+UseCompressedOops -version > nul 2>&1

                if not errorlevel == 1 (

                  set "JAVA_OPTS=-XX:+UseCompressedOops %JAVA_OPTS%"

                )

              )

            )

             

             

            if not "%PRESERVE_JAVA_OPTS%" == "true" (

              rem Add tiered compilation, if supported (64 bit VM), and not overriden

              echo "%JAVA_OPTS%" | findstr /I "\-XX:\-TieredCompilation \-client" > nul

              if errorlevel == 1 (

                "%JAVA%" -XX:+TieredCompilation -version > nul 2>&1

                if not errorlevel == 1 (

                  set "JAVA_OPTS=-XX:+TieredCompilation %JAVA_OPTS%"

                )

              )

            )

             

             

            rem Find jboss-modules.jar, or we can't continue

            if exist "%JBOSS_HOME%\jboss-modules.jar" (

                set "RUNJAR=%JBOSS_HOME%\jboss-modules.jar"

            ) else (

              echo Could not locate "%JBOSS_HOME%\jboss-modules.jar".

              echo Please check that you are in the bin directory when running this script.

              goto END

            )

             

             

            rem Setup JBoss specific properties

             

             

            rem Setup directories, note directories with spaces do not work

            set "CONSOLIDATED_OPTS=%JAVA_OPTS% %SERVER_OPTS%"

            :DIRLOOP

            echo(%CONSOLIDATED_OPTS% | findstr /r /c:"^-Djboss.server.base.dir" > nul && (

              for /f "tokens=1,2* delims==" %%a IN ("%CONSOLIDATED_OPTS%") DO (

                for /f %%i IN ("%%b") DO set "JBOSS_BASE_DIR=%%~fi"

              )

            )

            echo(%CONSOLIDATED_OPTS% | findstr /r /c:"^-Djboss.server.config.dir" > nul && (

              for /f "tokens=1,2* delims==" %%a IN ("%CONSOLIDATED_OPTS%") DO (

                for /f %%i IN ("%%b") DO set "JBOSS_CONFIG_DIR=%%~fi"

              )

            )

            echo(%CONSOLIDATED_OPTS% | findstr /r /c:"^-Djboss.server.log.dir" > nul && (

              for /f "tokens=1,2* delims==" %%a IN ("%CONSOLIDATED_OPTS%") DO (

                for /f %%i IN ("%%b") DO set "JBOSS_LOG_DIR=%%~fi"

              )

            )

             

             

            for /f "tokens=1* delims= " %%i IN ("%CONSOLIDATED_OPTS%") DO (

              if %%i == "" (

                goto ENDDIRLOOP

              ) else (

                set CONSOLIDATED_OPTS=%%j

                GOTO DIRLOOP

              )

            )

             

             

            :ENDDIRLOOP

             

             

            rem Set default module root paths

            if "x%JBOSS_MODULEPATH%" == "x" (

              set  "JBOSS_MODULEPATH=%JBOSS_HOME%\modules"

            )

             

             

            rem Set the standalone base dir

            if "x%JBOSS_BASE_DIR%" == "x" (

              set  "JBOSS_BASE_DIR=%JBOSS_HOME%\standalone"

            )

            rem Set the standalone log dir

            if "x%JBOSS_LOG_DIR%" == "x" (

              set  "JBOSS_LOG_DIR=%JBOSS_BASE_DIR%\log"

            )

            rem Set the standalone configuration dir

            if "x%JBOSS_CONFIG_DIR%" == "x" (

              set  "JBOSS_CONFIG_DIR=%JBOSS_BASE_DIR%/configuration"

            )

             

             

            echo ===============================================================================

            echo.

            echo   JBoss Bootstrap Environment

            echo.

            echo   JBOSS_HOME: %JBOSS_HOME%

            echo.

            echo   JAVA: %JAVA%

            echo.

            echo   JAVA_OPTS: %JAVA_OPTS%

            echo.

            echo ===============================================================================

            echo.

             

             

            :RESTART

            "%JAVA%" %JAVA_OPTS% ^

            "-Dorg.jboss.boot.log.file=%JBOSS_LOG_DIR%\server.log" ^

            "-Dlogging.configuration=file:%JBOSS_CONFIG_DIR%/logging.properties" ^

                -jar "%JBOSS_HOME%\jboss-modules.jar" ^

                -mp "%JBOSS_MODULEPATH%" ^

                -jaxpmodule "javax.xml.jaxp-provider" ^

                 org.jboss.as.standalone ^

                -Djboss.home.dir="%JBOSS_HOME%" ^

                 %SERVER_OPTS%

             

             

            if ERRORLEVEL 10 goto RESTART

             

             

            :END

            if "x%NOPAUSE%" == "x" pause

             

             

            :END_NO_PAUSE

             

             

            Here is the content of standalone-mdb-test.xml:

             

            <?xml version='1.0' encoding='UTF-8'?>

             

             

            <server xmlns="urn:jboss:domain:1.4">

             

             

                <extensions>

                    <extension module="org.jboss.as.clustering.infinispan"/>

                    <extension module="org.jboss.as.cmp"/>

                    <extension module="org.jboss.as.connector"/>

                    <extension module="org.jboss.as.deployment-scanner"/>

                    <extension module="org.jboss.as.ee"/>

                    <extension module="org.jboss.as.ejb3"/>

                    <extension module="org.jboss.as.jacorb"/>

                    <extension module="org.jboss.as.jaxr"/>

                    <extension module="org.jboss.as.jaxrs"/>

                    <extension module="org.jboss.as.jdr"/>

                    <extension module="org.jboss.as.jmx"/>

                    <extension module="org.jboss.as.jpa"/>

                    <extension module="org.jboss.as.jsf"/>

                    <extension module="org.jboss.as.jsr77"/>

                    <extension module="org.jboss.as.logging"/>

                    <extension module="org.jboss.as.mail"/>

                    <extension module="org.jboss.as.messaging"/>

                    <extension module="org.jboss.as.naming"/>

                    <extension module="org.jboss.as.pojo"/>

                    <extension module="org.jboss.as.remoting"/>

                    <extension module="org.jboss.as.sar"/>

                    <extension module="org.jboss.as.security"/>

                    <extension module="org.jboss.as.threads"/>

                    <extension module="org.jboss.as.transactions"/>

                    <extension module="org.jboss.as.web"/>

                    <extension module="org.jboss.as.webservices"/>

                    <extension module="org.jboss.as.weld"/>

                </extensions>

             

             

             

             

                <management>

                    <security-realms>

                        <security-realm name="ManagementRealm">

                            <authentication>

                                <local default-user="$local"/>

                                <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                            </authentication>

                        </security-realm>

                        <security-realm name="ApplicationRealm">

                            <authentication>

                                <local default-user="$local" allowed-users="*"/>

                                <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                            </authentication>

                            <authorization>

                                <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                            </authorization>

                        </security-realm>

                    </security-realms>

                    <management-interfaces>

                        <native-interface security-realm="ManagementRealm">

                            <socket-binding native="management-native"/>

                        </native-interface>

                        <http-interface security-realm="ManagementRealm">

                            <socket-binding http="management-http"/>

                        </http-interface>

                    </management-interfaces>

                </management>

             

             

                <profile>

                    <subsystem xmlns="urn:jboss:domain:logging:1.2">

                        <console-handler name="CONSOLE">

                            <level name="INFO"/>

                            <formatter>

                                <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                            </formatter>

                        </console-handler>

                        <periodic-rotating-file-handler name="FILE" autoflush="true">

                            <formatter>

                                <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                            </formatter>

                            <file relative-to="jboss.server.log.dir" path="server.log"/>

                            <suffix value=".yyyy-MM-dd"/>

                            <append value="true"/>

                        </periodic-rotating-file-handler>

                        <logger category="com.arjuna">

                            <level name="WARN"/>

                        </logger>

                        <logger category="org.apache.tomcat.util.modeler">

                            <level name="WARN"/>

                        </logger>

                        <logger category="org.jboss.as.config">

                            <level name="DEBUG"/>

                        </logger>

                        <logger category="sun.rmi">

                            <level name="WARN"/>

                        </logger>

                        <logger category="jacorb">

                            <level name="WARN"/>

                        </logger>

                        <logger category="jacorb.config">

                            <level name="ERROR"/>

                        </logger>

                        <root-logger>

                            <level name="INFO"/>

                            <handlers>

                                <handler name="CONSOLE"/>

                                <handler name="FILE"/>

                            </handlers>

                        </root-logger>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:cmp:1.1"/>

                    <subsystem xmlns="urn:jboss:domain:datasources:1.1">

                        <datasources>

                            <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">

                                <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>

                                <driver>h2</driver>

                                <security>

                                    <user-name>sa</user-name>

                                    <password>sa</password>

                                </security>

                            </datasource>

                            <drivers>

                                <driver name="h2" module="com.h2database.h2">

                                    <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>

                                </driver>

                            </drivers>

                        </datasources>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">

                        <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:ee:1.1">

                        <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>

                        <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:ejb3:1.4">

                        <session-bean>

                            <stateless>

                                <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>

                            </stateless>

                            <stateful default-access-timeout="5000" cache-ref="simple"/>

                            <singleton default-access-timeout="5000"/>

                        </session-bean>

                        <mdb>

                            <resource-adapter-ref resource-adapter-name="hornetq-ra"/>

                            <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                        </mdb>

                        <pools>

                            <bean-instance-pools>

                                <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                                <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                            </bean-instance-pools>

                        </pools>

                        <caches>

                            <cache name="simple" aliases="NoPassivationCache"/>

                            <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>

                        </caches>

                        <passivation-stores>

                            <file-passivation-store name="file"/>

                        </passivation-stores>

                        <async thread-pool-name="default"/>

                        <timer-service thread-pool-name="default">

                            <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>

                        </timer-service>

                        <remote connector-ref="remoting-connector" thread-pool-name="default"/>

                        <thread-pools>

                            <thread-pool name="default">

                                <max-threads count="10"/>

                                <keepalive-time time="100" unit="milliseconds"/>

                            </thread-pool>

                        </thread-pools>

                        <iiop enable-by-default="false" use-qualified-name="false"/>

                        <default-security-domain value="other"/>

                        <default-missing-method-permissions-deny-access value="true"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:infinispan:1.4">

                        <cache-container name="web" aliases="standard-session-cache" default-cache="local-web" module="org.jboss.as.clustering.web.infinispan">

                            <local-cache name="local-web" batching="true">

                                <file-store passivation="false" purge="false"/>

                            </local-cache>

                        </cache-container>

                        <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">

                            <local-cache name="entity">

                                <transaction mode="NON_XA"/>

                                <eviction strategy="LRU" max-entries="10000"/>

                                <expiration max-idle="100000"/>

                            </local-cache>

                            <local-cache name="local-query">

                                <transaction mode="NONE"/>

                                <eviction strategy="LRU" max-entries="10000"/>

                                <expiration max-idle="100000"/>

                            </local-cache>

                            <local-cache name="timestamps">

                                <transaction mode="NONE"/>

                                <eviction strategy="NONE"/>

                            </local-cache>

                        </cache-container>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:jacorb:1.3">

                        <orb socket-binding="jacorb" ssl-socket-binding="jacorb-ssl">

                            <initializers security="identity" transactions="spec"/>

                        </orb>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:jaxr:1.1">

                        <connection-factory jndi-name="java:jboss/jaxr/ConnectionFactory"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

                    <subsystem xmlns="urn:jboss:domain:jca:1.1">

                        <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>

                        <bean-validation enabled="true"/>

                        <default-workmanager>

                            <short-running-threads>

                                <core-threads count="50"/>

                                <queue-length count="50"/>

                                <max-threads count="50"/>

                                <keepalive-time time="10" unit="seconds"/>

                            </short-running-threads>

                            <long-running-threads>

                                <core-threads count="50"/>

                                <queue-length count="50"/>

                                <max-threads count="50"/>

                                <keepalive-time time="10" unit="seconds"/>

                            </long-running-threads>

                        </default-workmanager>

                        <cached-connection-manager/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>

                    <subsystem xmlns="urn:jboss:domain:jmx:1.2">

                        <expose-resolved-model/>

                        <expose-expression-model/>

                        <remoting-connector/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:jpa:1.1">

                        <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>

                    <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/>

                    <subsystem xmlns="urn:jboss:domain:mail:1.1">

                        <mail-session jndi-name="java:jboss/mail/Default">

                            <smtp-server outbound-socket-binding-ref="mail-smtp"/>

                        </mail-session>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:messaging:1.3">

                        <hornetq-server>

                            <persistence-enabled>true</persistence-enabled>

                            <journal-type>NIO</journal-type>

                            <journal-min-files>2</journal-min-files>

             

             

                            <connectors>

                                <netty-connector name="netty" socket-binding="messaging"/>

                                <netty-connector name="netty-throughput" socket-binding="messaging-throughput">

                                    <param key="batch-delay" value="50"/>

                                </netty-connector>

                                <in-vm-connector name="in-vm" server-id="0"/>

                            </connectors>

             

             

                            <acceptors>

                                <netty-acceptor name="netty" socket-binding="messaging"/>

                                <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">

                                    <param key="batch-delay" value="50"/>

                                    <param key="direct-deliver" value="false"/>

                                </netty-acceptor>

                                <in-vm-acceptor name="in-vm" server-id="0"/>

                            </acceptors>

             

             

                            <security-settings>

                                <security-setting match="#">

                                    <permission type="send" roles="guest"/>

                                    <permission type="consume" roles="guest"/>

                                </security-setting>

                            </security-settings>

             

             

                            <address-settings>

                                <address-setting match="#">

                                    <dead-letter-address>jms.queue.DLQ</dead-letter-address>

                                    <expiry-address>jms.queue.ExpiryQueue</expiry-address>

                                    <redelivery-delay>0</redelivery-delay>

                                    <max-size-bytes>10485760</max-size-bytes>

                                    <address-full-policy>BLOCK</address-full-policy>

                                    <message-counter-history-day-limit>10</message-counter-history-day-limit>

                                </address-setting>

                            </address-settings>

             

             

                            <jms-connection-factories>

                                <connection-factory name="InVmConnectionFactory">

                                    <connectors>

                                        <connector-ref connector-name="in-vm"/>

                                    </connectors>

                                    <entries>

                                        <entry name="java:/ConnectionFactory"/>

                                    </entries>

                                    <!--

                                    <connection-ttl>-1</connection-ttl>

                                    <client-failure-check-period>2147483646</client-failure-check-period>                      

                                    <reconnect-attempts>-1</reconnect-attempts>

                                    -->

                                </connection-factory>

                                <connection-factory name="RemoteConnectionFactory">

                                    <connectors>

                                        <connector-ref connector-name="netty"/>

                                    </connectors>

                                    <entries>

                                        <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>

                                    </entries>

                                </connection-factory>

                                <pooled-connection-factory name="hornetq-ra">

                                    <transaction mode="xa"/>

                                    <connectors>

                                        <connector-ref connector-name="in-vm"/>

                                    </connectors>

                                    <entries>

                                        <entry name="java:/JmsXA"/>

                                    </entries>

              <!-- Set the consumer window size to 0 to have *no* buffer on the client side -->

              <consumer-window-size>0</consumer-window-size>

                                </pooled-connection-factory>

                            </jms-connection-factories>

             

             

                            <jms-destinations>

                                <jms-queue name="testQueue">

                                    <entry name="queue/test"/>

                                    <entry name="java:jboss/exported/jms/queue/test"/>

                                </jms-queue>

                            </jms-destinations>

                        </hornetq-server>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:naming:1.3">

                        <remote-naming/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>

                    <subsystem xmlns="urn:jboss:domain:remoting:1.1">

                        <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>

                    <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

                    <subsystem xmlns="urn:jboss:domain:security:1.2">

                        <security-domains>

                            <security-domain name="other" cache-type="default">

                                <authentication>

                                    <login-module code="Remoting" flag="optional">

                                        <module-option name="password-stacking" value="useFirstPass"/>

                                    </login-module>

                                    <login-module code="RealmDirect" flag="required">

                                        <module-option name="password-stacking" value="useFirstPass"/>

                                    </login-module>

                                </authentication>

                            </security-domain>

                            <security-domain name="jboss-web-policy" cache-type="default">

                                <authorization>

                                    <policy-module code="Delegating" flag="required"/>

                                </authorization>

                            </security-domain>

                            <security-domain name="jboss-ejb-policy" cache-type="default">

                                <authorization>

                                    <policy-module code="Delegating" flag="required"/>

                                </authorization>

                            </security-domain>

                        </security-domains>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:threads:1.1"/>

                    <subsystem xmlns="urn:jboss:domain:transactions:1.3">

                        <core-environment>

                            <process-id>

                                <uuid/>

                            </process-id>

                        </core-environment>

                        <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                        <coordinator-environment default-timeout="300"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">

                        <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                        <virtual-server name="default-host" enable-welcome-root="true">

                            <alias name="localhost"/>

                            <alias name="example.com"/>

                        </virtual-server>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:webservices:1.2">

                        <modify-wsdl-address>true</modify-wsdl-address>

                        <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>

                        <endpoint-config name="Standard-Endpoint-Config"/>

                        <endpoint-config name="Recording-Endpoint-Config">

                            <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">

                                <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>

                            </pre-handler-chain>

                        </endpoint-config>

                        <client-config name="Standard-Client-Config"/>

                    </subsystem>

                    <subsystem xmlns="urn:jboss:domain:weld:1.0"/>

                </profile>

             

             

                <interfaces>

                    <interface name="management">

                        <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

                    </interface>

                    <interface name="public">

                        <inet-address value="${jboss.bind.address:127.0.0.1}"/>

                    </interface>

                    <interface name="unsecure">

                        <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>

                    </interface>

                </interfaces>

             

             

                <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

                    <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

                    <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

                    <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

                    <socket-binding name="ajp" port="9009"/>

                    <socket-binding name="http" port="9090"/>

                    <socket-binding name="https" port="9443"/>

                    <socket-binding name="jacorb" interface="unsecure" port="4528"/>

                    <socket-binding name="jacorb-ssl" interface="unsecure" port="4529"/>

                    <socket-binding name="messaging" port="6445"/>

                    <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>

                    <socket-binding name="messaging-throughput" port="6455"/>

                    <socket-binding name="remoting" port="6447"/>

                    <socket-binding name="txn-recovery-environment" port="5712"/>

                    <socket-binding name="txn-status-manager" port="5713"/>

                    <outbound-socket-binding name="mail-smtp">

                        <remote-destination host="localhost" port="25"/>

                    </outbound-socket-binding>

                </socket-binding-group>

             

             

            </server>

             

             

            I hope this helps!

            • 3. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
              Mustafa Musaji Novice

              I can't see what the problem is from the configuration. However, the only time I can reproduce this locally (Linux machine) is when I provide invalid arguments during JBoss start up. So somewhere, you're providing wrong arguments on start up.

               

              If I do ./standalone.sh -l I get 10:22:14,899 ERROR [stderr] (main) JBAS015801: Invalid option '-l'

               

              Wipe everything down, use the standard configuration and see if that works and try and narrow down where this option is being inserted.

               

              Mus

              • 6. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                jure12347 Newbie

                I still get the same error.

                 

                Can you pls test it on windows 8 64 bit?

                • 7. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                  Mustafa Musaji Novice

                  I don't have a Windows machine handy sorry. We know this works on Windows so the error is more than likely related to your set up or config. Try it using the normal standalone.xml and see if it starts up?

                  • 8. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                    jaikiran pai Master

                    I suspect one of those files, probably the standalone.conf.bat, was opened in some text editor which messed up the character encoding. Did you do any copy/paste into files?

                    • 9. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                      Tomaz Cerar Master

                      jure12347 wrote:

                       

                      I still get the same error.

                       

                      Can you pls test it on windows 8 64 bit?

                      Works just fine on

                      - Windows 8.1 64bit,

                      - Windows 8.0 64bit

                      - Windows 7 64 & 32bit

                      - Windows Server 2008, 2008R2, 2012, 2012R2

                       

                      I would check if you have JAVA_OPTS set in your enviroment.

                       

                      try doing

                      set JAVA_OPTS=

                      set JBOSS_HOME=

                      (mind that there is no space after =)

                      and run standalone.bat again.

                      • 10. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                        jure12347 Newbie

                        Hi there!

                         

                        Yes i modified standalone.conf.bat with modified space allocation (512M) in notepad.

                         

                        Could notepad break formating?

                        • 11. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                          jaikiran pai Master

                          Jure Zajnic wrote:

                           

                           

                          Could notepad break formating?

                          Not sure, I don't use Windows OS. You can easily test it out by copying (overwriting) a fresh copy of the standalone.conf.bat to the one that you edited and checking if it starts up fine.

                          • 12. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                            jure12347 Newbie

                            Hi there,

                             

                            my cmd writes this on starting up jboss:

                             

                            JBoss Bootstrap Environment

                             

                             

                            JBOSS_HOME: D:\Jure\jboss eap\jboss-eap-6.1

                             

                             

                            JAVA: C:\Program Files (x86)\Java\jdk1.7.0_79\jre\bin\java

                             

                             

                            JAVA_OPTS: -client -Dprogram.name=standalone.bat -Xms512M -Xmx512M -XX:MaxPermSize=512M -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman

                             

                             

                            Is this ok?

                            • 13. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                              jure12347 Newbie

                              It wont, because it seys heap memory is insufficient.

                              • 14. Re: JBAS015801: Invalid option 'ľc' in Jboss EAP 6.1
                                jaikiran pai Master

                                So this looks fine now - at least it isn't throwing an error about some invalid character.

                                1 2 Previous Next