10 Replies Latest reply on Nov 10, 2015 4:07 PM by Sverker Abrahamsson

    Arquillian plugin for Eclipse Mars?

    Sverker Abrahamsson Newbie

      Hi,

      I have Eclipse 4.5.1 (Mars.1) on which I have installed JBoss Tools 4.3.0. In Installation details it shows that I have "Arquillian support (Experimental)" version 1.2.0.Final-v20150925-0253-B27.

       

      However, that is all I see of it. On the project there is no option under Configure to add Arquillian support. If I run an Arquillian JUnit test it just prints out a debug log line and then terminates without telling anything about what went wrong, neither in console nor in .log.

       

      If I run maven then it starts up wildfly fine, I use wildfly-arquillian-container-managed version 1.0.1.Final with Wildfly 9.0.1.Final. One thing is odd though, if I enable debug socket and tell it to suspend it does wait for eclipse to connect and when the connection is done it continues the startup. BUT it will not activate any breakpoints.

       

      If I do the same on a running wildfly it attaches fine and breakpoints are working as expected.

       

      What am I missing?