1 Reply Latest reply on Mar 29, 2016 12:00 PM by Ramesh Reddy

    Creation of File and Ldap Resource Adapter

    Mirco Marchitiello Newbie

      Hi,

      trying to craete a resource adapter using the jboss-cli utility we get an error during the activation of the adapter:

       

      jboss-cli -c --file=create-ldap-ds.cli   --properties=create-ldap-ds.properties


      ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 49)  WFLYCTL0013: Operation ("add") failed - address: ([
          ("subsystem" => "resource-adapters"),
          ("resource-adapter" => "ldap")
      ]) - failure description: "WFLYJCA0080: RAR 'ldap' not yet deployed."


      We have found that the problem could be the name of the directory containing the Teiid directory (on Microsoft Windows server 2012).

      In the error scenario we put Teiid directory under "Program Files" on in another directory with a space in the name

      We tried to move Teiid directory under the root directory (c:\) or a directory without a space in the name and the installation worked properly

       

      thank,

      Mirco