after some time, I'm reopening the issue related to renaming of MavenImporter class. There where some discussions around that on Jira , GitHub  and on Andrew's Twitter . However, there was no agreement on the name. Additionally, I think that subsequently the whole API should change as well and that hasn't been solved either.
First of all I'd like to ask you:
Does anyone use this feature (MavenImporter) or is interested in it? I want to find out whether the effort of renaming/refactoring and maybe some additional implementation would be worth it...
Having considered all the suggestions and approaches I'm proposing three options (the first one is my favorite :-)):
ShrinkWrap.create(ArchiveMavenAssembler.class, "archive.war") .configuredFromFile("/path/to/settings.xml") .usingPomFile("/path/to/pom") .withBuildOutput() .withTestBuildOutput() .withDependencies() .as(WebArchive.class)
ShrinkWrap.create(ArchiveMavenAssembler.class) .configuredFromFile("/path/to/settings.xml") .usingPomFile("/path/to/pom") .addBuildOutput() .addTestBuildOutput() .addDependencies() .produce(WebArchive.class, "archive.war");
ShrinkWrap.create(ArchiveUsingMaven.class, "archive.war") .withMavenConfiguredFromFile("/path/to/settings.xml") .withPomLoadedFromFile("/path/to/pom") .addBuildOutput() .addTestBuildOutput() .addDependencies() .as(WebArchive.class);
Do you like it or do you hate it? Please tell me what you think...
I guess that EmbeddedGradleImporter should be renamed as well. Too keep the names consistent I would choose ArchiveGradleAssembler (ArchiveUsingGradle). The API could be the same as it is now except for methods "importBuildOutput" - they would be renamed analogically.
The current implementation (API) will be kept till next major release and marked as "@Depracated".