1 2 Previous Next 16 Replies Latest reply on Jun 7, 2016 5:09 PM by Tomaz Cerar

    [error] proxy: CLUSTER: (balancer://clustername). All workers are in error state

    Klemen Vicic Newbie

      Hello, we have a problem in Wildfly cluster. The problem is appearing on different hours, on different server loads and least different time. After a time servers are working normal again without intervention.  The error in Apache logs is:

      [Sat May 21 09:58:26 2016] [error] (70007)The timeout specified has expired: proxy: AJP: attempt to connect to instanceIP:19009 (instanceIP) failed

      [Sat May 21 09:58:26 2016] [error] ap_proxy_connect_backend disabling worker for (instanceIP)

      [Sat May 21 09:58:26 2016] [error] proxy: AJP: failed to make connection to backend: instanceIP

      [Sat May 21 09:58:26 2016] [error] proxy: CLUSTER: (balancer://instanceNAME). All workers are in error state

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] Connection closed to child 52 with standard shutdown (server URL:443)

      [Sat May 21 09:58:26 2016] [info] Subsequent (No.3) HTTPS request received for child 60 (server URL:443)

      [Sat May 21 09:58:26 2016] [info] Subsequent (No.4) HTTPS request received for child 60 (server URL:443)

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] (104)Connection reset by peer: SSL input filter read failed.

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] (32)Broken pipe: core_output_filter: writing data to the network

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] Connection closed to child 60 with standard shutdown (server URL:443)

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] (70007)The timeout specified has expired: SSL input filter read failed.

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] Connection closed to child 6 with standard shutdown (server URL:443)

      [Sat May 21 09:58:26 2016] [info] [client sourceIP] Connection to child 23 established (server URL:443)

      [Sat May 21 09:58:26 2016] [info] Seeding PRNG with 144 bytes of entropy

      [Sat May 21 09:58:26 2016] [info] Initial (No.1) HTTPS request received for child 23 (server URL:443)

      [Sat May 21 09:58:26 2016] [error] proxy: CLUSTER: (balancer://instanceNAME). All workers are in error state

       

      Architecture is two Apache servers on SUSElinux in high availability mode and two Wildfly servers under with mod_cluster, same on SUSElinux. Servers are working in load balance.
      Apache configuration:

       

      mod_cluster.conf

      #

      # This is mod_cluster module configuration file.

      # Please refer to online documentation for configuration options.

      #

      LoadModule proxy_module         /usr/lib64/apache2/mod_proxy.so

      LoadModule proxy_ajp_module     /usr/lib64/apache2/mod_proxy_ajp.so

      LoadModule slotmem_module       /usr/lib64/apache2/mod_slotmem.so

      LoadModule proxy_cluster_module /usr/lib64/apache2/mod_proxy_cluster.so

      # LoadModule advertise_module     /usr/lib64/apache2/mod_advertise.so

      LoadModule manager_module       /usr/lib64/apache2/mod_manager.so

       

       

      MemManagerFile /var/cache/apache2

       

       

      PersistSlots On

       

       

      CreateBalancers 0

      UseAlias 1

       

       

      MaxHost 40

      MaxContext 150

       

      vhosts

      <Location /mod_cluster-manager>

              SetHandler mod_cluster-manager

              Order Allow,Deny

              Allow from all

          </Location>

       

       

          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

       

       

      ManagerBalancerName

          AllowDisplay On

          AllowCmd Off

          EnableMCPMReceive true

          #ServerAdvertise Off

       

      wildfly

      <?xml version="1.0" ?>

       

       

      <server name="rom1" xmlns="urn:jboss:domain:3.0">

          <extensions>

              <extension module="org.jboss.as.clustering.infinispan"/>

              <extension module="org.jboss.as.clustering.jgroups"/>

              <extension module="org.jboss.as.connector"/>

              <extension module="org.jboss.as.deployment-scanner"/>

              <extension module="org.jboss.as.ee"/>

              <extension module="org.jboss.as.ejb3"/>

              <extension module="org.jboss.as.jaxrs"/>

              <extension module="org.jboss.as.jdr"/>

              <extension module="org.jboss.as.jmx"/>

              <extension module="org.jboss.as.jpa"/>

              <extension module="org.jboss.as.jsf"/>

              <extension module="org.jboss.as.logging"/>

              <extension module="org.jboss.as.mail"/>

              <extension module="org.jboss.as.modcluster"/>

              <extension module="org.jboss.as.naming"/>

              <extension module="org.jboss.as.pojo"/>

              <extension module="org.jboss.as.remoting"/>

              <extension module="org.jboss.as.sar"/>

              <extension module="org.jboss.as.security"/>

              <extension module="org.jboss.as.transactions"/>

              <extension module="org.jboss.as.webservices"/>

              <extension module="org.jboss.as.weld"/>

              <extension module="org.wildfly.extension.batch"/>

              <extension module="org.wildfly.extension.bean-validation"/>

              <extension module="org.wildfly.extension.io"/>

              <extension module="org.wildfly.extension.request-controller"/>

              <extension module="org.wildfly.extension.security.manager"/>

              <extension module="org.wildfly.extension.undertow"/>

          </extensions>

       

       

       

       

          <system-properties>

              <property name="LOG_PATH" value="/var/log/wildfly/rom1/log/"/>

              <property name="FILE_PATH" value="/var/log/wildfly/rom1/log/file/"/>

              <property name="CONFIG_PATH" value="WEB-INF/config.prod.01/"/>

              <property name="CONFIG_PATH_MULTI" value="WEB-INF/config"/>

              <property name="server_port" value="19009"/>

              <property name="server_addr" value="server-ip"/>

          </system-properties>

       

       

          <paths>

              <path name="instance.log.dir" path="/var/log/wildfly/rom1/log"/>

          </paths>

       

       

          <vault>

              <vault-option name="KEYSTORE_URL" value="/opt/wildfly/rom1/vault/vault.jks"/>

              <vault-option name="KEYSTORE_PASSWORD" value="MASK-"/>

              <vault-option name="KEYSTORE_ALIAS" value="rom1Vault"/>

              <vault-option name="SALT" value=""/>

              <vault-option name="ITERATION_COUNT" value="44"/>

              <vault-option name="ENC_FILE_DIR" value="/opt/wildfly/rom1/vault/vault/"/>

          </vault>

       

       

          <management>

              <security-realms>

                  <security-realm name="ManagementRealm">

                      <authentication>

                          <local default-user="$local" skip-group-loading="true"/>

                          <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                      <authorization map-groups-to-roles="false">

                          <properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>

                      </authorization>

                  </security-realm>

                  <security-realm name="ApplicationRealm">

                      <authentication>

                          <local default-user="$local" allowed-users="*" skip-group-loading="true"/>

                          <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                      <authorization>

                          <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                      </authorization>

                  </security-realm>

                  <security-realm name="ADManagementRealm">

                      <authentication>

                          <ldap connection="ADconnection" base-dn="OU=Site,OU=AdminAccounts,OU=map,DC=map,DC=pri" recursive="true">

                              <advanced-filter filter="(sAMAccountName={0})"/>

                          </ldap>

                      </authentication>

                  </security-realm>

                  <security-realm name="ADSSLCertificates">

                      <authentication>

                          <truststore path="/opt/wildfly/rom1/ssl/.jks" keystore-password=""/>

                      </authentication>

                  </security-realm>

              </security-realms>

              <outbound-connections>

                  <ldap name="ADconnection" url="ldap://:636 ldap://:636" search-dn="${VAULT::AD::user::1}" search-credential="${VAULT::AD::password::1}" security-realm="ADSSLCertificates"/>

              </outbound-connections>

              <audit-log>

                  <formatters>

                      <json-formatter name="json-formatter"/>

                  </formatters>

                  <handlers>

                      <file-handler name="file" formatter="json-formatter" relative-to="jboss.server.data.dir" path="audit-log.log"/>

                  </handlers>

                  <logger log-boot="true" log-read-only="false" enabled="false">

                      <handlers>

                          <handler name="file"/>

                      </handlers>

                  </logger>

              </audit-log>

              <management-interfaces>

                  <http-interface security-realm="ADManagementRealm" http-upgrade-enabled="true">

                      <socket-binding http="management-http"/>

                  </http-interface>

              </management-interfaces>

              <access-control provider="simple">

                  <role-mapping>

                      <role name="SuperUser">

                          <include>

                              <user name="$local"/>

                          </include>

                      </role>

                  </role-mapping>

              </access-control>

          </management>

          <profile>

              <subsystem xmlns="urn:jboss:domain:logging:3.0">

                  <console-handler name="CONSOLE">

                      <level name="INFO"/>

                      <formatter>

                          <named-formatter name="COLOR-PATTERN"/>

                      </formatter>

                  </console-handler>

                  <periodic-rotating-file-handler name="FILE" autoflush="true">

                      <formatter>

                          <named-formatter name="PATTERN"/>

                      </formatter>

                      <file relative-to="instance.log.dir" path="server.log"/>

                      <suffix value=".yyyy-MM-dd"/>

                      <append value="true"/>

                  </periodic-rotating-file-handler>

                  <logger category="com.arjuna">

                      <level name="WARN"/>

                  </logger>

                  <logger category="org.apache.tomcat.util.modeler">

                      <level name="WARN"/>

                  </logger>

                  <logger category="org.jboss.as.config">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="sun.rmi">

                      <level name="WARN"/>

                  </logger>

                  <logger category="jacorb">

                      <level name="WARN"/>

                  </logger>

                  <logger category="jacorb.config">

                      <level name="ERROR"/>

                  </logger>

                  <root-logger>

                      <level name="INFO"/>

                      <handlers>

                          <handler name="CONSOLE"/>

                          <handler name="FILE"/>

                      </handlers>

                  </root-logger>

                  <formatter name="PATTERN">

                      <pattern-formatter pattern="%d{yyyy-MM-dd HH:mm:ss,SSS} %-5p [%c] (%t) %s%e%n"/>

                  </formatter>

                  <formatter name="COLOR-PATTERN">

                      <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%e%n"/>

                  </formatter>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:batch:1.0">

                  <job-repository>

                      <in-memory/>

                  </job-repository>

                  <thread-pool>

                      <max-threads count="10"/>

                      <keepalive-time time="30" unit="seconds"/>

                  </thread-pool>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:bean-validation:1.0"/>

              <subsystem xmlns="urn:jboss:domain:datasources:3.0">

                  <datasources>

                      <datasource jta="false" jndi-name="java:/jdbc/atmwebds" pool-name="jdbc/atmwebds" enabled="true" use-ccm="false">

                          <connection-url>jdbc:db2://:50050/db|jdbc:db2://:50050/db|jdbc:db2://:50050/db|jdbc:db2://50050/db</connection-url>

                          <connection-property name="loginTimeout">

                              5

                          </connection-property>

                          <connection-property name="enableSeamlessFailover">

                              1

                          </connection-property>

                          <connection-property name="clientProgramName">

                              Instance Name

                          </connection-property>

                          <connection-property name="retrieveMessagesFromServerOnGetMessage">

                              true

                          </connection-property>

                          <connection-property name="maxRetriesForClientReroute">

                              12

                          </connection-property>

                          <connection-property name="retryIntervalForClientReroute">

                              5

                          </connection-property>

                          <connection-property name="blockingReadConnectionTimeout">

                              120

                          </connection-property>

                          <driver>db2jcc4</driver>

                          <url-delimiter>|</url-delimiter>

                          <security>

                              <user-name>${VAULT::DB::user::xxxx=}</user-name>

                              <password>${VAULT::DB::password::xxxx=}</password>

                          </security>

                      

      <validation>

                              <valid-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.db2.DB2ValidConnectionChecker"/>

                              <stale-connection-checker class-name="org.jboss.jca.adapters.jdbc.extensions.db2.DB2StaleConnectionChecker"/>

                              <exception-sorter class-name="org.jboss.jca.adapters.jdbc.extensions.db2.DB2ExceptionSorter"/>

                          </validation>

                          <statement>

                              <share-prepared-statements>false</share-prepared-statements>

                          </statement>

                      </datasource>

                      <drivers>

                          <driver name="db2jcc4" module="com.ibm.db2">

                              <xa-datasource-class>com.ibm.db2.jcc.DB2XADataSource</xa-datasource-class>

                          </driver>

                      </drivers>

                  </datasources>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0">

                  <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="0" runtime-failure-causes-rollback="${jboss.deployment.scanner.rollback.on.failure:false}"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ee:3.0">

                  <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>

                  <concurrent>

                      <context-services>

                          <context-service name="default" jndi-name="java:jboss/ee/concurrency/context/default" use-transaction-setup-provider="true"/>

                      </context-services>

                      <managed-thread-factories>

                          <managed-thread-factory name="default" jndi-name="java:jboss/ee/concurrency/factory/default" context-service="default"/>

                      </managed-thread-factories>

                      <managed-executor-services>

                          <managed-executor-service name="default" jndi-name="java:jboss/ee/concurrency/executor/default" context-service="default" hung-task-threshold="60000" core-threads="5" max-threads="25" keepalive-time="5000"/>

                      </managed-executor-services>

                      <managed-scheduled-executor-services>

                          <managed-scheduled-executor-service name="default" jndi-name="java:jboss/ee/concurrency/scheduler/default" context-service="default" hung-task-threshold="60000" core-threads="2" keepalive-time="3000"/>

                      </managed-scheduled-executor-services>

                  </concurrent>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ejb3:3.0">

                  <session-bean>

                      <stateful default-access-timeout="5000" cache-ref="distributable" passivation-disabled-cache-ref="simple"/>

                      <singleton default-access-timeout="5000"/>

                  </session-bean>

                  <pools>

                      <bean-instance-pools>

                          <!-- A sample strict max pool configuration -->

                          <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                          <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                      </bean-instance-pools>

                  </pools>

                  <caches>

                      <cache name="simple"/>

                      <cache name="distributable" aliases="passivating clustered" passivation-store-ref="infinispan"/>

                  </caches>

                  <passivation-stores>

                      <passivation-store name="infinispan" cache-container="ejb" max-size="10000"/>

                  </passivation-stores>

                  <async thread-pool-name="default"/>

                  <timer-service thread-pool-name="default" default-data-store="default-file-store">

                      <data-stores>

                          <file-data-store name="default-file-store" path="timer-service-data" relative-to="jboss.server.data.dir"/>

                      </data-stores>

                  </timer-service>

                  <remote connector-ref="http-remoting-connector" thread-pool-name="default"/>

                  <thread-pools>

                      <thread-pool name="default">

                          <max-threads count="10"/>

                          <keepalive-time time="100" unit="milliseconds"/>

                      </thread-pool>

                  </thread-pools>

                  <default-security-domain value="other"/>

                  <default-missing-method-permissions-deny-access value="true"/>

                  <log-system-exceptions value="true"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:io:1.1">

                  <worker name="default"/>

                  <buffer-pool name="default"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:infinispan:3.0">

                  <cache-container name="server" default-cache="default" module="org.wildfly.clustering.server" aliases="singleton cluster">

                      <transport lock-timeout="60000"/>

                      <replicated-cache name="default" mode="SYNC">

                          <transaction mode="BATCH"/>

                      </replicated-cache>

                  </cache-container>

                  <cache-container name="web" default-cache="dist" module="org.wildfly.clustering.web.infinispan">

                      <transport lock-timeout="60000"/>

                      <distributed-cache name="dist" mode="ASYNC" owners="2" l1-lifespan="0">

                          <locking isolation="REPEATABLE_READ"/>

                          <transaction mode="BATCH"/>

                          <file-store/>

                      </distributed-cache>

                  </cache-container>

                  <cache-container name="ejb" default-cache="dist" module="org.wildfly.clustering.ejb.infinispan" aliases="sfsb">

                      <transport lock-timeout="60000"/>

                      <distributed-cache name="dist" mode="ASYNC" owners="2" l1-lifespan="0">

                          <locking isolation="REPEATABLE_READ"/>

                          <transaction mode="BATCH"/>

                          <file-store/>

                      </distributed-cache>

                  </cache-container>

                  <cache-container name="hibernate" default-cache="local-query" module="org.hibernate.infinispan">

                      <transport lock-timeout="60000"/>

                      <local-cache name="local-query">

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <invalidation-cache name="entity" mode="SYNC">

                          <transaction mode="NON_XA"/>

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </invalidation-cache>

                      <replicated-cache name="timestamps" mode="ASYNC"/>

                  </cache-container>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jca:3.0">

                  <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>

                  <bean-validation enabled="true"/>

                  <default-workmanager>

                      <short-running-threads>

                          <core-threads count="50"/>

                          <queue-length count="50"/>

                          <max-threads count="50"/>

                          <keepalive-time time="10" unit="seconds"/>

                      </short-running-threads>

                      <long-running-threads>

                          <core-threads count="50"/>

                          <queue-length count="50"/>

                          <max-threads count="50"/>

                          <keepalive-time time="10" unit="seconds"/>

                      </long-running-threads>

                  </default-workmanager>

                  <cached-connection-manager/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jgroups:3.0">

                  <channels default="ee">

                      <channel name="ee"/>

                  </channels>

                  <stacks default="udp">

                      <stack name="udp">

                          <transport type="UDP" socket-binding="jgroups-udp"/>

                          <protocol type="PING"/>

                          <protocol type="MERGE3"/>

                          <protocol type="FD_SOCK" socket-binding="jgroups-udp-fd"/>

                          <protocol type="FD_ALL"/>

                          <protocol type="VERIFY_SUSPECT"/>

                          <protocol type="pbcast.NAKACK2"/>

                          <protocol type="UNICAST3"/>

                          <protocol type="pbcast.STABLE"/>

                          <protocol type="pbcast.GMS"/>

                          <protocol type="UFC"/>

                          <protocol type="MFC"/>

                          <protocol type="FRAG2"/>

                          <protocol type="RSVP"/>

                      </stack>

                      <stack name="tcp">

                          <transport type="TCP" socket-binding="jgroups-tcp"/>

                          <protocol type="MPING" socket-binding="jgroups-mping"/>

                          <protocol type="MERGE3"/>

                          <protocol type="FD_SOCK" socket-binding="jgroups-tcp-fd"/>

                          <protocol type="FD"/>

                          <protocol type="VERIFY_SUSPECT"/>

                          <protocol type="pbcast.NAKACK2"/>

                          <protocol type="UNICAST3"/>

                          <protocol type="pbcast.STABLE"/>

                          <protocol type="pbcast.GMS"/>

                          <protocol type="MFC"/>

                          <protocol type="FRAG2"/>

                          <protocol type="RSVP"/>

                      </stack>

                  </stacks>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jmx:1.3">

                  <expose-resolved-model/>

                  <expose-expression-model/>

                  <remoting-connector/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jpa:1.1">

                  <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>

              <subsystem xmlns="urn:jboss:domain:mail:2.0">

                  <mail-session name="default" jndi-name="java:jboss/mail/Default">

                      <smtp-server outbound-socket-binding-ref="mail-smtp"/>

                  </mail-session>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:modcluster:2.0">

                  <mod-cluster-config advertise-socket="modcluster" proxies="modcluster-proxy" balancer="balancername" advertise="false" sticky-session="false" sticky-session-force="false" load-balancing-group="group" connector="ajp">

                      <dynamic-load-provider>

                          <load-metric type="cpu"/>

                      </dynamic-load-provider>

                      <ssl key-alias="rom1" password="${VAULT::SSL::password::1}" certificate-key-file="/opt/wildfly/rom1/ssl/rom1.jks" cipher-suite="ALL" protocol="TLSv1"  ca-certificate-file="/opt/wildfly/rom1/ssl/rom1.jks"/>

                  </mod-cluster-config>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:naming:2.0">

                  <remote-naming/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>

              <subsystem xmlns="urn:jboss:domain:remoting:3.0">

                  <endpoint worker="default"/>

                  <http-connector name="http-remoting-connector" connector-ref="default" security-realm="ApplicationRealm"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:resource-adapters:3.0"/>

              <subsystem xmlns="urn:jboss:domain:request-controller:1.0"/>

              <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

              <subsystem xmlns="urn:jboss:domain:security-manager:1.0">

                  <deployment-permissions>

                      <maximum-set>

                          <permission class="java.security.AllPermission"/>

                      </maximum-set>

                  </deployment-permissions>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:security:1.2">

                  <security-domains>

                      <security-domain name="other" cache-type="default">

                          <authentication>

                              <login-module code="Remoting" flag="optional">

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                              <login-module code="RealmDirect" flag="required">

                                  <module-option name="password-stacking" value="useFirstPass"/>

                              </login-module>

                          </authentication>

                      </security-domain>

                      <security-domain name="jboss-web-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                      <security-domain name="jboss-ejb-policy" cache-type="default">

                          <authorization>

                              <policy-module code="Delegating" flag="required"/>

                          </authorization>

                      </security-domain>

                  </security-domains>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:transactions:3.0">

                  <core-environment>

                      <process-id>

                          <uuid/>

                      </process-id>

                  </core-environment>

                  <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:undertow:2.0">

                  <buffer-cache name="default"/>

                  <server name="default-server">

                      <ajp-listener name="ajp" socket-binding="ajp"/>

                      <http-listener name="default" socket-binding="http" redirect-socket="https"/>

                      <host name="default-host" alias="rom.activa.si, apache-VIP-IP">

                          <location name="/" handler="welcome-content"/>

                          <filter-ref name="server-header"/>

                          <filter-ref name="x-powered-by-header"/>

                      </host>

                  </server>

                  <servlet-container name="default">

                      <jsp-config/>

                      <websockets/>

                  </servlet-container>

                  <handlers>

                      <file name="welcome-content" path="${jboss.home.dir}/welcome-content"/>

                  </handlers>

                  <filters>

                      <response-header name="server-header" header-name="Server" header-value="WildFly/9"/>

                      <response-header name="x-powered-by-header" header-name="X-Powered-By" header-value="Undertow/1"/>

                  </filters>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:webservices:2.0">

                  <wsdl-host>${jboss.bind.address:server-ip}</wsdl-host>

                  <endpoint-config name="Standard-Endpoint-Config"/>

                  <endpoint-config name="Recording-Endpoint-Config">

                      <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">

                          <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>

                      </pre-handler-chain>

                  </endpoint-config>

                  <client-config name="Standard-Client-Config"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:weld:2.0"/>

          </profile>

          <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:server-ip}"/>

              </interface>

              <interface name="public">

                  <inet-address value="${jboss.bind.address:server-ip}"/>

              </interface>

              <!-- TODO - only show this if the jacorb subsystem is added  -->

              <interface name="unsecure">

                  <!--

                    ~  Used for IIOP sockets in the standard configuration.

                    ~                  To secure JacORB you need to setup SSL

                    -->

                  <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>

              </interface>

          </interfaces>

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:12000}">

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/>

              <socket-binding name="ajp" port="${jboss.ajp.port:8009}"/>

              <socket-binding name="http" port="${jboss.http.port:8080}"/>

              <socket-binding name="https" port="${jboss.https.port:8443}"/>

              <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700"/>

              <socket-binding name="jgroups-tcp" port="7600"/>

              <socket-binding name="jgroups-tcp-fd" port="57600"/>

              <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45688"/>

              <socket-binding name="jgroups-udp-fd" port="54200"/>

              <socket-binding name="modcluster" port="0" multicast-address="224.0.1.105" multicast-port="23364"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <outbound-socket-binding name="mail-smtp">

                  <remote-destination host="localhost" port="25"/>

              </outbound-socket-binding>

              <outbound-socket-binding name="modcluster-proxy">

                  <remote-destination host="apache-VIP-IP" port="443"/>

              </outbound-socket-binding>

          </socket-binding-group>

      </server>

       

      Thank you for any help!

      klemen

        1 2 Previous Next