5 Replies Latest reply on Jun 22, 2016 9:23 AM by Esakki Sundar Varatharajan

    Could not deploy web application with jbpm to Jboss EAP 6.1.0

    Esakki Sundar Varatharajan Newbie

      Hi,

          I'm trying to deploy a web application which has JBPM built in. This war file when deployed to Tomcat works fine. However when I try to deploy to Jboss EAP 6.1.0, I get below error. I am attaching the list of jars in my war. I have also added kie-remote-services-6.2.0.Final.jar, kie-remote-ws-wsdl-cmd-6.1.0.Beta4.jar, kie-remote-services-6.2.0.Final.jar to the lib folder of jboss (jboss-eap-6.1\standalone\lib) Please suggest what should be done to resolve this error. Thanks a lot for your help and support.

       

      11:39:38,361 WARN  [org.jboss.modules] (MSC service thread 1-2) Failed to define class org.kie.remote.services.ws.command.CommandWebServiceImpl in Module "deployment.xyzwar:main" from

      Service Module Loader: java.lang.LinkageError: Failed to link org/kie/remote/services/ws/command/CommandWebServiceImpl (Module "deployment.xyzwar:main" from Service Module Loader)

        at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:427) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:260) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:75) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.Module.loadModuleClass(Module.java:526) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:188) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at java.lang.Class.forName0(Native Method) [rt.jar:1.7.0_45]

        at java.lang.Class.forName(Class.java:270) [rt.jar:1.7.0_45]

        at org.jboss.as.server.deployment.reflect.DeploymentClassIndex.classIndex(DeploymentClassIndex.java:54)

        at org.jboss.as.ee.component.deployers.InterceptorAnnotationProcessor.processComponentConfig(InterceptorAnnotationProcessor.java:85) [jboss-as-ee-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]

        at org.jboss.as.ee.component.deployers.InterceptorAnnotationProcessor.deploy(InterceptorAnnotationProcessor.java:77) [jboss-as-ee-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]

        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)

        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_45]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_45]

        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

      Caused by: java.lang.NoClassDefFoundError: org/kie/remote/services/ws/wsdl/generated/CommandWebService

        at java.lang.ClassLoader.defineClass1(Native Method) [rt.jar:1.7.0_45]

        at java.lang.ClassLoader.defineClass(ClassLoader.java:800) [rt.jar:1.7.0_45]

        at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:344) [jboss-modules.jar:1.2.0.Final-redhat-1]

        at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:422) [jboss-modules.jar:1.2.0.Final-redhat-1]

        ... 19 more

        • 1. Re: Could not deploy web application with jbpm to Jboss EAP 6.1.0
          Esakki Sundar Varatharajan Newbie

          Update

               I tried to resolve the above error by adding many jars to my application WEB-INF/lib folder. Now when the application starts its throwing the below error. Please suggest how to resolve this error.

           

          10:58:20,827 INFO  [org.drools.compiler.kie.builder.impl.KieRepositoryImpl] (MSC service thread 1-6) KieModule was added:ZipKieModule

          [ ReleaseId=org.drools:drools-pmml:6.1.0.Finalfile=\Software\jboss-eap-6.1.0\jboss-eap-6.1\standalone\tmp\vfs\deploymentf99f95af8c3984a1\drools-pmml-6.1.0.Final.jar-dba8ebccae874521\drools-pmml-6.1.0.Final.jar]

          10:58:20,932 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.deployment.unit."myApp.war".WeldStartService: org.jboss.msc.service.StartException

          in service jboss.deployment.unit."myApp.war".WeldStartService: Failed to start service

                  at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

                  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_45]

                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_45]

                  at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]

          Caused by: org.jboss.weld.exceptions.DeploymentException: WELD-001408 Unsatisfied dependencies for type [EntityManagerFactory] with qualifiers [@Default] at injection point [[field] @PersistenceUnit @Inject private org.jbpm.executor.impl.jpa.JPAExecutorServiceProducer.emf]

                  at org.jboss.weld.bootstrap.Validator.validateInjectionPoint(Validator.java:311)

                  at org.jboss.weld.bootstrap.Validator.validateInjectionPoint(Validator.java:280)

                  at org.jboss.weld.bootstrap.Validator.validateBean(Validator.java:143)

                  at org.jboss.weld.bootstrap.Validator.validateRIBean(Validator.java:163)

                  at org.jboss.weld.bootstrap.Validator.validateBeans(Validator.java:382)

                  at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:367)

                  at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:379)

                  at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64)

                  at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

                  at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

          • 2. Re: Could not deploy web application with jbpm to Jboss EAP 6.1.0
            Amit Nijhawan Newbie

            Hi,

            You might be missed the CDI producer method for the EMF, Please check once.

            See: Chapter 20. Integration

            Regards,

            -A

            • 3. Re: Could not deploy web application with jbpm to Jboss EAP 6.1.0
              Esakki Sundar Varatharajan Newbie

              Hi Amit,

                   I added the below classes. Im still getting the same error (Caused by: org.jboss.weld.exceptions.DeploymentException:WELD-001408 Unsatisfied dependencies for type EntityManagerFactory] with qualifiers [@Default] at injection point [[field] @PersistenceUnit @Inject private rg.jbpm.executor.impl.jpa.JPAExecutorServiceProducer.emf]

                     I could not see the print statements given in the attached class constructor. Pl suggest if anything needs to be done to load these classes.

               

              Regards,

              Sundar.

              • 4. Re: Could not deploy web application with jbpm to Jboss EAP 6.1.0
                Amit Nijhawan Newbie

                I have checked the java classes shared by you, It is fine.

                Could you please share the beans.xml file?

                • 5. Re: Could not deploy web application with jbpm to Jboss EAP 6.1.0
                  Esakki Sundar Varatharajan Newbie

                  Hi Amit,

                      As I mentioned in my initial thread, our application was working fine with JBPM when deployed to Tomcat. However when we tried to deploy to Jboss issues started to creep in. As you suggested I had made the necessary CDI. Pl find attached snippet of beans.xml. Im also attaching persistence.xml. Im not sure what tweaks had to be done to these files to make it work. Pl help me.

                   

                  Regards,

                  Sundar.