5 Replies Latest reply on Sep 14, 2016 2:57 AM by Milan Kubov

    WFLYEJB0450: Entity Beans are no longer supported

    Milan Kubov Newbie

      Hi,

       

      We migrated our project to Wildfly 10.0 from jBoss5.1.0.GA and with "some" effort it was successfull to use this 15 years old project also under Wildfly 10.0.

      We are using EJB 2.1.

       

      Now I tried to use it with Wildfly 10.1 and it's no more possible, because of new error messages during the deployment 'WFLYEJB0450: Entity Beans are no longer supported':

      "{

          \"WFLYCTL0080: Failed services\" => {

              \"jboss.deployment.subunit.\\\"my_app.ear\\\".\\\"ejb-jar.jar\\\".PARSE\" => \"org.jboss.msc.service.StartException in service jboss.deployment.subunit.\\\"maportal.ear\\\".\\\"ejb-jar.jar\\\".PARSE: WFLYSRV0153: Failed to process phase PARSE of subdeployment \\\"ejb-jar.jar\\\" of deployment \\\"maportal.ear\\\"

          Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: WFLYEJB0450: Entity Beans are no longer supported, beans usersmpBean cannot be deployed\",

                ...

       

      We are using many entity beans and it's not realistic to change it.

      Is it some problem in Wildfly 10.1 in comparition with Wildfly 10.0 or is it intention?

       

      Thanx for your answers.

       

      Best Regards,

      Milan Kubov