0 Replies Latest reply on Jan 30, 2017 1:19 PM by Cheng Fang

    Upgraded minimal Java / JDK version to Java 8

    Cheng Fang Master

      The minimal Java version was just upgraded from 1.7 to 1.8 (Java 8) in project JBeret master branch.  See JIRA Issue JBERET-303 for details.

       

      This is needed in order to make use of Java 8 features, such as lamba and stream.  In addition, some of the project dependencies (e.g., infinispan 8.x) also require Java 8.

       

      Note that this does not affect 1.2.x maintenance branch, and any releases from 1.2.x series will continue supporting Java 6, 7 & 8.  All released versions in 1.3.0.x series (alpha & beta versions) will also continue support Java 6, 7 & 8.  Any future releases from 1.3.x series (1.3.0.Beta5 and later) will require Java 8 or later to build, test, and run.