6 Replies Latest reply on Apr 7, 2017 3:56 AM by paul gavoille

    [Resolved] Could not start Weld Container in DeltaSpike TestControl (Encolsing method not found)

    paul gavoille Newbie

      Hi !!

       

      My team and I recently switched from Seam 3 to DeltaSpike. And I can't manage to make the TestControl work.

      After contacting the DeltaSpike team, we decided that the question deserved to be posted here.

       

      So here it is :

      I have a minimum test case attached so you can test it.

      It's a simple Wildfly project with DeltaSpike included, I juste made a JUnit test with DeltaSpike's CdiTestRunner and get this error :

       

      org.jboss.weld.exceptions.DeploymentException: java.lang.InternalError: Enclosin - Pastebin.com

       

      The test is TestControlTest (the only test in the sources)

      Here is the DeltaSpike TestControl documentation : Test-Control Module

       

      After finding this post ( https://developer.jboss.org/thread/270123 ), I tried launching my unit test with maven instead of Eclipse (mvn clean compile test).

      Same error.

       

      Any help would be great.

      Thx in advance.