2 Replies Latest reply on Jan 8, 2018 3:26 AM by Kulbhushan Chaskar

    Setting up Teiid Designer.

    Kulbhushan Chaskar Master

      Hi

      I am trying to install Teiid Designer, for the same I am following steps from blog Installing Teiid Designer  but an update site url : http://download.jboss.org/jbosstools/updates/development/juno/soa-tooling/teiddesigner/8.0.0.Final/ is giving 404 and may be this is the case because of I am not able to install it.

       

      Also..

      Neither steps from the link Download & Install - JBoss Community  are working for me.

      e.g. @ Link: http://download.jboss.org/jbosstools/targetplatforms/jbtistarget/4.5.0.Final/jbtis/REPO/ 

      Gives o/p when trying to add update URL in Oxygen eclipse:

      Unable to read repository at http://download.jboss.org/jbosstools/targetplatforms/jbtistarget/4.5.0.Final/jbtis/REPO/content.xml.

      Unable to read repository at http://download.jboss.org/jbosstools/targetplatforms/jbtistarget/4.5.0.Final/jbtis/REPO/content.xml.

      No password provided.

      If I paste this URL in browser it returns 404

       

      Thanks,

      Kulbhushan Chaskar

        • 1. Re: Setting up Teiid Designer.
          Barry LaFond Master

          I've fixed the URL noted above. the "teiddesigner" segment is now "teiiddesigner" (i.e. missing an "i")

           

          If you really want to use Juno, the Designer versions and installation are here:  Older Downloads - JBoss Community

           

          If you don't care about Eclipse versions, I'd suggest using latest (Oxygen) and the instructions  here:  Download & Install - JBoss Community

          • 2. Re: Setting up Teiid Designer.
            Kulbhushan Chaskar Master

            Thanks Barry,

            The steps from Download & Install - JBoss Communit still not working for me I have added information for updates sites too. Please refer attached screenshot.

             

             

            Instead of URL if I try option Archive and provides Teiid designer zip file then it is giving error:

             

            Cannot complete the install because one or more required items could not be found.

              Software being installed: Teiid Designer Developer Resources 11.1.0.v20170905-2106 (org.teiid.designer.feature.source.feature.group 11.1.0.v20170905-2106)

              Missing requirement: Teiid DataTools Connectivity 11.1.0.v20170614-1904 (org.teiid.datatools.connectivity.feature.feature.group 11.1.0.v20170614-1904) requires 'org.jboss.tools.locus.sf.saxon [9.5.1,10.0.0)' but it could not be found

            Cannot satisfy dependency:

            From: Teiid Designer 11.1.0.v20170905-2106 (org.teiid.designer.feature.feature.group 11.1.0.v20170905-2106)

            To: org.teiid.datatools.connectivity.feature.feature.group [11.1.0.v20170614-1904]

            Cannot satisfy dependency:

            From: Teiid Designer Developer Resources 11.1.0.v20170905-2106 (org.teiid.designer.feature.source.feature.group 11.1.0.v20170905-2106)

            To: org.teiid.designer.feature.feature.group [11.1.0.v20170905-2106]