5 Replies Latest reply on May 13, 2002 6:45 PM by Hiram Chirino

    Jboss3.0beta JMS Jdbc persistence (Oracle) not using jaws?

    David Martinez Newbie

      Hello,

      So running the PersistenceManager with hsql seems to work fine after tweaking the misnamed DataSource depends prefix on jbossmq (it's listed as jboss.mq:service=... when it should be jboss:service=...).

      After this success I tried to set up jdbc persistence using Oracle.

      I got the connection to stuff work, but then it complains about org.jboss.mq.SpyJMSException: could not find or set up transaction table.

      If the table does not exist, the oracle error is INVALID DATATYPE. Seeing the SQL the jdbc persistence manager is generating, it is obviously because it's trying to push the hypersonic SQL OBJECT datatype (maybe it's not looking at jaws for the mappings?).

      I thought I could get away with using a blob like in the last version, but if I create the tables myself I get the same SpyJMSException (could not find or set up transaction table) with the SQLException attachment: java.sql.SQLException: ORA-00955: name is already used by an existing object. So it apparently wants to create it itself.

      Maybe it's checking for the datatype of OBJECT without looking at standardjaws.xml first to see that the mapping for java.lang.Object is indeed BLOB? I tried creating a fake OBJECT datatype on the Oracle Schema containing a single blob named object. Then I started JBoss and it created the table and connected everything properly (although I doubt it will run - haven't tried it yet) :-)

      Is there a property I can use to avoid the persistence manager trying to create the table with those exact parameters? Or should I try another Oracle datatype that would map to Object correctly? Or should I just wait until the actual release? :-)

      Anyway, just a heads-up. Magnificent Job on Jboss3 otherwise.

      Thank you,

      - David