7 Replies Latest reply on Jul 8, 2003 6:32 PM by Adrian Brock

    Client not responding to some servers

    dasfoid Newbie

      Hi, I have a major problem that I was wondering if anyone could help me out with. I am running 4 servers using Redhat 7.3, JBoss 3.4, and running on a client that is win 2k with JRE 1.4.1 and behind a firewall. We initially ran JBoss on 2 servers, no problem, then one day when our applet ran on our production server, the messages stopped being sent to the client. We monitored the server and saw that the message from the client was being read from the queue, processed correctly, then published over the topic, it was just that the client never fired the onMessage() method. We put a packet sniffer on and saw that the packets were in fact coming to the client, and everything looked normal(can anyone tell me what would be abnormal in a jboss packet, I have no idea how to tell). We then created another production machine, and loaded it up, everything worked fine. We then tried to create a production backup, but the problem came up again, and we have tried everything imaginable(we tried changing the connection from OIL to UIL, UIL2, and RMI, no luck). We even upgraded to JBoss 3.2, still nothing. When the messages are sent on the same machine, it works fine, when a client publishes on a topic directly to another client, it works fine, and when the client attatches to our current production server, it works fine, the only problem we seem to have is when the client tries to connect to these 2 servers. All the servers are running the same code, and JBoss is set up identically on both. Any suggestions as to where to look for a solution to this quandry?