6 Replies Latest reply on Apr 27, 2009 6:54 AM by Heiko Braun

    Report Server Build Dependency Issue

    Brian Marbury Newbie

      My "out of the box" maven build for the report server is missing the following artifacts:
      org.eclipse.emf:ecore:jar:2.2.2.v200702131851
      org.eclipse.emf:ecore-xmi:jar:2.2.2.v200702131851
      org.eclipse.emf:common:jar:2.2.1.v200702131851
      org.w3c:flute:jar:1.2
      org.w3c:sac:jar:1.3

      I pulled the source from
      http://anonsvn.jboss.org/repos/jbpm/projects/report-server/trunk/
      and added the the birt 2.2.2 dependency as per
      https://www.jboss.org/community/docs/DOC-13191

      Anyone know if I am missing repository(s)? I did some repo searching and didn't find the org.eclipse.emf depency versions.

      The build is using:
      central (http://repo1.maven.org/maven2),
      maven2.java.net (http://download.java.net/maven/2/),
      maven1.java.net (http://download.java.net/maven/1/),
      gwt-maven (http://gwt-maven.googlecode.com/svn/trunk/mavenrepo/),
      repository.jboss.org (http://repository.jboss.org/maven2),
      repository.codehaus.org (http://repository.codehaus.org),
      snapshots.jboss.org (http://snapshots.jboss.org/maven2)

      Thanks.