1 Reply Latest reply on Mar 19, 2003 3:59 PM by Adrian Brock

    Problem including SAR in a EAR

    mekatoka Newbie

      Hi,

      here goes my situation

      I am having an MBean that depends on one of my ejb's in the application EAR. Now whenever i hot redeploy the MBean starts throwing exceptions cuz the beans no longer exists.

      After exhaustive searching came to know that i need to inlcude the MBeans in a SAR and place the corresponding jboss-service.xml in META-INF directory of the SAR.

      Place the SAR in EAR and then add a link of SAR in the jboss-app.xml


      Here goes the files

      <jboss-app>
      <loader-repository>kom.jmx:loader=test.ear</loader-repository>

      new.sar

      </jboss-app>


      i tried .sar in both exploded and imploded formats, and also i tried including both (exploded and imploded) formats in the EAR.

      But no matter what i get

      Failed to find the module: new.sar

      Btwn, I am not sure what shud be there exactly in the <loader-repository>


      somebody please provide me with an example, is i had

      new.sar in test.ear

      Regards

      Meka Toka