1 2 Previous Next 26 Replies Latest reply on Nov 29, 2002 10:09 PM by Ken Williamson

    interest client

    pf Newbie

      I got a problem when running jboss without tomcat. I used windows xp. the output message is as follow:
      ***********************************************
      C:\jboss\examples\build>ant intro-interest-client
      Buildfile: build.xml

      validate-servlet:

      validate-jboss:

      fail_if_not_valid:

      init:
      [echo] Using JBoss directory=C:\jboss
      [echo] Using base classpath=C:\jboss\client\jboss-j2ee.jar;C:\jboss\client\
      jaas.jar;C:\jboss\client\jbosssx-client.jar;C:\jboss\client\jboss-client.jar;C:\
      jboss\client\jnp-client.jar;C:\jboss\examples\COULD_NOT_FIND_SERVLET_JAR
      [echo] Using Source directory=C:\jboss\examples
      [echo] Using Build directory=C:\jboss\examples/build-examples

      intro-interest-client:

      compile:

      interest-client:
      [java] Got context
      [java] javax.naming.ServiceUnavailableException: Connection refused: connec
      t [Root exception is java.net.ConnectException: Connection refused: connect]

      BUILD SUCCESSFUL

      Total time: 2 seconds
      ******************************************************
      what's wrong with my setup?
      Thanks a lot

        • 1. Re: interest client
          jbossobj Newbie

          A shot in the dark; was JBoss running when you compiled?

          • 2. Re: interest client
            marlon ric umali Newbie

            have u tried copying jndi.properties to your directory where you put your InterestClient? If not try it, it may just because of your jndi lookup.

            Or try this:
            ----------------------------------------------
            Properties p = new Properties();
            p.put("java.naming.factory.initial","org.jnp.interfaces.NamingContextFactory");
            p.put("java.naming.provider.url","localhost:1099");
            p.put("java.naming.factory.url.pkgs","org.jboss.naming:org.jnp.interfaces");
            // Get a naming context
            InitialContext jndiContext = new InitialContext(p);

            ------------------------------------------------------
            Replace that code to your
            InitialContext jndiContext = new InitialContext();
            on your original InterestClient.java.

            regards,
            Marlon

            • 3. Re: interest client
              rene Newbie

              Hi.

              I was wondering if you already resolved your problem.

              I have a very similar situation. I tried to run my InterestClient in my XP Home and I am getting this error message:

              [java] Got Context
              [java] javax.naming.CommunicationException [Root exception is java.rmi.ConnectionException: Connection refused to host: 152.163.0.0; nested exception is: java.net.ConnectException: Connection timed out: connection]

              If you already found a solution to this problem, could share it with me?

              Thanks,

              rene

              • 4. Re: interest client
                brandon Newbie

                I am also getting the exact same error
                =============================
                Got context
                {java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory, java.naming.provider.url=blah.com:1099, java.naming.factory.url.pkgs=org.jboss.naming}


                javax.naming.CommunicationException [Root exception is java.rmi.ConnectException: Connection refused to host: blah.com; nested exception is:
                java.net.ConnectException: Operation timed out: connect]
                ==========================
                the extra code after Got Context comes from this statement
                System.out.println(jndiContext.getEnvironment().toString());

                I was attempting to get more information and figure out why it dosn't work....
                I was getting a time out when running the client on the server (it's a FreeBSD server 4.3 Release) running Linux emmulation... I then deleted everything and re-extracted it and it worked on the server from an ssh session ... I was getting an error from the server saying it was 127.0.0.1 but got it to behave by adding -Djava.rmi.server.hostname=blah.com to run.sh now this time out problem is comming up again... the only difference between now and earlier is now I am attempting to run the client on my machine here to access the server.

                • 5. Re: interest client
                  brandon Newbie

                  a follow up, I just noticed that tcpdump dosn't show any traffic going across port 1099 when the InterestClient is run from the server but it does get traffic comming remotely, don't know if that helps

                  • 6. Re: interest client
                    Peter Len Newbie

                    I had this same problem and have updated my forum question. This is what I put:

                    After several disgusting days of no progress on this problem I finally found out why. A friend told me that the 152.163.0.0 IP Address in my error output had something to do with AOL. I don't use AOL but my pre-installed XP computer had some AOL app loaded. I guess it is there so that you can hook-up to AOL easily. Once I un-installed this piece of @#$%^, the client app ran fine.

                    • 7. Re: interest client
                      brandon Newbie

                      I wish it were that easy, I'm running FreeBSD 4.3 Release, I've downloaded the JBoss zip binary and I'm able to run it locally but not remotely, it just sits there, I know I'm getting traffic across the port 1099 cause my tcpdump shows traffic going across it but it hangs. here is a copy of the "tcpdump -X port 1099"

                      my-dialup > my-server
                      0x0000 4500 0030 5f3d 4000 6e06 4252 d1b3 d8d7 E..0_=@.n.BR....
                      0x0010 c0a8 0005 06e2 044b 017e 96cc 0000 0000 .......K.~......
                      0x0020 7002 2000 580b 0000 0204 0218 0101 0402 p...X...........

                      my-server > my-dialup
                      0x0000 4500 002c cef0 4000 4006 00a3 c0a8 0005 E..,..@.@.......
                      0x0010 d1b3 d8d7 044b 06e2 04af 146d 017e 96cd .....K.....m.~..
                      0x0020 6012 40e8 2f61 0000 0204 05b4 0000 `.@./a........

                      my-dialup > my-server
                      0x0000 4500 0028 603d 4000 6e06 415a d1b3 d8d7 E..(`=@.n.AZ....
                      0x0010 c0a8 0005 06e2 044b 017e 96cd 04af 146e .......K.~.....n
                      0x0020 5010 2180 6686 0000 0000 0000 0000 P.!.f.........

                      my-server > my-dialup
                      0x0000 4500 002c cef1 4000 4006 00a2 c0a8 0005 E..,..@.@.......
                      0x0010 d1b3 d8d7 044b 06e2 04af 146e 017e 96cd .....K.....n.~..
                      0x0020 5018 40e8 9a1f 0000 aced 0005 0000 P.@...........

                      my-dialup > my-server
                      0x0000 4500 019d cef2 4000 4006 ff2f c0a8 0005 E.....@.@../....
                      0x0010 d1b3 d8d7 044b 06e2 04af 1472 017e 96cd .....K.....r.~..
                      0x0020 5019 40e8 2c36 0000 7372 0019 6a61 7661 P.@.,6..sr..java
                      0x0030 2e72 6d69 2e4d 6172 7368 616c 6c65 644f .rmi.MarshalledO
                      0x0040 626a 6563 747c bd1e 97ed 63fc 3e02 0003 bject|....c.>...
                      0x0050 4900 I.

                      my-dialup > my-server
                      0x0000 4500 0028 0100 4000 6e06 a097 d1b3 d8d7 E..(..@.n.......
                      0x0010 c0a8 0005 06e2 044b 017e 96cd 04af 15e8 .......K.~......
                      0x0020 5010 2007 6685 0000 0000 0000 0000 P...f.........

                      my-dialup > my-server
                      0x0000 4500 0028 893d 4000 6e06 185a d1b3 d8d7 E..(.=@.n..Z....
                      0x0010 c0a8 0005 06e2 044b 017e 96cd 04af 15e8 .......K.~......
                      0x0020 5011 2007 6684 0000 0000 0000 0000 P...f.........

                      my-server > my-dialup
                      0x0000 4500 0028 cefb 4000 4006 009c c0a8 0005 E..(..@.@.......
                      0x0010 d1b3 d8d7 044b 06e2 04af 15e8 017e 96ce .....K.......~..
                      0x0020 5010 40e8 45a3 0000 0000 0000 0000 P.@.E.........

                      my ISP is earthlink but it hangs from other locations I've tried as well. I had to set the java.rmi.server.hostname variable in run.sh so jboss would know what it's name was. the example runs from an ssh session so I know it's capable of running, and it looks like it's one stupid thing that's not right. if someone can't help me fix this could someone suggest another EJB server?

                      thanks

                      • 8. Re: interest client
                        brandon Newbie

                        is anyone going to reply? is my question that stupid?

                        • 9. Re: interest client
                          Jose Luis Newbie

                          I have same problem :

                          [oracle@hefestus build]$ ant intro-interest-client
                          .
                          .
                          .
                          interest-client:
                          [java] Got context
                          [java] javax.naming.NameNotFoundException: interest not bound

                          BUILD SUCCESSFUL

                          Total time: 3 seconds
                          [oracle@hefestus build]$

                          • 10. Re: interest client
                            brandon Newbie

                            that's because you didn't deploy it (a.k.a copy the jar to the deployment directory) you can do this with ant using the command
                            ant intro-interest-deploy from the examples/build directory
                            as stated in the jboss documentation, however my problem is not that, I've gotten everything to run locally, the problem is when I try and envoke the bean remotely, it hands, connection timed out.....
                            SOMEONE HELP ME
                            !!!!!!!1

                            • 11. Re: interest client
                              Rick Poe Newbie

                              Did you have any success with the
                              "[java] javax.naming.NameNotFoundException: interest not bound" problem. I have same problem and it appears that I have deployed Jar as described. However when I run the deploy that is set up in the build.xml my messages do not mention [Auto deploy] or match the example , yet I get a " Build Successful" message. This would make sense that it was not bound if never deployed.. Any ideas would be a hlp.Thanks

                              • 12. Re: interest client
                                dries de vleeschauwer Newbie

                                in JBoss3.0 they moved the deploy dir to /server/default/deploy instead of /deploy
                                Change the build xml file deploy dir to the new one and it will deploy, but then i ran into another problem that he could not find org.jboss.logger.logging. Did not found a solution to this.

                                • 13. Re: interest client
                                  wqhhust Newbie

                                  I also have the same problem,can anyone give the answer to this common problem.

                                  I think the drawback of the document frustrate many newbies.Why nobody can post the right interest exmaple for jboss3.0,and it is a piece of cake for those who are familar with jboss,and this will motivate ,give impetus to those who are first use jboss.But the reality??

                                  • 14. Re: interest client
                                    Bruno Lowagie Newbie

                                    I think you need to add several jars to the classpath in the build.xml. I'm not sure, I'm a newbie trying to get the first example to work too...

                                    1 2 Previous Next