1 2 Previous Next 18 Replies Latest reply on Nov 11, 2008 6:19 PM by jj nn

    Cannot start Jboss

    jj nn Newbie

      Hello, I have been working for a month succesfully with JBoss, but now I can't start the server. I downloaded a clean distribution of jboss-4.2.3.GA application server, and when I try to run with the command java -jar run.jar It seems to start but I am not able to watch http://localhost:8080. When I put this address in the browser it takes thinking so it seems that something is happening but I can't see the jboss web page. I disabled my firewall and my antivirus and it happened the same. The console shows "started in" and the minutes, but it dosn't work in the browser. I have tried it from Eclipse IDE with and without jboss tools and it hungs.

      I don't know wha else I can do. does anyone have any idea of what I can do?

      Thanks in advance

        • 1. Re: Cannot start Jboss
          jaikiran pai Master

          From where are you trying to start it? Is it from the IDE or the command prompt. I would recommend starting it from the command prompt to ensure that everything is fine. To start it from the command prompt, you have to use the run.bat (or run.sh for Unix).

          • 2. Re: Cannot start Jboss
            jj nn Newbie

            Thanks for the answer. I have just tried to start it from the run.bat (I have windows XP) and it seems to start but it doen´t load localhost al 8080 port (http://localhost:8080). I have saved the output of jboss when starting and I show it here if it helps. The browser seems to hung.

            Thanks.

            ===============================================================================

            JBoss Bootstrap Environment

            JBOSS_HOME: C:\Eclipse\Mi Workspace\jboss-4.2.3.GA

            JAVA: C:\Archivos de programa\Java\jdk1.6.0_10\bin\java

            JAVA_OPTS: -Dprogram.name=run.bat -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

            CLASSPATH: C:\Archivos de programa\Java\jdk1.6.0_10\lib\tools.jar;C:\Eclipse\Mi Workspace\jboss-4.2.3.GA\bin\run.jar

            ===============================================================================

            18:47:01,953 INFO [Server] Starting JBoss (MX MicroKernel)...
            18:47:01,968 INFO [Server] Release ID: JBoss [Trinity] 4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)
            18:47:01,968 INFO [Server] Home Dir: C:\Eclipse\Mi Workspace\jboss-4.2.3.GA
            18:47:01,968 INFO [Server] Home URL: file:/C:/Eclipse/Mi Workspace/jboss-4.2.3.GA/
            18:47:01,968 INFO [Server] Patch URL: null
            18:47:01,968 INFO [Server] Server Name: default
            18:47:01,968 INFO [Server] Server Home Dir: C:\Eclipse\Mi Workspace\jboss-4.2.3.GA\server\default
            18:47:01,968 INFO [Server] Server Home URL: file:/C:/Eclipse/Mi Workspace/jboss-4.2.3.GA/server/default/
            18:47:01,968 INFO [Server] Server Log Dir: C:\Eclipse\Mi Workspace\jboss-4.2.3.GA\server\default\log
            18:47:01,968 INFO [Server] Server Temp Dir: C:\Eclipse\Mi Workspace\jboss-4.2.3.GA\server\default\tmp
            18:47:01,968 INFO [Server] Root Deployment Filename: jboss-service.xml
            18:47:03,390 INFO [ServerInfo] Java version: 1.6.0_10,Sun Microsystems Inc.
            18:47:03,390 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 11.0-b15,Sun Microsystems Inc.
            18:47:03,390 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
            18:47:04,484 INFO [Server] Core system initialized
            18:47:07,281 INFO [WebService] Using RMI server codebase: http://127.0.0.1:8083/
            18:47:07,281 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:jboss-log4j.xml
            18:47:09,781 INFO [TransactionManagerService] JBossTS Transaction Service (JTA version) - JBoss Inc.
            18:47:09,781 INFO [TransactionManagerService] Setting up property manager MBean and JMX layer
            18:47:10,218 INFO [TransactionManagerService] Starting recovery manager
            18:47:10,437 INFO [TransactionManagerService] Recovery manager started
            18:47:10,437 INFO [TransactionManagerService] Binding TransactionManager JNDI Reference
            18:47:14,140 INFO [EJB3Deployer] Starting java:comp multiplexer
            18:47:16,765 INFO [NativeServerConfig] JBoss Web Services - Native
            18:47:16,765 INFO [NativeServerConfig] jbossws-3.0.1-native-2.0.4.GA (build=200803312044)
            18:47:17,828 INFO [Embedded] Catalina naming disabled
            18:47:18,046 INFO [AprLifecycleListener] The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Archivos de programa\Java\jdk1.6.0_10\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\Archivos de programa\MiKTeX 2.5\miktex\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\wbem;C:\Archivos de programa\MATLAB\R2006b\bin;C:\Archivos de programa\MATLAB\R2006b\bin\win32;c:\matlabr11\bin;c:\archivos de programa\quicktime\qtsystem\;;C:\Archivos de programa\Archivos comunes\GTK\2.0\bin;c:\Archivos de programa\Microsoft SQL Server\90\Tools\binn\;;C:\MATLABR11\bin;;C:\Archivos de programa\SSH Communications Security\SSH Secure Shell
            18:47:18,140 INFO [Http11Protocol] Inicializando Coyote HTTP/1.1 en puerto http-127.0.0.1-8080
            18:47:18,156 INFO [AjpProtocol] Initializing Coyote AJP/1.3 on ajp-127.0.0.1-8009
            18:47:18,156 INFO [Catalina] Initialization processed in 322 ms
            18:47:18,156 INFO [StandardService] Arrancando servicio jboss.web
            18:47:18,156 INFO [StandardEngine] Starting Servlet Engine: JBossWeb/2.0.1.GA
            18:47:18,218 INFO [Catalina] Server startup in 64 ms
            18:47:18,421 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../deploy/jboss-web.deployer/ROOT.war/
            18:47:19,718 INFO [TomcatDeployer] deploy, ctxPath=/invoker, warUrl=.../deploy/http-invoker.sar/invoker.war/
            18:47:19,937 INFO [TomcatDeployer] deploy, ctxPath=/jbossws, warUrl=.../deploy/jbossws.sar/jbossws-context.war/
            18:47:20,156 INFO [TomcatDeployer] deploy, ctxPath=/jbossmq-httpil, warUrl=.../deploy/jms/jbossmq-httpil.sar/jbossmq-httpil.war/
            18:47:21,062 INFO [TomcatDeployer] deploy, ctxPath=/web-console, warUrl=.../deploy/management/console-mgr.sar/web-console.war/
            18:47:21,687 INFO [MailService] Mail Service bound to java:/Mail
            18:47:21,890 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-ha-local-jdbc.rar
            18:47:21,953 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-ha-xa-jdbc.rar
            18:47:22,000 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-local-jdbc.rar
            18:47:22,046 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-xa-jdbc.rar
            18:47:22,125 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jms/jms-ra.rar
            18:47:22,171 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/mail-ra.rar
            18:47:22,234 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/quartz-ra.rar
            18:47:22,234 INFO [QuartzResourceAdapter] start quartz!!!
            18:47:22,312 INFO [SimpleThreadPool] Job execution threads will use class loader of thread: main
            18:47:22,343 INFO [QuartzScheduler] Quartz Scheduler v.1.5.2 created.
            18:47:22,343 INFO [RAMJobStore] RAMJobStore initialized.
            18:47:22,343 INFO [StdSchedulerFactory] Quartz scheduler 'DefaultQuartzScheduler' initialized from default resource file in Quartz package: 'quartz.properties'
            18:47:22,343 INFO [StdSchedulerFactory] Quartz scheduler version: 1.5.2
            18:47:22,343 INFO [QuartzScheduler] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED started.
            18:47:23,953 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultDS' to JNDI name 'java:DefaultDS'
            18:47:24,343 INFO [A] Bound to JNDI name: queue/A
            18:47:24,343 INFO [B] Bound to JNDI name: queue/B
            18:47:24,343 INFO [C] Bound to JNDI name: queue/C
            18:47:24,343 INFO [D] Bound to JNDI name: queue/D
            18:47:24,343 INFO [ex] Bound to JNDI name: queue/ex
            18:47:24,375 INFO [testTopic] Bound to JNDI name: topic/testTopic
            18:47:24,375 INFO [securedTopic] Bound to JNDI name: topic/securedTopic
            18:47:24,375 INFO [testDurableTopic] Bound to JNDI name: topic/testDurableTopic
            18:47:24,375 INFO [testQueue] Bound to JNDI name: queue/testQueue
            18:47:24,437 INFO [UILServerILService] JBossMQ UIL service available at : /127.0.0.1:8093
            18:47:24,484 INFO [DLQ] Bound to JNDI name: queue/DLQ
            18:47:24,609 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=ConnectionFactoryBinding,name=JmsXA' to JNDI name 'java:JmsXA'
            18:47:24,765 INFO [TomcatDeployer] deploy, ctxPath=/InteContConfig, warUrl=.../deploy/InteContConfig.war/
            18:47:24,968 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../deploy/jmx-console.war/
            18:47:25,234 INFO [Http11Protocol] Arrancando Coyote HTTP/1.1 en puerto http-127.0.0.1-8080
            18:47:25,265 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
            18:47:25,312 INFO [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)] Started in 23s:328ms

            • 3. Re: Cannot start Jboss
              LeQuoc Thai Novice

              Hi all,

              After JBoss start complete, you can try again in your browser !

              • 4. Re: Cannot start Jboss
                jaikiran pai Master

                Going by the logs, the server should be available at http://localhost:8080. When you access the page, does it hang or does it show an error? Also do you have any firewalls or anti-virus running on your system, which might be blocking the requests?

                What does the following output

                telnet localhost 8080


                • 5. Re: Cannot start Jboss
                  jj nn Newbie

                  Thanks for your answer. It hangs when I set http://localhost:8080 in the browser. I have a firewall and an antivirus, but I have disabled both to try and it happened the same. I don't know what else I can do.

                  • 6. Re: Cannot start Jboss
                    jj nn Newbie

                    When I type "telnet localhost 8080" after running jboss with run.exe I get a black screen with a blinking underscore (A _ which apperas and dissapears). But it doen'st work either in the browser.

                    thanks

                    • 7. Re: Cannot start Jboss
                      Peter Johnson Master

                      Your description of what happens when you run telnet tells me that the port (8080) is open and JBossAS is listening to it.

                      I can think of only two things that could possibly be wrong.

                      1) Are you running your browser on the same system that is running JBossAS, and are you using the exact url: "http://localhost:8080"?

                      2) Have you "locked" the command prompt window by accidentally selecting some text in the window? As long as the text is selected, any attempt by an application to write to stdout will cause the application to hang until the text is unselected.

                      • 8. Re: Cannot start Jboss
                        jj nn Newbie

                        Thanks Peter for your answer, but I'm running jboss in my local PC (I have only one at home) and I have written "http://localhost:8080" in the browser (I have just copied it now from there). I haven't either selected anything in the window, and I have tried to access several times either in Internet Explorer or in Mozilla Firefox.
                        I have to say that when I try to start jboss the browser seems to hang when I try to access localhost at 8080, but when jboss is off it shows an error that this page doesn't exist, so I know that jboss is working but not properly.

                        • 9. Re: Cannot start Jboss
                          Peter Johnson Master

                          Hmm. This problems defies all logic. Here are some more things to try. Yes, they are strange, but so is the problem you are encountering.

                          1) Get both the JDK and JBossAS out of paths that have spaces in their names. I have my JDK at c:\apps\java\jdk-1.6.0_10, and JBossAS at f:\opt\jboss\jb-ss-4.2.3.GA. You do not have to re-install the JDK - just move (or copy it) and change JAVA_HOME.

                          2) There are two 4.2.3 binary downloads - one for JDK 5 and one for JDK 6. Did you get the right one?

                          3) If you have the JDK6 variant of 4.2.3, try installing and using JDK 1.6.0_07.

                          4) Try installing JDK 1.5.0.16 and the JDK 5 binary of 4.2.3, and see if that works.

                          5) Try running using "run -b 0.0.0.0". Then you can try using the URLs "http://localhost:8080" and "http://yourhostname"8080".

                          • 10. Re: Cannot start Jboss
                            jaikiran pai Master

                            This is in addition to what Peter said.

                            You mentioned that:

                            I have a firewall and an antivirus, but I have disabled both to try and it happened the same.


                            I had once observed with my local setup that even if i disable the anti-virus, for some reason the corresponding service(s) in the Windows panel were still running. So i would recommend that you check the Windows Services panel to check that the firewall, anti-virus services are indeed stopped.




                            • 11. Re: Cannot start Jboss
                              jj nn Newbie

                              Sorry Peter but none of this tests worked. I'm starting to think that something is wrong with the 8080 port of my computer. I have wrtitten netstat -an in my computer without starting jboss but there is nothing listening on this port. Is there any other port which can make any interference in jboss?
                              On the other hand I have Java JDK 6 and this jboss, and I have tried others and happen the same.

                              • 12. Re: Cannot start Jboss
                                Peter Johnson Master

                                What happens if you use these urls:

                                http://localhost:8080/jmx-console

                                http://localhost:8080/web-console

                                Also, try this. Open another command prompt at the jboss_home/bin directory and enter:

                                twiddle get "jboss.system:type=Server"

                                If none of the above works, then I would suspect something is wrong on your PC and suggest you try on anther PC. I have run JBossAS on dozens of different Windows boxes using XP, Vista, Server 2003, Server 2008, many using both 32-bit and 64-bit OSes and JVMs without a problem.

                                • 13. Re: Cannot start Jboss
                                  jj nn Newbie

                                  Hi again, thanks for your answers, but when I have tried it seem to happen the same. I have disabled the antivirus and the firewall (including services) and have gotten the same result. I have tried witrin this addreses and the comand and I got no answer.
                                  I have tried to use a program called CruiseControl which works al 8080 port as well, and it doesn't load completely, it happens the same, but there's nothing listening at port 8080. It's everything very extrange. I can't change of PC because this is the only one I have at home, and I can't format it right now.

                                  • 14. Re: Cannot start Jboss
                                    Peter Johnson Master

                                    If the twiddle command did not work, then port 1099 is also not working. This leads me to believe that none of your ports are working. Is there any other software you are using where you could try out a port. Things like IIS, Apache HTTP Server, SQL Server, MySQL?

                                    If you look at the properties of your network connection, what services are installed? This should include things such as "Client for Microsoft Networks" and "Internet Protocol (TCP/IP)". Please post a list of all of the items (please use the exact names as they appear in the properties dialog).

                                    Another thing to try is get the listdlls utility from sysinternals (http://technet.microsoft.com/en-us/sysinternals/bb896656.aspx). With JBossAS running, open a command prompt and enter "listdlls java". Post the full output.

                                    1 2 Previous Next