4 Replies Latest reply on Dec 17, 2007 8:25 PM by Scott Stark

    assembly manifest entries

    Scott Stark Master

      Why doesn't the assembly plugin support the same manifest configuration as the jar plugin? The docs for the assembly plugin refer to the jar plugin for manfiest info, but the following does not work:

       <plugin>
      
       <groupId>org.apache.maven.plugins</groupId>
      
       <artifactId>maven-assembly-plugin</artifactId>
      
       <version>2.1</version>
      
       <executions>
      
       <execution>
      
       <phase>package</phase>
      
       <goals>
      
       <goal>attached</goal>
      
       </goals>
      
       </execution>
      
       </executions>
      
       <configuration>
       <archive>
       <manifest>
       <addDefaultSpecificationEntries>true</addDefaultSpecificationEntries>
       <addDefaultImplementationEntries>true</addDefaultImplementationEntries>
       </manifest>
       </archive>
       <descriptors>
      
       <descriptor>assembly/bin.xml</descriptor>
      
       <descriptor>assembly/sources.xml</descriptor>
      
       </descriptors>
      
       </configuration>
      
       <inherited>false</inherited>
      
       </plugin>
      


      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Failed to configure plugin parameters for: org.apache.maven.plugins:maven-assembly-plugin:2.1
      
      
      
      Cause: Cannot find setter nor field in org.apache.maven.archiver.ManifestConfiguration for 'addDefaultSpecificationEntries'
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 2 seconds
      [INFO] Finished at: Sat Dec 15 08:45:45 PST 2007
      [INFO] Final Memory: 21M/293M
      [INFO] ------------------------------------------------------------------------
      [starksm@succubus security-jboss-sx]$
      
      


      why doesn't this work?