3 Replies Latest reply on Nov 21, 2008 8:55 PM by Paul Gier

    Missing integration source jars

    Scott Stark Master

      When I run the current jbossas build or do a mvn package from the thirdparty directory, I'm not seeing the source jars for the jboss/integration or jboss/profileservice-spi being added:

      [713][valkyrie: thirdparty]$ ls jboss/integration/lib/
      jboss-classloading-spi.jar jboss-integration.jar
      jboss-corba-ots-spi.jar jboss-transaction-spi.jar
      jboss-deployment-spi.jar
      [714][valkyrie: thirdparty]$ ls jboss/profileservice-spi/lib/
      jboss-profileservice-spi.jar
      


      Sources for other jars are there.

      If I run a mvn dependency:sources is shows a bunch of skipped sources:
      [INFO] Searching repository for plugin with prefix: 'dependency'.
      WAGON_VERSION: 1.0-beta-2
      [INFO] ------------------------------------------------------------------------
      [INFO] Building JBoss Application Server Thirdparty Build
      [INFO] task-segment: [dependency:sources]
      [INFO] ------------------------------------------------------------------------
      [INFO] [dependency:sources]
      [INFO]
      [INFO] The following files have been resolved:
      [INFO] none
      [INFO]
      [INFO] The following files where skipped:
      [INFO] ant:ant:java-source:sources:1.6.5
      ...
      [INFO] org.jboss.integration:jboss-integration:java-source:sources:5.0.3.GA
      [INFO] org.jboss.integration:jboss-profileservice-spi:java-source:sources:5.0.3.GA
      [INFO] org.jboss.integration:jboss-transaction-spi:java-source:sources:5.0.3.GA
      ...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 12 seconds
      [INFO] Finished at: Fri Nov 21 07:41:18 PST 2008
      [INFO] Final Memory: 27M/52M
      [INFO] ------------------------------------------------------------------------
      [716][valkyrie: thirdparty]$
      


      The sources do exist in the local repository:
      [626][valkyrie: trunk]$ ls /home/svn/repository.jboss.org/org/jboss/integration/jboss-profileservice-spi/5.0.3.GA/
      jboss-profileservice-spi-5.0.3.GA-sources.jar
      jboss-profileservice-spi-5.0.3.GA-sources.jar.md5
      jboss-profileservice-spi-5.0.3.GA-sources.jar.sha1
      jboss-profileservice-spi-5.0.3.GA.jar
      jboss-profileservice-spi-5.0.3.GA.jar.md5
      jboss-profileservice-spi-5.0.3.GA.jar.sha1
      jboss-profileservice-spi-5.0.3.GA.pom
      jboss-profileservice-spi-5.0.3.GA.pom.md5
      jboss-profileservice-spi-5.0.3.GA.pom.sha1
      



        • 1. Re: Missing integration source jars
          Paul Gier Master

          I wasn't able to reproduce the missing source jars. The integration sources and profileservice-spi sources were copied to my thirdparty directory.

          About the skipped jar messages, the maven depenency plugin will keep track of which jars it already tried to download. So when you run the dependency plugin the first time, it will try to download all dependencies, and then create a list in the target target that says whether each one was successful or not. That prevents it from continually trying to find missing jars. So the second time the dependeny plugin is run, normally all the files are skipped because they are either already downloaded or known to not be available in the repository.

          If you run "mvn clean" it will delete this cache and next time the dependency plugin will try again to download everything that is not already downloaded. Maybe this is what caused the problem you saw.

          • 2. Re: Missing integration source jars
            Scott Stark Master

            Where is the cache, in the thirdparty dir or my local maven repo?

            After I threw away all of the thirdparty contents and reran mvn package the sources are there:

            [732][valkyrie: thirdparty]$ ls jboss/integration/lib/
            jboss-classloading-spi-sources.jar jboss-deployment-spi.jar
            jboss-classloading-spi.jar jboss-integration-sources.jar
            jboss-corba-ots-spi-sources.jar jboss-integration.jar
            jboss-corba-ots-spi.jar jboss-transaction-spi-sources.jar
            jboss-deployment-spi-sources.jar jboss-transaction-spi.jar
            [733][valkyrie: thirdparty]$ ls jboss/profileservice-spi/lib/
            jboss-profileservice-spi-sources.jar jboss-profileservice-spi.jar
            [734][valkyrie: thirdparty]$
            



            • 3. Re: Missing integration source jars
              Paul Gier Master

              The cache is in the "target" directory in thirdparty.