1 Reply Latest reply on Mar 6, 2009 10:14 AM by Paul Gier

    ant version check in 4.2 branch

    Scott Stark Master

      Just running ant to build the https://svn.jboss.org/repos/jbossas/branches/Branch_4_2 its failing to recognize the ant 1.7.1 version as it does not appear to see the ant.version system property:

      BUILD FAILED
      /Users/svn/JBossAS/branches/Branch_4_2/tools/etc/buildmagic/buildmagic.ent:28: Unsupported Ant version:
      
       ${ant.version}
      
       Please install a version which is compatible with Ant 1.6.5 or 1.7.1.
      
      Total time: 1 second
      [512][valkyrie: build]$ type ant
      ant is hashed (/usr/bin/ant)
      [513][valkyrie: build]$ ant -version
      Apache Ant version 1.7.1 compiled on June 27 2008
      


      I can build with the bundled ant 1.6.5 fine.


        • 1. Re: ant version check in 4.2 branch
          Paul Gier Master

          This bug happened because of a change in the way ant handles it's version properties starting in ant 1.7. I put a fix in buildmagic a little while back to handle this but the 4_2 branch is still using the old buildmagic.

          I'm going to release a new version of buildmagic today, and I'll test the 4_2 build with ant 1.7 and this buildmagic version to make sure that it works.