1 2 Previous Next 20 Replies Latest reply on Apr 1, 2004 8:15 AM by jae

    allow ant 1.6

    jae Master

      are there any objections to updating the build to allow ant version 1.6 as well as 1.5?

        • 1. Re: allow ant 1.6
          Viet Master

          no as long as it works

          • 2. Re: allow ant 1.6
            Sherman Wood Apprentice


            I think there are some incompatibilities between buildmagic and Ant 1.6.

            I am working in Eclipse 3.0 M7, which has 1.6 as standard. One issue I had was that the "copy = filtering=yes" task seemed to have changed from the version of Ant that buildmagic uses, requiring a properties file instead of using Ant's defined properties.

            It would be godd to get feedback on this from the JBoss community.


            Sherman

            • 3. Re: allow ant 1.6
              jae Master

              hrm - what do you mean it requires a properties file?

              if you set a property using the property tag and try to pass it through the filter, it doesn't work unless the property is defined through a file?

              • 4. Re: allow ant 1.6
                Sherman Wood Apprentice


                Correct.

                Sherman

                • 5. Re: allow ant 1.6
                  jae Master

                  hrm - i find it strange that the ant folks would allow this to happen - perhaps a bug?

                  this is what i had intended to add to the buildmagic.ents file b/c i would like to be able to execute targets from w/in eclipse.

                   <property name="buildmagic.ant.baseversion.1.5" value="1.5"/>
                   <property name="buildmagic.ant.baseversion.1.6" value="1.6"/>
                  
                   <!--
                   | Add new conditions for other supported Ant versions when they
                   | become avaialble.
                   -->
                  
                   <condition property="buildmagic.ant.compatible">
                   <or>
                   <contains string="${ant.version}"
                   substring="Ant version ${buildmagic.ant.baseversion.1.5}"/>
                  
                   <contains string="${ant.version}"
                   substring="Ant version ${buildmagic.ant.baseversion.1.6}"/>
                   </or>
                   </condition>
                  


                  what do you think? should i just hold off? i can always just use this locally b/c i want to run ant from w/in eclipse.

                  the main "tools" component for jboss has this change already.

                  • 6. Re: allow ant 1.6
                    Sherman Wood Apprentice


                    Try it out. The _default:compile-resources target in targets.ent in the nukes build (for example) did not work.

                    Sherman

                    • 7. Re: allow ant 1.6
                      jae Master

                      hrm - i'll take a look at it tonight and see what i can do w/ it.

                      • 8. Re: allow ant 1.6
                        jae Master

                        i can't replicate - was there a specific module this occurs with?

                        the manifest files are being tokenized correctly, and they are set via properties (altho i can't find the filter for them).

                        • 9. Re: allow ant 1.6
                          Sherman Wood Apprentice


                          How are you testing? Using build.sh or bat uses the Ant libraries in the tools directory, not anything you have set up externally through ANT_HOME and the path.

                          My testing was failing with a raw build.xml being used in a Run Ant... in Eclipse 3.0 M7. The documentation on copy off the Ant User Manual on the Ant web site does not mention properties and filters, only the file option.

                          Sherman

                          • 10. Re: allow ant 1.6
                            jae Master

                            no - i tested using "ant" on the command line (not using the build.* files).

                            i'm still not able to replicate, even running this inside eclipse (i tested against the rss and news module) - as far as i can tell, the everything is working correctly.

                            are you trying to tokenize something specific for your module?

                            • 11. Re: allow ant 1.6
                              Dennis Przybyla Novice

                              I will try it out if that is the only change to the file that we need to make. I would like to do this to because netbeans 3.6 RC1 now uses ant 1.6.

                              So all we have to do is add

                              <property name="buildmagic.ant.baseversion.1.6" value="1.6"/>
                              to the file?

                              Dennis Przybyla

                              • 12. Re: allow ant 1.6
                                jae Master

                                you also have to update the condition statement to check for that property as well. see my earlier post, i pasted in the entire block.

                                this should be the only change that needs to occur.

                                • 13. Re: allow ant 1.6
                                  Dennis Przybyla Novice

                                  Making it look like the following worked:

                                   <!-- Make sure we have the right version of Ant -->
                                   <property name="buildmagic.ant.baseversion" value="1.5"/>
                                   <property name="buildmagic.ant.baseversion.1.6" value="1.6"/>
                                  
                                  
                                   <!--
                                   | Add new conditions for other supported Ant versions when they
                                   | become avaialble.
                                   -->
                                  
                                   <condition property="buildmagic.ant.compatible">
                                   <or>
                                   <contains string="${ant.version}" substring="Ant version ${buildmagic.ant.baseversion}"/>
                                   <contains string="${ant.version}" substring="Ant version ${buildmagic.ant.baseversion.1.6}"/>
                                   </or>
                                   </condition>
                                  


                                  Why did the and change to an or?

                                  • 14. Re: allow ant 1.6
                                    jae Master

                                    b/c it's now an or operation - check for ant 1.5 or 1.6.

                                    1 2 Previous Next