1 2 Previous Next 28 Replies Latest reply on Jun 25, 2004 5:51 PM by jae

    nukes 1.1RC1 available

    jae Master

      the first release candidate for the nukes 1.1 release is now available. you can check it out from cvs using the following tag:

      Nukes_1_1_0_RC1

      i've also made a precompiled version for mysql available here:

      http://www.scriptkitty.org/nukes-1.1.0-mysql-RC1.zip

      if you want to use a different database, you will need to check out from cvs and compile the code on your own (checking out against this tag will only pull the files for inclusion in the 1.1).

      some things to note...

      this release marks the first attempts at a "pure" cmp implementation in all modules except the core. if this is your first time setting up nukes, the ddls will handle setting up the tables required for the "core". all other modules will have their tables created upon deployment.

      if you had previously tried the news module prior to this release (this includes any of the alpha/beta releases) you should drop the tables and allow them to be re-created.

      if you have tried the downloads module since it "pure" cmp support has been added and are a postgres user, you should drop the tables and allow them to be re-created.

      pls report any problems you encounter back in this thread, so the issues can be tracked in one spot, and there aren't a ton of duplicate threads posting the same problem over or just adding "me too!" noise.

      thx and happy hunting :)

        • 1. Issues with 5/25 snapshot
          jae Master

          Just FYI, I'm testing nukes for a potential deployment and came across a few problems so far. Platform is linux, db is mysql.

          1. When running the installer, I had some problems (permissions) that required me to back up and recreate the tables. I told the installer to run the drop table scripts, but there appear to be 2 tables that don't get dropped and I got an error that they already existed.
          2. I just tried to create a quote and it supposedly worked according to the UI, but in the logs I see: 12:04:09,489 ERROR [quotes] Cannot retrieve quotes
          javax.ejb.FinderException: Find failed: java.sql.SQLException: Column not found, message from server: "Unknown column 't0_s.pn_id' in 'field list'"

          I'll report any other problems as I find them.

          Cheers.

          • 2. Re: nukes 1.1RC1 available
            jae Master

            ok - thx - i'll make the necessary updates.

            in the mean time, you can adjust the postgres.properties in build/etc to correct the sql syntax for creating the constraint.

            let me know if the table is created and everything works after that.

            • 3. Re: nukes 1.1RC1 available
              joe hobson Newbie

              I'm still using postgreSQL and was curious to see how the pure-CMP solutions are coming. I updated my whole nukes dev directory via CVS but was unable to build. Got this error...

              BUILD FAILED
              file:/home/jhobson/dev/eclipse/workspace/nukes/nukes/build.xml:128: Could not create task or type of type: ejbdoclet.
              
              Ant could not find the task or a class this task relies upon.
              


              Saw someone in a previous Nukes:Dev forum post with the same error and it looked like it was an Ant version issue. Did something get introduced lately that would require a newer version of Ant? Although i'm not immediately sure if i'm on 1.5 or 1.6, it didn't sound like it should matter. Then again, that post was from late March and I've updated fine since then.

              Any help on this one? Or is there just a new .jar file I need to find and get into my classpath?

              thanks... .joe


              • 4. Re: nukes 1.1RC1 available
                innovate Newbie

                 

                "joehobson" wrote:


                Any help on this one? Or is there just a new .jar file I need to find and get into my classpath?

                thanks... .joe


                • 5. Re: nukes 1.1RC1 available
                  innovate Newbie

                  Hello,

                  Have some troubles with the forum :-)

                  Just do a fresh checkout of nukes and you will get rid of this error. In my case, that helped.

                  I am running postreSQL 7.4.x, and I get errors because of a syntax error in auto increment of rows.


                  Regards,

                  Cyrill

                  • 6. Re: nukes 1.1RC1 available
                    jae Master

                    you need to do a fresh checkout b/c the xdoclet libraries are now obtained from a different location.

                    pls check out against the tag so you can test the release candidate.

                    • 7. Re: nukes 1.1RC1 available
                      jae Master

                      (what happenned to all the other posts in this thread from yesterday?)

                      all the issues posted about yesterday in this thread (NPE in news and error w/ watches in forums) have been fixed. update against the cvs tag or re-fetch the precompiled mysql binaries.

                      • 8. Re: nukes 1.1RC1 available
                        joe hobson Newbie

                        fyi : RedHat 8.0 / PostgreSQL 7.4.1

                        I downloaded a new CVS snapshot tonight and didn't get the xdoclet error when building this time - thanks for the tip.

                        you can check it out from cvs using the following tag: Nukes_1_1_0_RC1


                        I'm still new to CVS and was unable to figure out how to get it to only give me that branch (that's what it would be, right?). Eclipse had trouble "discovering" the branches for the nukes project under my jboss sourceforge repository setup. I'm using Eclipse 3M8 if anyone has tips on checking out projects under particular tags (if you do, i'll test and add it to the Extending Nukes page).

                        when i first built nukes i ran into an error in the nukes\build.xml file on line 274, which looked something like this...

                        <require file="${jboss.home}/server/${nukes.deploy.dir}/nukes/nukes"/>
                        <copy todir="${jboss.home}/server/${nukes.deploy.dir}/nukes/nukes">


                        i figured it was one too many nukes on there so i verified against an old snapshot, removed the extra nukes and it built fine.

                        i downloaded the whole snapshot but only deployed news, bb, faq, core components, and downloads. I hadn't tried downloads before so I went for that one right away. My thoughts and errors...


                        when adding a download category, if you leave off the description, it reloads the form but doesn't display an error.

                        adding a download works okay, but it would be nice to have an indication of which fields are required. Actually, this would be a good place to possible add a nukes CSS class for required field display so that it's consistent throughout the site. Not sure how we deal with new styles. I tend to just put a red asterik next to the field label.

                        When i attempt to rate a download (clicking on the link below the download), i get an error: Parent Category does not exist.

                        i added the MostPopularDownloads block to my right column, but all of the links to downloads are dead - looks like the wrong module in the URL (module=kingpin). Link works okay if the module in the link is changed.

                        although i did ./build.sh deploy-components under the nukes/nukes directory, i didn't get a Permissions module so i was unable to change any permissions for any other mods.



                        those are the errors I got. News worked fine for me but i didn't get a chance to try out the forums. that's about it for me this evening. I think i'll do a bit of work on displaying with JSP now. good luck with more updates... .joe


                        • 9. Re: nukes 1.1RC1 available
                          jae Master

                          thx for catching that build.xml problem. i'll fix that now.

                          all of the bugs you reported have been fixed except for the MostPopularDownloads issue. i'll take a look at that tonight. i also fixed a couple problems w/ some table columns not being null and the downloads module now gets a category created by default when the table is created.

                          i don't know if the faq module is working correctly, and won't be part of the 1.1 release.

                          you have to deploy the permissions module seperately (just run a build deploy in the permissions directory).

                          • 10. Re: nukes 1.1RC1 available
                            jae Master

                            hrm - it appears as if the downloads module is missing a way to manage user submitted items.

                            trying to add the functionality would definately cause a delay - does anyone have any opinions on a temporary stop-gap solution for this?

                            • 11. Re: nukes 1.1RC1 available
                              Howard Pearlmutter Novice

                              Jae --

                              Just stopped in my travels to plow thru all the forums and see the most recent progress... congrats on all the good results!!

                              Especially happy to see the substantial movement towards pure-CMP across the board :) Did I read it right -- that you have been moving even the core modules over??

                              Now, onto the topic of noodles -- with all that work on 1.1RC1, I'm sure you're getting hungry. I'm in Princeton now, and will start southward at the end of this week. ETA in MD could be as early as 15th, but for sure were talking about Pho before the end of the month. How about sending a mail to the addr listed in my profile; + send me your voice #. I'll send you mine once I have your email addr, and we can sync up.

                              -- Howard



                              • 12. Re: nukes 1.1RC1 available
                                Gary Cuozzo Newbie

                                Have there been any recent commits to the Nukes_1_1_0_RC1 tagged revision? I ran a cvs update this morning, but didn't show anything changing since my last update (early last week IIRC).

                                I'm interested in doing further testing on the 1.1 release. Should I checkout from HEAD? Or just wait for further changes to be commited?

                                Cheers,
                                gary.

                                • 13. Re: nukes 1.1RC1 available
                                  Viet Master

                                  I have a couple of bug fixes to do and I switched the charset encoding to UTF-8 for i18n facilities.

                                  You should definitely checkout HEAD.

                                  • 14. Re: nukes 1.1RC1 available
                                    jae Master

                                    i've promoted the tag to include julien's latest fixed for the utf-8 encoding.

                                    i've also checked in minor updates to the news to address the lack of getter/setter methods for the copyright and location member variables, and to also add a unique constraint to the "name" column on the nuke_news_topics table.

                                    those of you w/ already established schemas should create the index on their own, but i would appricate those who can test the table creation on mysql, oracle, and postgres to make sure the statements are correct.

                                    as far as the downloads module goes, i'm still working on adding in the user submissions management functionality.

                                    1 2 Previous Next