I refer the honourable gentlement I gave some moments ago:
i.e. Worry about what it does, rather than what it is called.
Call it ClassAdapter2 to adopt the wonderfully clear convention used with class loading implementations.
A good name will help you understand what it does, without having to look deep into it. A bad name will just confuse you.
Humpty dumpty will haunt me :)