1 2 Previous Next 20 Replies Latest reply on Jun 29, 2007 1:45 PM by flindet

    Couldn't install eclipse plug-ins

    Rauan Maemirov Newbie

      I'm trying to install some other plug-ins(not from Eclipse distro). Everytime he returns me exception

      JBossIDE JBossAS Adapter Feature (1.0.0.200706241629-nightly) requires plug-in "org.eclipse.wst.common.project.facet.core (1.1.0)", or equivalent.


        • 1. Re: Couldn't install eclipse plug-ins
          fabio quimbay Newbie

          Initially I use this versions, but don't works for me:

          - eclipse-SDK-3.3RC4-win32.zip
          - wtp-sdk-S-2.0RC4-200706212235.zip
          - GEF-ALL-3.3RC4.zip
          - emf-sdo-xsd-SDK-2.3.0RC4.zip
          - dtp-sdk_1.5RC4.zip
          - JBossTools-200706241629-nightly-ALL-win32.zip

          I try with the last version of this tools, and I saw the same error like you and others, well ... then, I saw this versions like at the page of the project:

          - eclipse-SDK-3.3RC3-win32.zip
          - wtp-sdk-S-2.0RC2-200706050057.zip
          - GEF-SDK-3.3RC2.zip
          - emf-sdo-xsd-SDK-2.3.0RC2.zip
          - dtp-sdk_1.5RC2.zip
          - JBossTools-200706241629-nightly-ALL-win32.zip

          and works successfully for me. You can try with these.

          • 2. Re: Couldn't install eclipse plug-ins
            Rauan Maemirov Newbie

            I'm also using this configuration from "JBoss Tools Build Result". But, anyway, it doesn't work. :(

            • 4. Re: Couldn't install eclipse plug-ins
              Holger Sachse Newbie

              Hi all,

              I would not say that I have a problem to install the plugin ins, that works. But with the start of eclipse the problems start:

              1. With the first start using an existing workspace created by pure Eclipse 3.2 I get a serious error message about not beeing able to restore the perspectives. Not the warning, a real error.

              2. As a result the newly offered 3.3 standard wizards disappear.

              3. Also the JBoss tools wizards does not appear (f.e. jPBM, SEAM etc.)

              4. A jBPM project can not be worked on as under 3.2 + jPBM editor.

              I copy the eclipse log file for further details:

              !SESSION 2007-06-26 12:02:56.593 -----------------------------------------------
              eclipse.buildId=I20070601-1539
              java.version=1.4.2_12
              java.vendor=Sun Microsystems Inc.
              BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
              Command-line arguments: -os win32 -ws win32 -arch x86 -data C:\Data\DEV_Workspace_Learn_JBoss

              !ENTRY org.eclipse.ui.workbench 4 2 2007-06-26 12:03:04.453
              !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
              !STACK 1
              org.eclipse.core.runtime.CoreException: Plug-in org.jboss.ide.eclipse.firstrun was unable to load class org.jboss.ide.eclipse.firstrun.FirstRunStartup.
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:180)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:164)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
              org.eclipse.core.runtime.CoreException[1]: java.lang.UnsupportedClassVersionError: org/jboss/ide/eclipse/firstrun/FirstRunStartup (Unsupported major.minor version 49.0)
              at java.lang.ClassLoader.defineClass0(Native Method)
              at java.lang.ClassLoader.defineClass(Unknown Source)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:161)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:501)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:471)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:430)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:413)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
              at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
              at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
              !SUBENTRY 1 org.eclipse.equinox.registry 4 1 2007-06-26 12:03:04.453
              !MESSAGE Plug-in org.jboss.ide.eclipse.firstrun was unable to load class org.jboss.ide.eclipse.firstrun.FirstRunStartup.
              !STACK 0
              java.lang.UnsupportedClassVersionError: org/jboss/ide/eclipse/firstrun/FirstRunStartup (Unsupported major.minor version 49.0)
              at java.lang.ClassLoader.defineClass0(Native Method)
              at java.lang.ClassLoader.defineClass(Unknown Source)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:161)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:501)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:471)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:430)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:413)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
              at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
              at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
              !SUBENTRY 1 org.eclipse.equinox.registry 4 1 2007-06-26 12:03:04.453
              !MESSAGE Plug-in org.jboss.ide.eclipse.firstrun was unable to load class org.jboss.ide.eclipse.firstrun.FirstRunStartup.
              !STACK 0
              java.lang.UnsupportedClassVersionError: org/jboss/ide/eclipse/firstrun/FirstRunStartup (Unsupported major.minor version 49.0)
              at java.lang.ClassLoader.defineClass0(Native Method)
              at java.lang.ClassLoader.defineClass(Unknown Source)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:161)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:501)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:471)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:430)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:413)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
              at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
              at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

              !ENTRY org.eclipse.ui 4 4 2007-06-26 12:03:04.468
              !MESSAGE Unhandled Exception

              !ENTRY org.jboss.ide.eclipse.firstrun 4 0 2007-06-26 12:03:04.468
              !MESSAGE Unable to execute early startup code for an extension
              !STACK 1
              org.eclipse.core.runtime.CoreException: Plug-in org.jboss.ide.eclipse.firstrun was unable to load class org.jboss.ide.eclipse.firstrun.FirstRunStartup.
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:180)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:164)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
              org.eclipse.core.runtime.CoreException[1]: java.lang.UnsupportedClassVersionError: org/jboss/ide/eclipse/firstrun/FirstRunStartup (Unsupported major.minor version 49.0)
              at java.lang.ClassLoader.defineClass0(Native Method)
              at java.lang.ClassLoader.defineClass(Unknown Source)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:161)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:501)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:471)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:430)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:413)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
              at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
              at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
              !SUBENTRY 1 org.eclipse.equinox.registry 4 1 2007-06-26 12:03:04.468
              !MESSAGE Plug-in org.jboss.ide.eclipse.firstrun was unable to load class org.jboss.ide.eclipse.firstrun.FirstRunStartup.
              !STACK 0
              java.lang.UnsupportedClassVersionError: org/jboss/ide/eclipse/firstrun/FirstRunStartup (Unsupported major.minor version 49.0)
              at java.lang.ClassLoader.defineClass0(Native Method)
              at java.lang.ClassLoader.defineClass(Unknown Source)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:161)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:501)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:471)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:430)
              at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:413)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
              at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
              at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
              at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
              at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
              at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
              at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
              at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
              at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:243)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:49)
              at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:239)
              at org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableExtension(EarlyStartupRunnable.java:117)
              at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
              at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190)
              at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


              • 5. Re: Couldn't install eclipse plug-ins
                Holger Sachse Newbie

                Sorry,

                I forgot to metion: I only installed the zip file metioned in the above link and in the proposed sequence.

                Regarding the workspace: I have the same problem using a fresh empty directory.

                • 6. Re: Couldn't install eclipse plug-ins
                  Rauan Maemirov Newbie

                  I did everything as in the Wiki. But there is nothing new to me. I tried to do that on other computer. It returns me

                  JBossTools (2.0.0.200706241629-nightly) requires feature "org.eclipse.jem".


                  I don't know why. All components is the same on both computers. Does anybody have the same problem?

                  • 7. Re: Couldn't install eclipse plug-ins
                    Max Rydahl Andersen Master

                    Eclipse 3.3 requires JDK 5 hence the "(Unsupported major.minor version 49.0)" message from the jdk not being able to load java5 compiled classes.

                    • 8. Re: Couldn't install eclipse plug-ins
                      Holger Sachse Newbie

                      It works now, thank you for the help.
                      It looks like that if there is a Java 1.4 version is on the system it has to be deinstalled. Even with JAVA_HOME on 5. and 6 it produced the mentioned behaviour. Only after deleting 1.4 from the machine it worked.

                      • 9. Re: Couldn't install eclipse plug-ins
                        Rauan Maemirov Newbie

                        I'm completely sured that there is the bug in JBossTools. 'Cause

                        plug-in "org.eclipse.wst.common.project.facet.core (1.1.0)"
                        is from previous releases of WTP. I guess WTP 1.5.2 or 1.5.3.

                        And this errors appears not only in update, but also when i try to disable JBoss AS. It shows the same error.
                        And why it says here that I need WTP 2.0? Could U try to fix it?

                        • 10. Re: Couldn't install eclipse plug-ins
                          Max Rydahl Andersen Master

                          JBoss Tools is for WTP 2.0 so what do you want me to fix ;)

                          Where do you see that plugin reference ? The nightly builds should only point to WTP 2/eclipse 3.3 plugins.

                          • 11. Re: Couldn't install eclipse plug-ins
                            Rauan Maemirov Newbie

                            I don't know. :)

                            But the fact is that "org.eclipse.wst.common.project.facet.core (1.1.0)" is really from previous release. I didn't find this neither in features nor in plugins of WTP 2.0.
                            Didn't U try to install something through update manager?

                            • 12. Re: Couldn't install eclipse plug-ins
                              Max Rydahl Andersen Master

                              You don't know where you see that plugin reference ? Soo how are you able to quote it ? :)


                              And no the update site is not configured to include nightly builds and hence you only see the old versions that are not migrated to WTP 2.x

                              • 13. Re: Couldn't install eclipse plug-ins
                                Jamie Cruise Newbie

                                I also get the message

                                JBossIDE JBossAS Adapter Feature (1.0.0.200706241629-nightly) requires plug-in "org.eclipse.wst.common.project.facet.core (1.1.0)", or equivalent.


                                when using help->software updates->find and install->search for new features

                                and then try and install a new feature e.g. subclipse.

                                It's a bit of a show stopper.

                                Cheers
                                Jamie

                                • 14. Re: Couldn't install eclipse plug-ins
                                  Jamie Cruise Newbie

                                  OK I fixed this by editing a couple of feature.xml files.

                                  D:\Development\Seam2\eclipse\features\org.jboss.ide.eclipse.as.feature_1.0.0.200706241629-nightly:

                                  
                                  
                                   <requires>
                                   <import plugin="org.eclipse.core.runtime"/>
                                   <import plugin="org.eclipse.debug.core"/>
                                   <import plugin="org.eclipse.core.resources"/>
                                   <import plugin="org.eclipse.jdt.launching"/>
                                   <import plugin="org.eclipse.jdt.core"/>
                                   <import plugin="org.eclipse.jst.server.core" version="1.0.102" match="equivalent"/>
                                   <import plugin="org.eclipse.jst.server.generic.core" version="1.0.100" match="equivalent"/>
                                   <import plugin="org.eclipse.wst.server.core" version="1.0.102" match="equivalent"/>
                                   <import plugin="org.eclipse.core.boot"/>
                                   <import plugin="org.eclipse.debug.ui"/>
                                   <import plugin="org.eclipse.jst.j2ee"/>
                                   <import plugin="org.eclipse.jst.j2ee.core" version="1.1.0" match="equivalent"/>
                                   <import plugin="org.eclipse.ant.ui"/>
                                   <import plugin="org.eclipse.ant.core"/>
                                   <import plugin="org.eclipse.ui.externaltools"/>
                                   <import plugin="org.eclipse.wst.common.project.facet.core" version="1.1.0" match="compatible"/>
                                   <import plugin="org.eclipse.jst.common.project.facet.core" version="1.1.0" match="compatible"/>
                                   <import plugin="org.eclipse.wst.xml.core" version="1.1.0" match="compatible"/>
                                   <import plugin="org.eclipse.ui"/>
                                   <import plugin="org.eclipse.ui.forms"/>
                                   <import plugin="org.eclipse.jst.server.ui"/>
                                   <import plugin="org.eclipse.wst.server.ui" version="1.0.102" match="compatible"/>
                                   <import plugin="org.eclipse.wst.server.ui.doc.user"/>
                                   <import plugin="org.eclipse.jst.server.generic.ui"/>
                                   <import plugin="org.eclipse.jdt.debug"/>
                                   <import plugin="org.eclipse.jdt.debug.ui"/>
                                   <import plugin="org.eclipse.ui.console"/>
                                   <import plugin="org.eclipse.text"/>
                                   <import plugin="org.eclipse.jface.text"/>
                                   <import plugin="org.eclipse.ui.views"/>
                                   <import plugin="org.eclipse.ui.editors"/>
                                   <import plugin="org.eclipse.ui.workbench.texteditor" version="3.2.0" match="compatible"/>
                                   <import plugin="org.eclipse.wst.xml.ui"/>
                                   <import plugin="org.eclipse.wst.sse.ui"/>
                                   <import plugin="org.eclipse.wst.sse.core" version="1.1.0" match="compatible"/>
                                   <import plugin="org.eclipse.jdt.ui" version="3.2.0" match="compatible"/>
                                   <import plugin="org.eclipse.core.filesystem"/>
                                   <import plugin="org.eclipse.ui.ide" version="3.2.0" match="compatible"/>
                                   <import plugin="org.eclipse.jst.server.tomcat.core"/>
                                   <import plugin="org.eclipse.jst.servlet.ui"/>
                                   <import plugin="org.eclipse.jst.j2ee.ui"/>
                                   <import plugin="org.eclipse.wst.web.ui"/>
                                   <import plugin="org.eclipse.wst.common.frameworks.ui"/>
                                   <import plugin="org.eclipse.jst.server.tomcat.ui"/>
                                   <import plugin="org.eclipse.core.variables"/>
                                   <import plugin="org.eclipse.search"/>
                                   <import plugin="org.eclipse.jst.ws"/>
                                   <import plugin="org.eclipse.jst.ws.ui"/>
                                   <import plugin="org.eclipse.jst.ws.consumption"/>
                                   <import plugin="org.eclipse.jst.ws.consumption.ui"/>
                                   <import plugin="org.eclipse.jst.ws.axis.creation.ui"/>
                                   <import plugin="org.eclipse.wst.ws"/>
                                   <import plugin="org.eclipse.wst.ws.ui"/>
                                   <import plugin="org.jboss.ide.eclipse.firstrun"/>
                                   </requires>
                                  


                                  note the changes of match="equivalent" to match="compatible"

                                  also removed the org.eclipse.jem import element from D:\Development\Seam2\eclipse\features\org.jboss.ide.eclipse.feature_2.0.0.200706241629-nightly

                                  Don't know if my environment will now disappear in a puff of smoke when I do any serious work. But at least I can checkout my code from subversion now :)

                                  Cheers
                                  J


                                  1 2 Previous Next