7 Replies Latest reply on Nov 14, 2009 7:06 PM by Michael Strong

    SeamResourceServlet and SeamListener Problem

    Michael Strong Newbie

      THIS IS NOT A CROSS POST :o) The Seam forum recommended that I move my question to this forum. :o)

      I have read other posts that included references to these two classes; however, I was unable to find my situation (at least not recognize the similarity).

      I have a very simple, JBoss Tools wizard generated Seam Project (my first). I have a simple Seam entity bean wizard generated bean, along with it's accompanying xhtml page and session bean. I added a couple more fields to the entity and updated the corresponding xhtml.

      When I click publish and start in the JBoss Server tab, the deployment fails because these two classes cannot be found or loaded.

      15:28:24,984 WARN [JAXWSDeployerHookPreJSE] Cannot load servlet class: org.jboss.seam.servlet.SeamResourceServlet
      15:28:24,998 INFO [TomcatDeployment] deploy, ctxPath=/RaisedInAmerica
      15:28:25,048 ERROR [[/RaisedInAmerica]] Error configuring application listener of class org.jboss.seam.servlet.SeamListener
      java.lang.ClassNotFoundException: org.jboss.seam.servlet.SeamListener


      I do not want to bludgeon you with a bunch of context that you do NOT want. So, please, let me know what else about my project you'd like to see to help me sleuth this.

      Again, searching all of Google and this forum have left me still stuck.

      Thank you, in advance, to any kind readers who want to give an old dog trying to learn new tricks a nudge.

      Regards,

      Mike