1 2 Previous Next 16 Replies Latest reply on Apr 10, 2012 6:12 PM by Tony Kaska

    PicketLink Console for JBoss AS 7

    Pedro Igor Master

      Hi All,


          The PicketLink Console for JBoss AS7 is available.


          This console aims to provide a UI to manage all PicketLink configurations. It is still under development supporting just a small set of configurations.


          We would appreciate your sugestions and feedback about the current and new features. It is just a start, the objective is to show you the idea behind the console and gather all feedback as possible to make even easier to use and manage PicketLink resources and configurations.


          For more informations, see https://community.jboss.org/wiki/PicketLinkConsoleForJBossAS7.



      Pedro Igor

        • 1. Re: PicketLink Console for JBoss AS 7
          Tony Kaska Newbie

          I had Jboss 7.1.1 installaed and your PicketLink 2.0.3 on top of it. Then unzipped the attached as7-subsystem-config.tar.gz to the JBoss root directory per your instruction. It overwrote many module files. But when I start the application I get the following fatal error.


          This is for your information. Thank you.


          Calling "C:\jboss\jb711pl203\bin\standalone.conf.bat"




            JBoss Bootstrap Environment



            JBOSS_HOME: C:\jboss\jb711pl203



            JAVA: C:\jdk6\bin\java



            JAVA_OPTS: -XX:+TieredCompilation -Dprogram.name=standalone.bat -Xms64M -Xmx51

          2M -XX:MaxPermSize=256M -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.se

          rver.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.war

          ning=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djboss.server.default.c







          16:05:36,051 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA

          16:05:36,204 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA

          16:05:36,255 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" sta


          16:05:36,646 ERROR [org.jboss.as.server] JBAS015956: Caught exception during boo

          t: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS01

          4676: Failed to parse configuration

                  at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(Xm

          lConfigurationPersister.java:141) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Fin


                  at org.jboss.as.server.ServerService.boot(ServerService.java:266) [jboss


                  at org.jboss.as.controller.AbstractControllerService$1.run(AbstractContr

          ollerService.java:155) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]

          Caused by: javax.xml.stream.XMLStreamException: Failed to load module org.picket


                  at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(Extensio

          nXml.java:154) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_1(Stand

          aloneXml.java:305) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.j

          ava:127) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.j

          ava:100) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:1

          10) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                  at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:6

          9) [staxmapper-1.1.0.Final.jar:1.1.0.Final]

                  at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(Xm

          lConfigurationPersister.java:133) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Fin


                  ... 3 more

          Caused by: java.util.concurrent.ExecutionException: javax.xml.stream.XMLStreamEx

          ception: JBAS014674: Failed to load module

                  at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222) [r


                  at java.util.concurrent.FutureTask.get(FutureTask.java:83) [rt.jar:1.6.0


                  at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(Extensio

          nXml.java:146) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  ... 9 more

          Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load modul


                  at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.

          java:195) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.as.controller.parsing.ExtensionXml.access$000(ExtensionXml.

          java:68) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java

          :126) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java

          :123) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [r


                  at java.util.concurrent.FutureTask.run(FutureTask.java:138) [rt.jar:1.6.


                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExec

          utor.java:886) [rt.jar:1.6.0_31]

                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor

          .java:908) [rt.jar:1.6.0_31]

                  at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]

                  at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-thread


          Caused by: org.jboss.modules.ModuleLoadException: Error loading module from C:\j


                  at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java

          :292) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java

          :242) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.LocalModuleLoader.parseModuleInfoFile(LocalModuleLo

          ader.java:138) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java

          :122) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)


                  at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [


                  at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.j

          ava:94) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:204) [jbo


                  at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.

          java:177) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]

                  ... 9 more

          Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[27,63]

          Message: Failed to add resource root 'picketlink-fed-2.0.2.Final.jar' at path 'p


                  at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.j

          ava:898) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java

          :854) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser

          .java:676) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:

          548) [jboss-modules.jar:1.1.1.GA]

                  at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java

          :287) [jboss-modules.jar:1.1.1.GA]

                  ... 17 more



          16:05:36,718 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in a

          n unrecoverable manner; exiting. See previous messages for details.

          16:05:36,727 INFO  [org.jboss.as] JBAS015950: JBoss AS 7.1.1.Final "Brontes" sto

          pped in 3ms

          Press any key to continue . . .

          • 2. Re: PicketLink Console for JBoss AS 7
            Pedro Igor Master

            Hi Tony,


                The as7-subsystem-config.tar.gz file assumes that you are using PicketLink 2.0.2.Final. This is the official version shipped with JBoss AS 7.1.1.Final.


                I think you have downloaded the custom JBoss AS 7.1.1.Final updated with PicketLink 2.0.3. So, you have two options:


                       1) Update the ${jboss.home.dir}/modules/org/picketlink/main/module.xml to use the 2.0.3 jar files (or use the file attached in this thread);

                       2) Download the official distribution of the JBoss AS 7.1.1.Final (http://www.jboss.org/jbossas/downloads/);



            Pedro Igor

            • 3. Re: PicketLink Console for JBoss AS 7
              Tony Kaska Newbie



              Thank you. Yes I was using PicketLink 2.0.3. But I followed your option 2 suggestion. It works for me now. Previously I could not get the sample war files to run on JBoss AS 7.1.1 with PicktLink 2.0.2. Whereas I was able to run JBoss AS 7.1.0 and Picket Link 2.0.2. But now with the approach suggested I am able to run JBoss AS 7.1.1 and PicketLink 2.0.2. But I only tried the idp.war and sales.war as suggested by the article so far. I was able to open the PicketLink profile. I was able to see the Federation section. But I was not able to see the IDP and SP sections mentioned in the documentation. I am wondering if I am missing something or doing something wrong.


              Thank you.



              • 4. Re: PicketLink Console for JBoss AS 7
                Pedro Igor Master

                Hi Tony,


                    Please, try to download the file as7-subsystem-config.tar.gz and install it again.


                    I think you are the first to start using the console, thanks for the feedbacks. Be free to contribute with ideas and suggestions.



                Pedro Igor

                • 5. Re: PicketLink Console for JBoss AS 7
                  Pedro Igor Master

                  I did not mencion that this version of the console was only compiled to  Firefox. Please use it to access the console.


                  As you read, the console is based on AS7 Console and to reduce the number of permutations (and consequently have a small package) it is compiled only for this browser and for the english language.



                  Pedro Igor

                  • 6. Re: PicketLink Console for JBoss AS 7
                    Tony Kaska Newbie



                    I originally tried it with Chrome. So I could not see IdP or SP tabs. When I try it in Firefox I am able to see General, IDP and SP tabs. I am able to see all the right things I would expect to see in those two tabs. I just wanted to send you a quick note that it is working in Firefox. I will try to play more and update.


                    Let me know if you want me test any thing specific.


                    Thank you.



                    • 7. Re: PicketLink Console for JBoss AS 7
                      Tony Kaska Newbie



                      Can you give me some pointers to go further with PicketLink IDP and SP. I would like have a MySQL database data store for the users and roles for the IdP. I would like to have my JEE6 application to be SP. I am looking for a sample code or any documentation to get started on this. I appreciate any help you can give me on this. Thank you.



                      • 8. Re: PicketLink Console for JBoss AS 7
                        Pedro Igor Master

                        Hi Tony,


                            The IDP uses JAAS during the authentication process. I think It is a matter of which LoginModule implementation you want. If you want to use a database as an identity store, there is an out-of-box LoginModule called org.jboss.security.auth.spi.DatabaseServerLoginModule. If you want to use a LDAP identity store there is also another implementation.


                            You can also create a custom LoginModule to do what ever you want to ....


                            Take a look at this documentation: http://docs.jboss.org/jbosssecurity/docs/6.0/security_guide/html/Login_Modules.html.



                        Pedro Igor

                        • 9. Re: PicketLink Console for JBoss AS 7
                          Tony Kaska Newbie



                          Thank you for the great pointers.


                          I will work with them. Thank you again.



                          • 10. Re: PicketLink Console for JBoss AS 7
                            Pedro Igor Master

                            By the way,


                                There is a new version of the console. With a new layout. See the comments in https://community.jboss.org/wiki/PicketLinkConsoleForJBossAS7#comment-9608.


                                Next time you post  a question, can you create a new discussion when the subject is not about the console ?



                            Pedro Igor

                            • 11. Re: PicketLink Console for JBoss AS 7
                              Tony Kaska Newbie


                              Yes I agree. It makes perfect sense to limit only console specific questions in this thread. My apologies for corrupting it little bit. As a matter of fact I have created a separate thread with a question. Now, coming to the new console version. Also I did more tests on the previous version after my post. I will try to explain what remains the same and what is different.

                              1. When I go to the Federation tab from Picket Link once I am in Profile, the page is not updating for the first time. It just stays in the current page showing the details of JDBC database connection. Might make people to wonder nothing happening when they try the Federation link first time.  Actually I faced the same problem with chrome in the last version also. We assumed it Chrome specific. But I am able to consistently reproduce it in Firefox both in old and new version. I need to kind of refresh the page couple of times to get the actual screen specific to Federation.
                              2. I see you have the View Link now which takes you a tabbed view for IDP and SPs. (In previous versions you could see all that tabs in Federation link itself). Of course this approach also works.
                              3. I am able to go to IDP and SP tabs and I am seeing what I would expect to see. No issues here. As a matter of fact in SP section, you have the right URL for Sales.war. In the previous version it was not correct. It just had sales.war instead of the actual URL. (I think it is just what user can enter. Just a side note)
                              4. I also added another SP with emoployee.war. It added as expected. No problem there either. (It also worked in the previous version the same way).
                              5. Just for the sake of completion, I want to let you know the last version also worked in Chrome. The same way like Firefox. (First time the page will not update). I tested this version also in Chrome. It throws an error or warning when you first try to get into admin portal. (GWT error sighting incompatibility from Safari version). If you ignore and continue it works like Firefox.

                              Though not related to the console, I just want to share few more observation I have when I tested IDP and Sales.

                              Sales.war part works as expected. I am not able to see any problem.

                              Once I log in to sales, I am able to navigate to  idp without login which is good.

                              But in the IdP page, when I see the listed applications sales and employees, when I try those links it is not going to sales page. It is gives an error page not found. (Link is trying to jump to page sales-saml11 which is not present)

                              Employee.war does not work at all. Of course the instruction says it might not work.

                              Hope this helps. Let me know if you want to check anything specifically. Thanks.



                              • 12. Re: PicketLink Console for JBoss AS 7
                                Pedro Igor Master

                                Hi Tony,


                                    First of all thanks for the feedbacks. You are helping a lot


                                    A new version is available for download. Given the changes, the package is not attached in the article anymore. Here are the major changes:


                                         - Code refactoring to use the new AS7 extension mechanism. As you can see, the project structure has changed;

                                         - Added some validations when configuring the IDP and SPs;

                                         - Now the restart of the applications (IDPs and SPs) are optional. The user can force a restart clicking on a link

                                         - Fixed some bugs when removing a federation and trying to create a new one with the same IDP used before

                                         - Documentation was updated. I reorganized the pages too.

                                         - Updated the employee.war.

                                         - I think the "first access" bug you reported is now fixed. If you still have problems with this, please tell me. 


                                    A 1.0.Final version should be released soon.


                                Thanks again,

                                Pedro Igor

                                • 13. Re: PicketLink Console for JBoss AS 7
                                  Tony Kaska Newbie

                                  Happy to be of help. Where can I find the download now? Is the link below the right one? Please advise. Thanks.



                                  • 14. Re: PicketLink Console for JBoss AS 7
                                    Tony Kaska Newbie

                                    First access bug seems to be addressed. I do not see it.


                                    Restart works.


                                    Employee.war is working. (I am able to see the cartoon of the day)


                                    Looks pretty good so far.


                                    However, the annoying message when you start in Chrome still happens. But if you just go past the message everything works in chrome. So if you can remove that message you can assume you are supporting Chrome browser also as much as I can tell.

                                    1 2 Previous Next