3 Replies Latest reply on Nov 19, 2013 3:39 PM by Ramesh Reddy

    Issue with data source creation TEIID70006 JBAS010477: At least one of ARCHIVE or MODULE is required

    ravi katkar Newbie

      I am facing issue while creating the data source below is the steps to reproduce  .

       

      1. I have added the data source thorugh teiid admin api  , its successfully added the data source
      2. I have deleted the data source through the teiid admin api , its successfully deleted
      3. When I try to add datasource ( adding the same data source which I have deleted earlier )  teiid admin api (createdatasource)  is throwing below error.

       

      ETJCF010E Error occured while adding the data source ERROR msg :TEIID70006 JBAS010477: At least one of ARCHIVE or MODULE is required

      below is the environment details :

       

      teiid version : 8.5

       

      jboss : EAP 6.1aplha

       

      the data source :

       

      <?xml version="1.0" encoding="UTF-8"?>

      <connection-factories>

         <no-tx-connection-factory>

            <jndi-name>test-ds</jndi-name>

             <rar-name>teiid-connector-file.rar</rar-name>

                 <connection-definition>org.teiid.resource.adapter.file.FileManagedConnectionFactory</connection-definition>                  

            <config-property name="ParentDirectory"

                     type="java.lang.String">/data/</config-property>           

          </no-tx-connection-factory>

      </connection-factories>

       

      thanks,

      Ravi katkar