1 Reply Latest reply on Jul 22, 2015 12:36 PM by Steven Hawkins

    Teiid 8.11.1 error "version not set" on vdb

    gadeyne.bram Master

      Hi,

       

      I've installed a server instance with teiid 8.11.1.

       

      It seems like the datasources etc are correctly loaded but when it reaches the vdb (named vdb3) the following error occurs:

       

      14:25:27,080 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3)  MSC000001: Failed to stservice jboss.teiid.vdb.vdb3.1: org.jboss.msc.service.StartException in service jboss.teiid.vdb.v1: Failed to start service

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1 [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.ja7.0_25]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.ja7.0_25]

              at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]

      Caused by: java.lang.IllegalStateException: version not set

              at org.teiid.translator.jdbc.JDBCExecutionFactory.getVersion(JDBCExecutionFactory.java:16

              at org.teiid.translator.jdbc.postgresql.PostgreSQLExecutionFactory.start(PostgreSQLExecutactory.java:136)

              at org.teiid.deployers.TranslatorUtil.buildExecutionFactory(TranslatorUtil.java:127)

              at org.teiid.jboss.VDBService.getExecutionFactory(VDBService.java:318)

              at org.teiid.jboss.VDBService$5.getExecutionFactory(VDBService.java:290)

              at org.teiid.dqp.internal.datamgr.ConnectorManagerRepository.createConnectorManager(ConneManagerRepository.java:134)

              at org.teiid.dqp.internal.datamgr.ConnectorManagerRepository.createConnectorManagers(ConnrManagerRepository.java:108)

              at org.teiid.jboss.VDBService.createConnectorManagers(VDBService.java:294)

              at org.teiid.jboss.VDBService.start(VDBService.java:128)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImava:1980) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1 [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

              ... 3 more

       

      The vdb was created with designer version 8. And worked in Teiid 8.9.1.When I look in teiiddesigner I see that version is set to 1.

       

      With kind regards