9 Replies Latest reply on Jan 11, 2016 7:22 AM by Marco Ardito

    Datasource disconnects, needs manual flush to work again. What should I do?

    Marco Ardito Master

      I always studied/tested teiid servers locally, starting the local AS, played with DS, VDBs, testet with Squirrel (jdbc) and msaccess (odbc), I learned the basics, and now I wish to move in an "always on" lan server. Now I have a teiid server (latest "8.12.3 With EAP") in the lan (on debian), and I'm testing it with same datasources and simple VDBs.

       

      Everything works, as it did locally, but I have a problem about datasource disconnections/reconnections.

       

      I have basically two test DS, one to a lan MSSQL server and another to a lan MYSQL server.

       

      After the first night, I tested again with Squirrel could query a simple VBD to MSSQL, while it could not query a simple VDB to MYSQL.

      I had errors that referred errors like TEIID30504, teiid SQLState: 50000, ErrorCode: 30504

       

      I digged the teiid web admin console, tried to reload the VDB and found the problem to be that the connection was not active anymore.

      "TEIID11010 com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: No operations allowed after connection closed."

       

      I've found that sometimes I need to flush the datasource (manually from the teiid web console), and everything works again imediately...

      I can reproduce this, killing the connection on the MYSQL server (from the teiid server).

       

      Sometimes also flush is not enough, and happens:

      "TEIID11010 com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

      The last packet successfully received from the server was 1.284.760 milliseconds ago.  The last packet sent successfully to the server was 0 milliseconds ago."

       

      This I can only solved by disabiling/re-enabling the DS.

       

      What should I do? What I do wrong? What useful can I post here for you to help me ? Thanks.

       

      Marco